summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-07-27 16:18:47 +0800
committerArmin Kuster <akuster808@gmail.com>2017-08-13 08:26:14 -0700
commit2f30963b822b508bf53795950ea6e8198f464807 (patch)
treef450be82d07421c54eb295230bfb33ebc4fdb626
parent91467868aa1c697d71bbc38660ed34a44f04d306 (diff)
downloadmeta-security-2f30963b822b508bf53795950ea6e8198f464807.tar.gz
nmap: upgrade to 7.50
- Add a patch to fix python library install dir for multilib. - Add a patch to fix race condition with mkdir command. - Inherit pythonnative instead of python-dir and install python modules for ndiff to fix the following errors: """ root@qemux86-64:~# ndiff --help -sh: /usr/bin/ndiff: /path_to_build/tmp/hosttools/python: bad interpreter: No such file or directory root@qemux86-64:~# python /usr/bin/ndiff Could not import the ndiff module: 'No module named ndiff'. """ Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/nmap/files/nmap-redefine-the-python-library-dir.patch37
-rw-r--r--recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch48
-rw-r--r--recipes-security/nmap/nmap_7.50.bb (renamed from recipes-security/nmap/nmap_7.31.bb)23
3 files changed, 97 insertions, 11 deletions
diff --git a/recipes-security/nmap/files/nmap-redefine-the-python-library-dir.patch b/recipes-security/nmap/files/nmap-redefine-the-python-library-dir.patch
new file mode 100644
index 0000000..356b507
--- /dev/null
+++ b/recipes-security/nmap/files/nmap-redefine-the-python-library-dir.patch
@@ -0,0 +1,37 @@
1[PATCH] redefine the python library install dir
2
3Upstream-Status: Pending
4
5If install-lib is not defined, it is always /usr/lib/, but it
6maybe /usr/lib64 for multilib
7
8Signed-off-by: Roy Li <rongqing.li@windriver.com>
9---
10 Makefile.in | 4 ++--
11 1 file changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/Makefile.in b/Makefile.in
14index 1bb062c..cced2fb 100644
15--- a/Makefile.in
16+++ b/Makefile.in
17@@ -311,7 +311,7 @@ build-zenmap: $(ZENMAPDIR)/setup.py $(ZENMAPDIR)/zenmapCore/Version.py
18
19 install-zenmap: $(ZENMAPDIR)/setup.py
20 $(INSTALL) -d $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
21- cd $(ZENMAPDIR) && $(PYTHON) setup.py --quiet install --prefix "$(prefix)" --force $(if $(DESTDIR),--root "$(DESTDIR)")
22+ cd $(ZENMAPDIR) && $(PYTHON) setup.py --quiet install --prefix "$(prefix)" --install-lib="${PYTHON_SITEPACKAGES_DIR}" --force $(if $(DESTDIR),--root "$(DESTDIR)")
23 $(INSTALL) -c -m 644 docs/zenmap.1 $(DESTDIR)$(mandir)/man1/
24 # Create a symlink from nmapfe to zenmap if nmapfe doesn't exist or is
25 # already a link.
26@@ -328,7 +328,7 @@ build-nping: $(NPINGDIR)/Makefile nbase_build nsock_build netutil_build $(NPINGD
27 @cd $(NPINGDIR) && $(MAKE)
28
29 install-ndiff:
30- cd $(NDIFFDIR) && $(PYTHON) setup.py install --prefix "$(prefix)" $(if $(DESTDIR),--root "$(DESTDIR)")
31+ cd $(NDIFFDIR) && $(PYTHON) setup.py install --prefix "$(prefix)" --install-lib="${PYTHON_SITEPACKAGES_DIR}" $(if $(DESTDIR),--root "$(DESTDIR)")
32
33 NSE_FILES = scripts/script.db scripts/*.nse
34 NSE_LIB_LUA_FILES = nselib/*.lua nselib/*.luadoc
35--
361.9.1
37
diff --git a/recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch b/recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch
new file mode 100644
index 0000000..cfe043a
--- /dev/null
+++ b/recipes-security/nmap/files/nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch
@@ -0,0 +1,48 @@
1[PATCH] replace "./shtool mkdir" with coreutils mkdir command
2
3Upstream-Status: Pending
4
5"./shtool mkdir" is used when mkdir has not -p parameter, but mkdir in today
6most release has supportted the -p parameter, not need to use shtool, and it
7can not fix the race if two process are running mkdir to create same dir
8
9Signed-off-by: Roy Li <rongqing.li@windriver.com>
10---
11 ncat/Makefile.in | 4 ++--
12 nmap-update/Makefile.in | 2 +-
13 2 files changed, 3 insertions(+), 3 deletions(-)
14
15diff --git a/ncat/Makefile.in b/ncat/Makefile.in
16index cfd306d..2166e08 100644
17--- a/ncat/Makefile.in
18+++ b/ncat/Makefile.in
19@@ -163,11 +163,11 @@ $(NSOCKDIR)/libnsock.a: $(NSOCKDIR)/Makefile
20
21 install: $(TARGET)
22 @echo Installing Ncat;
23- $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
24+ mkdir -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
25 $(INSTALL) -c -m 755 ncat $(DESTDIR)$(bindir)/ncat
26 $(STRIP) -x $(DESTDIR)$(bindir)/ncat
27 if [ -n "$(DATAFILES)" ]; then \
28- $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(pkgdatadir); \
29+ mkdir -p -m 755 $(DESTDIR)$(pkgdatadir); \
30 $(INSTALL) -c -m 644 $(DATAFILES) $(DESTDIR)$(pkgdatadir)/; \
31 fi
32 $(INSTALL) -c -m 644 docs/$(TARGET).1 $(DESTDIR)$(mandir)/man1/$(TARGET).1
33diff --git a/nmap-update/Makefile.in b/nmap-update/Makefile.in
34index 89ff928..93f48d8 100644
35--- a/nmap-update/Makefile.in
36+++ b/nmap-update/Makefile.in
37@@ -37,7 +37,7 @@ $(NBASELIB):
38 cd $(NBASEDIR) && $(MAKE)
39
40 install: nmap-update
41- $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
42+ mkdir -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
43 $(INSTALL) -c -m 755 nmap-update $(DESTDIR)$(bindir)
44 $(STRIP) -x $(DESTDIR)$(bindir)/nmap-update
45 $(INSTALL) -c -m 644 ../docs/nmap-update.1 $(DESTDIR)$(mandir)/man1/
46--
471.9.1
48
diff --git a/recipes-security/nmap/nmap_7.31.bb b/recipes-security/nmap/nmap_7.50.bb
index c50b240..30ae06f 100644
--- a/recipes-security/nmap/nmap_7.31.bb
+++ b/recipes-security/nmap/nmap_7.50.bb
@@ -3,14 +3,17 @@ DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utili
3SECTION = "security" 3SECTION = "security"
4LICENSE = "GPL-2.0" 4LICENSE = "GPL-2.0"
5 5
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=bce7593e567a4b12f60c6a04f9b8c1e5" 6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=87c6956e28c3603a0a1dda11bcdc227a"
7 7
8SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2" 8SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \
9 file://nmap-redefine-the-python-library-dir.patch \
10 file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \
11"
9 12
10SRC_URI[md5sum] = "f2f6660142a777862342a58cc54258ea" 13SRC_URI[md5sum] = "435c7e095bdd4565e0f69c41743a45be"
11SRC_URI[sha256sum] = "cb9f4e03c0771c709cd47dc8fc6ac3421eadbdd313f0aae52276829290583842" 14SRC_URI[sha256sum] = "e9a96a8e02bfc9e80c617932acc61112c23089521ee7d6b1502ecf8e3b1674b2"
12 15
13inherit autotools-brokensep pkgconfig python-dir distro_features_check 16inherit autotools-brokensep pkgconfig pythonnative distro_features_check
14 17
15PACKAGECONFIG ?= "ncat nping ndiff pcap" 18PACKAGECONFIG ?= "ncat nping ndiff pcap"
16PACKAGECONFIG += " ${@bb.utils.contains('IMAGE_FEATURES', 'x11-base', 'zenmap', '', d)}" 19PACKAGECONFIG += " ${@bb.utils.contains('IMAGE_FEATURES', 'x11-base', 'zenmap', '', d)}"
@@ -22,7 +25,7 @@ PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, op
22#disable/enable packages 25#disable/enable packages
23PACKAGECONFIG[nping] = ",--without-nping," 26PACKAGECONFIG[nping] = ",--without-nping,"
24PACKAGECONFIG[ncat] = ",--without-ncat," 27PACKAGECONFIG[ncat] = ",--without-ncat,"
25PACKAGECONFIG[ndiff] = ",--without-ndiff," 28PACKAGECONFIG[ndiff] = ",--without-ndiff,python"
26PACKAGECONFIG[update] = ",--without-nmap-update," 29PACKAGECONFIG[update] = ",--without-nmap-update,"
27 30
28#Add gui 31#Add gui
@@ -30,6 +33,8 @@ PACKAGECONFIG[zenmap] = "--with-zenmap, --without-zenmap, gtk+ python-core pytho
30 33
31EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included" 34EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included"
32 35
36export PYTHON_SITEPACKAGES_DIR
37
33do_configure() { 38do_configure() {
34 # strip hard coded python2# 39 # strip hard coded python2#
35 sed -i -e 's=python2\.*=python=g' ${S}/configure.ac 40 sed -i -e 's=python2\.*=python=g' ${S}/configure.ac
@@ -38,13 +43,9 @@ do_configure() {
38 oe_runconf 43 oe_runconf
39} 44}
40 45
41do_install_append () {
42 # remove python dir, its not used or installed
43 rm -fr ${D}/${libdir}
44}
45
46PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'zenmap', '${PN}-zenmap', '', d)}" 46PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'zenmap', '${PN}-zenmap', '', d)}"
47 47
48FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
48FILES_${PN}-zenmap = "${@bb.utils.contains("PACKAGECONFIG", "zenmap", "${bindir}/*zenmap ${bindir}/xnmap ${datadir}/applications/* ${bindir}/nmapfe ${datadir}/zenmap/* ${PYTHON_SITEPACKAGES_DIR}/radialnet/* ${PYTHON_SITEPACKAGES_DIR}/zenmap*", "", d)}" 49FILES_${PN}-zenmap = "${@bb.utils.contains("PACKAGECONFIG", "zenmap", "${bindir}/*zenmap ${bindir}/xnmap ${datadir}/applications/* ${bindir}/nmapfe ${datadir}/zenmap/* ${PYTHON_SITEPACKAGES_DIR}/radialnet/* ${PYTHON_SITEPACKAGES_DIR}/zenmap*", "", d)}"
49 50
50RDEPENDS_${PN} = "python" 51RDEPENDS_${PN} = "python"