summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2019-03-30 09:57:19 -0700
committerArmin Kuster <akuster808@gmail.com>2019-03-31 10:37:09 -0700
commit6d3aa03272b9472bd8e48baf4f45b78c09715f38 (patch)
tree8b0c31a30a502288c39053b80d962db94787a44b
parentf1f54b94ad886365330f2a92e12793d7a67c34d4 (diff)
downloadmeta-security-6d3aa03272b9472bd8e48baf4f45b78c09715f38.tar.gz
clamav: drop llvm version setting
There is only one llvm and its in core so drop allowing it to be overwritten. We can hardcode it now. Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/clamav/clamav_0.99.4.bb10
1 files changed, 3 insertions, 7 deletions
diff --git a/recipes-security/clamav/clamav_0.99.4.bb b/recipes-security/clamav/clamav_0.99.4.bb
index 1d09ba6..6219d9e 100644
--- a/recipes-security/clamav/clamav_0.99.4.bb
+++ b/recipes-security/clamav/clamav_0.99.4.bb
@@ -31,17 +31,13 @@ GID = "clamav"
31 31
32# Clamav has a built llvm version 2 but does not build with gcc 6.x, 32# Clamav has a built llvm version 2 but does not build with gcc 6.x,
33# disable the internal one. This is a known issue 33# disable the internal one. This is a known issue
34# If you want LLVM support, use meta-oe llvm3.3 to build for GCC 6.X, 34# If you want LLVM support, use the one in core
35# as defined below
36 35
37CLAMAV_LLVM ?= "oellvm" 36PACKAGECONFIG ?= "ncurses openssl bz2 zlib llvm"
38CLAMAV_LLVM_RELEASE ?= "8.0"
39
40PACKAGECONFIG ?= "ncurses openssl bz2 zlib ${CLAMAV_LLVM}"
41PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}" 37PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
42PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 38PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
43 39
44PACKAGECONFIG[oellvm] = "--with-system-llvm --with-llvm-linking=dynamic --disable-llvm, ,llvm${CLAMAV_LLVM_RELEASE}" 40PACKAGECONFIG[llvm] = "--with-system-llvm --with-llvm-linking=dynamic --disable-llvm, ,llvm8.0"
45 41
46PACKAGECONFIG[pcre] = "--with-pcre=${STAGING_LIBDIR}, --without-pcre, libpcre" 42PACKAGECONFIG[pcre] = "--with-pcre=${STAGING_LIBDIR}, --without-pcre, libpcre"
47PACKAGECONFIG[xml] = "--with-xml=${STAGING_LIBDIR}/.., --with-xml=no, libxml2," 43PACKAGECONFIG[xml] = "--with-xml=${STAGING_LIBDIR}/.., --with-xml=no, libxml2,"