summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-05-07 10:09:41 -0700
committerArmin Kuster <akuster808@gmail.com>2016-05-25 18:48:11 -0700
commit8511a96b26bed899db7472d41e04cbe092a2ec26 (patch)
tree3b27cef009912b981142b231f50770cd2d060329
parentf82b858dbd02a1a704ebbf70baff7684565dc4e1 (diff)
downloadmeta-security-8511a96b26bed899db7472d41e04cbe092a2ec26.tar.gz
clamav: update package to 0.99.2
remove unused patches. remove merged patches move files to /file for easier maintenance Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/clamav/clamav-0.99.1/mempool_build_fix.patch14
-rw-r--r--recipes-security/clamav/clamav-0.99.1/remove_rpath_chk.patch16
-rw-r--r--recipes-security/clamav/clamav-0.99.1/rpath_rmove.patch44
-rw-r--r--recipes-security/clamav/clamav_0.99.2.bb (renamed from recipes-security/clamav/clamav_0.99.1.bb)9
-rw-r--r--recipes-security/clamav/files/clamav-freshclam.service (renamed from recipes-security/clamav/clamav-0.99.1/clamav-freshclam.service)0
-rw-r--r--recipes-security/clamav/files/clamav-milter.conf.sample (renamed from recipes-security/clamav/clamav-0.99.1/clamav-milter.conf.sample)0
-rw-r--r--recipes-security/clamav/files/clamav.service (renamed from recipes-security/clamav/clamav-0.99.1/clamav.service)0
-rw-r--r--recipes-security/clamav/files/clamd.conf (renamed from recipes-security/clamav/clamav-0.99.1/clamd.conf)0
-rw-r--r--recipes-security/clamav/files/freshclam.conf (renamed from recipes-security/clamav/clamav-0.99.1/freshclam.conf)0
-rw-r--r--recipes-security/clamav/files/volatiles.03_clamav (renamed from recipes-security/clamav/clamav-0.99.1/volatiles.03_clamav)0
10 files changed, 4 insertions, 79 deletions
diff --git a/recipes-security/clamav/clamav-0.99.1/mempool_build_fix.patch b/recipes-security/clamav/clamav-0.99.1/mempool_build_fix.patch
deleted file mode 100644
index 18ead72..0000000
--- a/recipes-security/clamav/clamav-0.99.1/mempool_build_fix.patch
+++ /dev/null
@@ -1,14 +0,0 @@
1Index: libclamav/readdb.c
2===================================================================
3--- a/libclamav/readdb.c
4+++ b/libclamav/readdb.c
5@@ -4163,7 +4163,9 @@ static int cli_loadpwdb(FILE *fs, struct
6
7 /* use the tdb to track filetypes and check flevels */
8 memset(&tdb, 0, sizeof(tdb));
9+#ifdef USE_MPOOL
10 tdb.mempool = engine->mempool;
11+#endif
12 ret = init_tdb(&tdb, engine, attribs, passname);
13 free(attribs);
14 if(ret != CL_SUCCESS) {
diff --git a/recipes-security/clamav/clamav-0.99.1/remove_rpath_chk.patch b/recipes-security/clamav/clamav-0.99.1/remove_rpath_chk.patch
deleted file mode 100644
index 4d00931..0000000
--- a/recipes-security/clamav/clamav-0.99.1/remove_rpath_chk.patch
+++ /dev/null
@@ -1,16 +0,0 @@
1Index: clamav-0.99/configure
2===================================================================
3--- clamav-0.99.orig/configure
4+++ clamav-0.99/configure
5@@ -16192,11 +16192,6 @@ $as_echo_n "checking for shared library
6 if ${acl_cv_rpath+:} false; then :
7 $as_echo_n "(cached) " >&6
8 else
9-
10- CC="$CC" GCC="$GCC" LDFLAGS="$LDFLAGS" LD="$LD" with_gnu_ld="$with_gnu_ld" \
11- ${CONFIG_SHELL-/bin/sh} "$ac_aux_dir/config.rpath" "$host" > conftest.sh
12- . ./conftest.sh
13- rm -f ./conftest.sh
14 acl_cv_rpath=done
15
16 fi
diff --git a/recipes-security/clamav/clamav-0.99.1/rpath_rmove.patch b/recipes-security/clamav/clamav-0.99.1/rpath_rmove.patch
deleted file mode 100644
index a903c7e..0000000
--- a/recipes-security/clamav/clamav-0.99.1/rpath_rmove.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1Index: clamav-0.99/configure
2===================================================================
3--- clamav-0.99.orig/configure
4+++ clamav-0.99/configure
5@@ -9266,7 +9266,7 @@ $as_echo_n "checking whether the $compil
6 # are reset later if shared libraries are not supported. Putting them
7 # here allows them to be overridden if necessary.
8 runpath_var=LD_RUN_PATH
9- hardcode_libdir_flag_spec='${wl}-rpath ${wl}$libdir'
10+ hardcode_libdir_flag_spec='${wl}-rpath $libdir'
11 export_dynamic_flag_spec='${wl}--export-dynamic'
12 # ancient GNU ld didn't support --whole-archive et. al.
13 if $LD --help 2>&1 | $GREP 'no-whole-archive' > /dev/null; then
14@@ -9502,7 +9502,7 @@ _LT_EOF
15 # DT_RUNPATH tag from executables and libraries. But doing so
16 # requires that you compile everything twice, which is a pain.
17 if $LD --help 2>&1 | $GREP ': supported targets:.* elf' > /dev/null; then
18- hardcode_libdir_flag_spec='${wl}-rpath ${wl}$libdir'
19+ hardcode_libdir_flag_spec='${wl}-rpath $libdir'
20 archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
21 archive_expsym_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
22 else
23@@ -10074,7 +10074,7 @@ $as_echo "$lt_cv_irix_exported_symbol" >
24 archive_expsym_cmds='$CC -shared $libobjs $deplibs $compiler_flags -soname $soname `test -n "$verstring" && func_echo_all "-set_version $verstring"` -update_registry ${output_objdir}/so_locations -exports_file $export_symbols -o $lib'
25 fi
26 archive_cmds_need_lc='no'
27- hardcode_libdir_flag_spec='${wl}-rpath ${wl}$libdir'
28+ hardcode_libdir_flag_spec='${wl}-rpath $libdir'
29 hardcode_libdir_separator=:
30 inherit_rpath=yes
31 link_all_deplibs=yes
32Index: clamav-0.99/config/config.rpath
33===================================================================
34--- clamav-0.99.orig/config/config.rpath
35+++ clamav-0.99/config/config.rpath
36@@ -156,7 +156,7 @@ if test "$with_gnu_ld" = yes; then
37 # here allows them to be overridden if necessary.
38 # Unlike libtool, we use -rpath here, not --rpath, since the documented
39 # option of GNU ld is called -rpath, not --rpath.
40- hardcode_libdir_flag_spec='${wl}-rpath ${wl}$libdir'
41+ hardcode_libdir_flag_spec=
42 case "$host_os" in
43 aix3* | aix4* | aix5*)
44 # On AIX/PPC, the GNU linker is very broken
diff --git a/recipes-security/clamav/clamav_0.99.1.bb b/recipes-security/clamav/clamav_0.99.2.bb
index 461015f..184d605 100644
--- a/recipes-security/clamav/clamav_0.99.1.bb
+++ b/recipes-security/clamav/clamav_0.99.2.bb
@@ -12,11 +12,10 @@ SRC_URI = "http://www.clamav.net/downloads/production/${BPN}-${PV}.tar.gz \
12 file://clamd.conf \ 12 file://clamd.conf \
13 file://freshclam.conf \ 13 file://freshclam.conf \
14 file://volatiles.03_clamav \ 14 file://volatiles.03_clamav \
15 file://mempool_build_fix.patch \ 15 "
16 file://remove_rpath_chk.patch \ 16
17" 17SRC_URI[md5sum] = "61b51a04619aeafd965892a53f86d192"
18SRC_URI[md5sum] = "cf1f3cbe62a08c9165801f79239166ff" 18SRC_URI[sha256sum] = "167bd6a13e05ece326b968fdb539b05c2ffcfef6018a274a10aeda85c2c0027a"
19SRC_URI[sha256sum] = "e144689122d3f91293808c82cbb06b7d3ac9eca7ae29564c5d148ffe7b25d58a"
20 19
21LEAD_SONAME = "libclamav.so" 20LEAD_SONAME = "libclamav.so"
22SO_VER = "7.1.1" 21SO_VER = "7.1.1"
diff --git a/recipes-security/clamav/clamav-0.99.1/clamav-freshclam.service b/recipes-security/clamav/files/clamav-freshclam.service
index 0c909fb..0c909fb 100644
--- a/recipes-security/clamav/clamav-0.99.1/clamav-freshclam.service
+++ b/recipes-security/clamav/files/clamav-freshclam.service
diff --git a/recipes-security/clamav/clamav-0.99.1/clamav-milter.conf.sample b/recipes-security/clamav/files/clamav-milter.conf.sample
index ed0d519..ed0d519 100644
--- a/recipes-security/clamav/clamav-0.99.1/clamav-milter.conf.sample
+++ b/recipes-security/clamav/files/clamav-milter.conf.sample
diff --git a/recipes-security/clamav/clamav-0.99.1/clamav.service b/recipes-security/clamav/files/clamav.service
index f13191f..f13191f 100644
--- a/recipes-security/clamav/clamav-0.99.1/clamav.service
+++ b/recipes-security/clamav/files/clamav.service
diff --git a/recipes-security/clamav/clamav-0.99.1/clamd.conf b/recipes-security/clamav/files/clamd.conf
index 0457785..0457785 100644
--- a/recipes-security/clamav/clamav-0.99.1/clamd.conf
+++ b/recipes-security/clamav/files/clamd.conf
diff --git a/recipes-security/clamav/clamav-0.99.1/freshclam.conf b/recipes-security/clamav/files/freshclam.conf
index 100724f..100724f 100644
--- a/recipes-security/clamav/clamav-0.99.1/freshclam.conf
+++ b/recipes-security/clamav/files/freshclam.conf
diff --git a/recipes-security/clamav/clamav-0.99.1/volatiles.03_clamav b/recipes-security/clamav/files/volatiles.03_clamav
index ee2153c..ee2153c 100644
--- a/recipes-security/clamav/clamav-0.99.1/volatiles.03_clamav
+++ b/recipes-security/clamav/files/volatiles.03_clamav