summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2020-08-03 14:21:02 +0800
committerArmin Kuster <akuster808@gmail.com>2020-08-04 10:41:00 -0700
commit98e0a3ecf8161b678a224bc7b06abae9dc9d9039 (patch)
tree96ff9184152c8923e1aaa618dd0b6ccfcb6aa0ad
parent3becd114a2888c87d8a9de4332fdb929e37fd1dc (diff)
downloadmeta-security-98e0a3ecf8161b678a224bc7b06abae9dc9d9039.tar.gz
libseccomp: fix cross compile error for mips
Backport patch to fix cross compile error for mips: | syscalls.h:44:6: error: expected identifier or '(' before numeric constant | 44 | int mips; | | ^~~~ Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/libseccomp/files/fix-mips-build-failure.patch49
-rw-r--r--recipes-security/libseccomp/libseccomp_2.5.0.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes-security/libseccomp/files/fix-mips-build-failure.patch b/recipes-security/libseccomp/files/fix-mips-build-failure.patch
new file mode 100644
index 0000000..7d17a03
--- /dev/null
+++ b/recipes-security/libseccomp/files/fix-mips-build-failure.patch
@@ -0,0 +1,49 @@
1Backport patch to fix cross compile error for mips:
2
3| syscalls.h:44:6: error: expected identifier or '(' before numeric constant
4| 44 | int mips;
5| | ^~~~
6
7Upstream-Status: Submitted [https://github.com/seccomp/libseccomp/pull/279/commits/04c519e5]
8
9Signed-off-by: Kai Kang <kai.kang@windriver.com>
10
11From 04c519e5b1de53592e98307813e5c6db7418f91b Mon Sep 17 00:00:00 2001
12From: Paul Moore <paul@paul-moore.com>
13Date: Sun, 2 Aug 2020 09:57:39 -0400
14Subject: [PATCH] build: undefine "mips" to prevent build problems for MIPS
15 targets
16
17It turns out that the MIPS GCC compiler defines a "mips" cpp macro
18which was resulting in build failures on MIPS so we need to
19undefine the "mips" macro during build. As this should be safe
20to do in all architectures, just add it to the compiler flags by
21default.
22
23This was reported in the following GH issue:
24* https://github.com/seccomp/libseccomp/issues/274
25
26Reported-by: Rongwei Zhang <pudh4418@gmail.com>
27Suggested-by: Rongwei Zhang <pudh4418@gmail.com>
28Signed-off-by: Paul Moore <paul@paul-moore.com>
29---
30 configure.ac | 4 +++-
31 1 file changed, 3 insertions(+), 1 deletion(-)
32
33diff --git a/configure.ac b/configure.ac
34index 40d9dcbb..3e877348 100644
35--- a/configure.ac
36+++ b/configure.ac
37@@ -65,9 +65,11 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
38
39 dnl ####
40 dnl build flags
41+dnl NOTE: the '-Umips' is here because MIPS GCC compilers "helpfully" define it
42+dnl for us which wreaks havoc on the build
43 dnl ####
44 AM_CPPFLAGS="-I\${top_srcdir}/include -I\${top_builddir}/include"
45-AM_CFLAGS="-Wall"
46+AM_CFLAGS="-Wall -Umips"
47 AM_LDFLAGS="-Wl,-z -Wl,relro"
48 AC_SUBST([AM_CPPFLAGS])
49 AC_SUBST([AM_CFLAGS])
diff --git a/recipes-security/libseccomp/libseccomp_2.5.0.bb b/recipes-security/libseccomp/libseccomp_2.5.0.bb
index 7a6b483..35365d5 100644
--- a/recipes-security/libseccomp/libseccomp_2.5.0.bb
+++ b/recipes-security/libseccomp/libseccomp_2.5.0.bb
@@ -10,6 +10,7 @@ SRCREV = "f13f58efc690493fe7aa69f54cb52a118f3769c1"
10 10
11SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.5 \ 11SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.5 \
12 file://run-ptest \ 12 file://run-ptest \
13 file://fix-mips-build-failure.patch \
13" 14"
14 15
15COMPATIBLE_HOST_riscv32 = "null" 16COMPATIBLE_HOST_riscv32 = "null"