summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2022-05-02 09:36:56 -0700
committerArmin Kuster <akuster808@gmail.com>2022-05-23 07:54:29 -0700
commit9301e39d19d6c3f72ef24cd900855fbadca79177 (patch)
treeb146c879a98a97161fddd3ec7579effbff6ea716
parent93f2146211001ee3cf697d8428969cc3069ed6ba (diff)
downloadmeta-security-9301e39d19d6c3f72ef24cd900855fbadca79177.tar.gz
fscrypt: add distro_check on pam
Signed-off-by: Armin Kuster <akuster808@gmail.com> (cherry picked from commit 20c13f6335165d693f7f3270c829b3069dbbad66) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/fscrypt/fscrypt_1.0.0.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/recipes-security/fscrypt/fscrypt_1.0.0.bb b/recipes-security/fscrypt/fscrypt_1.0.0.bb
index 663d8e2..8147fe6 100644
--- a/recipes-security/fscrypt/fscrypt_1.0.0.bb
+++ b/recipes-security/fscrypt/fscrypt_1.0.0.bb
@@ -8,19 +8,19 @@ SECTION = "base"
8LICENSE = "Apache-2.0" 8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" 9LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
10 10
11BBCLASSEXTEND = "native nativesdk"
12
13# fscrypt depends on go and libpam 11# fscrypt depends on go and libpam
14DEPENDS += "go-native libpam" 12DEPENDS += "go-native libpam"
15 13
16SRCREV = "92b1e9a8670ccd3916a7d24a06cab1e4c9815bc4" 14SRCREV = "92b1e9a8670ccd3916a7d24a06cab1e4c9815bc4"
17SRC_URI = "git://github.com/google/fscrypt.git;branch=master;protocol=https" 15SRC_URI = "git://github.com/google/fscrypt.git;branch=master;protocol=https"
16
18GO_IMPORT = "import" 17GO_IMPORT = "import"
19 18
20S = "${WORKDIR}/git" 19inherit go goarch features_check
21 20
22inherit go 21REQUIRED_DISTRO_FEATURES = "pam"
23inherit goarch 22
23S = "${WORKDIR}/git"
24 24
25do_compile() { 25do_compile() {
26 export GOARCH=${TARGET_GOARCH} 26 export GOARCH=${TARGET_GOARCH}
@@ -47,3 +47,5 @@ do_install() {
47 install -d ${D}/${bindir} 47 install -d ${D}/${bindir}
48 install ${S}/src/${GO_IMPORT}/bin/fscrypt ${D}/${bindir}/fscrypt 48 install ${S}/src/${GO_IMPORT}/bin/fscrypt ${D}/${bindir}/fscrypt
49} 49}
50
51BBCLASSEXTEND = "native nativesdk"