summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-01-01 12:46:01 -0800
committerArmin Kuster <akuster808@gmail.com>2015-01-03 21:21:44 -0800
commitb265a8f1c7fc75374282a35c32b6d6bb52c1fc3c (patch)
tree4a00c76508ce72dad249eafc9adf6825cbaa328f
parent397b35c028ce69e315fef0ebcdf790c9056ebe42 (diff)
downloadmeta-security-b265a8f1c7fc75374282a35c32b6d6bb52c1fc3c.tar.gz
libwhisker2-perl: fix build issue
minor formating clean ups. add "ssl" depend packageconf option Change inherit perlnative to BBCLASSEXTEND = "native" to fix build issue error: Can't install libwhisker2-perl-2.5-r0@i586: no package provides /home/akuster/oss/maint/security/poky/build/tmp/sysroots/x86_64-linux/usr/bin/perl-native/perl.real Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-perl/perl/libwhisker2-perl_2.5.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/recipes-perl/perl/libwhisker2-perl_2.5.bb b/recipes-perl/perl/libwhisker2-perl_2.5.bb
index a98bde0..d9af430 100644
--- a/recipes-perl/perl/libwhisker2-perl_2.5.bb
+++ b/recipes-perl/perl/libwhisker2-perl_2.5.bb
@@ -5,8 +5,6 @@ LICENSE = "Artistic-1.0 | GPL-1.0+"
5 5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=254b8e29606fce6d1c1a4c9e32354573" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=254b8e29606fce6d1c1a4c9e32354573"
7 7
8DEPENDS = "perl"
9
10SRC_URI = "http://sourceforge.net/projects/whisker/files/libwhisker/${PV}/libwhisker2-${PV}.tar.gz \ 8SRC_URI = "http://sourceforge.net/projects/whisker/files/libwhisker/${PV}/libwhisker2-${PV}.tar.gz \
11 file://libwhisker2.patch" 9 file://libwhisker2.patch"
12 10
@@ -15,10 +13,15 @@ SRC_URI[sha256sum] = "f45a1cf2ad2637b29dd1b13d7221ea12e3923ea09d107ced446400f190
15 13
16S = "${WORKDIR}/libwhisker2-2.5" 14S = "${WORKDIR}/libwhisker2-2.5"
17 15
18inherit cpan-base perlnative 16inherit cpan-base
17
18PACKAGEGROUP ??=""
19PACKAGEGROUP[ssl] = ", , libnet-ssleay-perl, libnet-ssleay-perl"
19 20
20do_install() { 21do_install() {
21 install -d 755 ${D}${PERLLIBDIRS}/vendor_perl/${PERLVERSION} 22 install -d 755 ${D}${PERLLIBDIRS}/vendor_perl/${PERLVERSION}
22 install -d 755 ${D}${datadir}/perl/${PERLVERSION} 23 install -d 755 ${D}${datadir}/perl/${PERLVERSION}
23 oe_runmake install DESTDIR=${D} INSTALLDIR=${PERLLIBDIRS}/vendor_perl/${PERLVERSION} MANDIR=${datadir}/perl/${PERLVERSION} 24 oe_runmake install DESTDIR=${D} INSTALLDIR=${PERLLIBDIRS}/vendor_perl/${PERLVERSION} MANDIR=${datadir}/perl/${PERLVERSION}
24} 25}
26
27BBCLASSEXTEND = "native"