summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2014-07-09 19:12:41 -0700
committerArmin Kuster <akuster@mvista.com>2014-08-06 08:06:36 -0700
commita1f10775fec7c6c7e8b8fd723adabb37dcab6990 (patch)
treeced1fcffce087ef0ca7544745c9a7a2b82e6fd66
parentf20ff5c45c2b6b2f5e699581eb0f997b892cc09d (diff)
downloadmeta-security-a1f10775fec7c6c7e8b8fd723adabb37dcab6990.tar.gz
V2 packagegroup: Add initial set of package groups
Signed-off-by: Armin Kuster <akuster@mvista.com>
-rw-r--r--recipes-security/packagegroup/packagegroup-core-security.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-security/packagegroup/packagegroup-core-security.bb b/recipes-security/packagegroup/packagegroup-core-security.bb
new file mode 100644
index 0000000..25f9f1f
--- /dev/null
+++ b/recipes-security/packagegroup/packagegroup-core-security.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "Security packagegroup for Poky"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6inherit packagegroup
7
8PACKAGES = "\
9 packagegroup-core-security \
10 packagegroup-security-utils \
11 packagegroup-security-scanners \
12 "
13
14RDEPENDS_packagegroup-core-security = "\
15 packagegroup-security-utils \
16 packagegroup-security-scanners \
17 "
18
19SUMMARY_packagegroup-security-utils = "Security utilities"
20RDEPENDS_packagegroup-security-utils = "\
21 nmap \
22 libseccomp \
23 pinentry \
24 ${@bb.utils.contains("DISTRO_FEATURES", "pax", "pax-utils", "",d)} \
25 "
26
27SUMMARY_packagegroup-security-scanners = "Security scanners"
28RDEPENDS_packagegroup-security-scanners = "\
29 nikto \
30 checksecurity \
31 "
32
33SUMMARY_packagegroup-security-audit = "Security Audit tools "
34RDEPENDS_packagegroup-security-audit = " \
35 buck-security \
36 redhat-security \
37 "
38
39SUMMARY_packagegroup-security-hardening = "Security Hardening tools"
40RDEPENDS_packagegroup-security-hardening = " \
41 bastille \
42 "
43