summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2014-09-04 14:35:21 -0700
committerArmin Kuster <akuster808@gmail.com>2014-11-28 19:13:46 -0800
commit93891d856d874064394c23af6c3b0da39c2955d3 (patch)
tree94c677e28c8a272392b98cc302dbf73bd0a7b013
parentb584aa13f67ca3d551659bcef55cdc426dad5313 (diff)
downloadmeta-security-93891d856d874064394c23af6c3b0da39c2955d3.tar.gz
libseccomp: add package for tests.
I wanted to run the tests manually on a target. Tests are now built and packaged. to run: /usr/lib/libseccomp/tests/regression -a will add ptest later. Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/libseccomp/libseccomp_2.1.1.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-security/libseccomp/libseccomp_2.1.1.bb b/recipes-security/libseccomp/libseccomp_2.1.1.bb
index 27fa259..5e0b962 100644
--- a/recipes-security/libseccomp/libseccomp_2.1.1.bb
+++ b/recipes-security/libseccomp/libseccomp_2.1.1.bb
@@ -18,6 +18,15 @@ do_configure() {
18 ${S}/configure --prefix=${prefix} --libdir=${libdir} 18 ${S}/configure --prefix=${prefix} --libdir=${libdir}
19} 19}
20 20
21do_compile_append() {
22 oe_runmake DESTDIR=${D} tests
23}
24
21do_install() { 25do_install() {
22 oe_runmake DESTDIR=${D} install 26 oe_runmake DESTDIR=${D} install
27 oe_runmake DESTDIR=${D} install-tests
23} 28}
29
30PACKAGES += "${PN}-tests "
31FILES_${PN}-tests = "${libdir}/${BPN}/tests/*"
32FILES_${PN}-dbg += "${libdir}/${BPN}/tests/.debug/*"