summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandru.Vaduva <Alexandru.Vaduva at enea.com>2014-07-02 19:45:00 -0700
committerArmin Kuster <akuster@mvista.com>2014-07-02 19:46:00 -0700
commit914128d8c98e267f761cbfcab4061167444c4168 (patch)
treeff7cd9cbe7919476585409b0cc052183df7972d9
parent3689209e5282ea8bcba213bfd4f762d516ac5103 (diff)
downloadmeta-security-914128d8c98e267f761cbfcab4061167444c4168.tar.gz
libcap-ng: resolved issue related with LONG_BIT definition
The problem is well known for 64 bits architectures and the solution is offered in the same recibe but in the meta-selinux layer. Signed-off-by: Alexandru.Vaduva <Alexandru.Vaduva at enea.com> Signed-off-by: Armin Kuster <akuster@mvista.com>
-rw-r--r--recipes-security/libcap-ng/libcap-ng/python.patch39
-rw-r--r--recipes-security/libcap-ng/libcap-ng_0.7.3.bb38
2 files changed, 71 insertions, 6 deletions
diff --git a/recipes-security/libcap-ng/libcap-ng/python.patch b/recipes-security/libcap-ng/libcap-ng/python.patch
new file mode 100644
index 0000000..d82ceb4
--- /dev/null
+++ b/recipes-security/libcap-ng/libcap-ng/python.patch
@@ -0,0 +1,39 @@
1configure.ac - Avoid an incorrect check for python.
2Makefile.am - avoid hard coded host include paths.
3
4Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
5
6--- libcap-ng-0.6.5/configure.ac.orig 2012-01-17 13:59:03.645898989 -0600
7+++ libcap-ng-0.6.5/configure.ac 2012-01-17 13:59:46.353959252 -0600
8@@ -120,17 +120,8 @@
9 else
10 AC_MSG_RESULT(testing)
11 AM_PATH_PYTHON
12-if test -f /usr/include/python${am_cv_python_version}/Python.h ; then
13- python_found="yes"
14- AC_MSG_NOTICE(Python bindings will be built)
15-else
16- python_found="no"
17- if test x$use_python = xyes ; then
18- AC_MSG_ERROR([Python explicitly required and python headers found])
19- else
20- AC_MSG_WARN("Python headers not found - python bindings will not be made")
21- fi
22-fi
23+python_found="yes"
24+AC_MSG_NOTICE(Python bindings will be built)
25 fi
26 AM_CONDITIONAL(HAVE_PYTHON, test ${python_found} = "yes")
27
28--- libcap-ng-0.6.5/bindings/python/Makefile.am.orig 2010-11-03 12:31:59.000000000 -0500
29+++ libcap-ng-0.6.5/bindings/python/Makefile.am 2012-01-17 14:05:50.199834467 -0600
30@@ -24,7 +24,8 @@
31 CONFIG_CLEAN_FILES = *.loT *.rej *.orig
32 AM_CFLAGS = -fPIC -DPIC
33 PYLIBVER ?= python$(PYTHON_VERSION)
34-INCLUDES = -I. -I$(top_builddir) -I/usr/include/$(PYLIBVER)
35+PYINC ?= /usr/include/$(PYLIBVER)
36+INCLUDES = -I. -I$(top_builddir) -I$(PYINC)
37 LIBS = $(top_builddir)/src/libcap-ng.la
38 pyexec_PYTHON = capng.py
39 pyexec_LTLIBRARIES = _capng.la
diff --git a/recipes-security/libcap-ng/libcap-ng_0.7.3.bb b/recipes-security/libcap-ng/libcap-ng_0.7.3.bb
index ef70207..3f225ba 100644
--- a/recipes-security/libcap-ng/libcap-ng_0.7.3.bb
+++ b/recipes-security/libcap-ng/libcap-ng_0.7.3.bb
@@ -1,11 +1,37 @@
1DESCRIPTION = "The libcap-ng library is intended to make programming with posix capabilities much easier than the traditional libcap library." 1SUMMARY = "An alternate posix capabilities library"
2HOMEPAGE = "http://people.redhat.com/sgrubb/libcap-ng/index.html" 2DESCRIPTION = "The libcap-ng library is intended to make programming \
3LICENSE = "GPL-2.0" 3with POSIX capabilities much easier than the traditional libcap library."
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 4HOMEPAGE = "http://freecode.com/projects/libcap-ng"
5SECTION = "base"
6LICENSE = "GPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06"
5 9
6SRC_URI = "http://people.redhat.com/sgrubb/libcap-ng/${PN}-${PV}.tar.gz" 10SRC_URI = "http://people.redhat.com/sgrubb/libcap-ng/libcap-ng-${PV}.tar.gz \
11 file://python.patch"
12
13inherit lib_package autotools pythonnative
7 14
8SRC_URI[md5sum] = "610afb774f80a8032b711281df126283" 15SRC_URI[md5sum] = "610afb774f80a8032b711281df126283"
9SRC_URI[sha256sum] = "5ca441c8d3a1e4cfe8a8151907977662679457311ccaa7eaac91447c33a35bb1" 16SRC_URI[sha256sum] = "5ca441c8d3a1e4cfe8a8151907977662679457311ccaa7eaac91447c33a35bb1"
10 17
11inherit autotools 18DEPENDS += "swig-native python"
19
20EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'"
21
22PACKAGES += "${PN}-python"
23
24FILES_${PN}-dbg += "${libdir}/python${PYTHON_BASEVERSION}/*/.debug"
25FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}"
26
27BBCLASSEXTEND = "native"
28
29do_install_append() {
30 # Moving libcap-ng to base_libdir
31 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
32 mkdir -p ${D}/${base_libdir}/
33 mv -f ${D}${libdir}/libcap-ng.so.* ${D}${base_libdir}/
34 relpath=${@os.path.relpath("${base_libdir}", "${libdir}")}
35 ln -sf ${relpath}/libcap-ng.so.0.0.0 ${D}${libdir}/libcap-ng.so
36 fi
37}