summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2014-07-03 08:03:56 -0700
committerArmin Kuster <akuster@mvista.com>2014-08-06 07:56:14 -0700
commit6f64473a40147bffdef7d2e12cf5de0db07fb1df (patch)
tree5435bf1392c7bdea56d057f9c26f439608d8a18b
parent914128d8c98e267f761cbfcab4061167444c4168 (diff)
downloadmeta-security-6f64473a40147bffdef7d2e12cf5de0db07fb1df.tar.gz
nmap: update to 6.46
Updated to later version on nmap. remove patch which is included in update Added ndiff package Include zenmap build changes but commented out for now and untested Signed-off-by: Armin Kuster <akuster@mvista.com>
-rw-r--r--recipes-security/nmap/files/lua.patch79
-rw-r--r--recipes-security/nmap/nmap_6.25.bb24
-rw-r--r--recipes-security/nmap/nmap_6.46.bb36
3 files changed, 36 insertions, 103 deletions
diff --git a/recipes-security/nmap/files/lua.patch b/recipes-security/nmap/files/lua.patch
deleted file mode 100644
index 7cb86ab..0000000
--- a/recipes-security/nmap/files/lua.patch
+++ /dev/null
@@ -1,79 +0,0 @@
1Added missing definitions which caused failuire at do_configure
2with --without-liblua option.
3
4Upstream Status : pending
5
6Signed-off-by: Andrei Dinu <andrei.adrianx.dinu@intel.com>
7--- a/output.h
8+++ b/output.h
9@@ -226,6 +226,10 @@
10 void printscriptresults(ScriptResults *scriptResults, stype scantype);
11
12 void printhostscriptresults(Target *currenths);
13+
14+/*This is a helper function to determine the ordering of the script results
15+ based on their id */
16+bool comparescriptids(ScriptResult first, ScriptResult second);
17 #endif
18
19 /* Print a table with traceroute hops. */
20@@ -253,8 +257,4 @@
21 were found. */
22 void printdatafilepaths();
23
24-/*This is a helper function to determine the ordering of the script results
25- based on their id */
26-bool comparescriptids(ScriptResult first, ScriptResult second);
27-
28 #endif /* OUTPUT_H */
29--- a/output.cc
30+++ b/output.cc
31@@ -2613,6 +2613,7 @@
32 }
33 }
34
35+#ifndef NOLUA
36 /*This is a helper function to determine the ordering of the script results
37 based on their id */
38 bool comparescriptids(ScriptResult first, ScriptResult second){
39@@ -2625,5 +2626,6 @@
40 else
41 return false;
42 }
43+#endif
44
45
46--- a/portlist.cc
47+++ b/portlist.cc
48@@ -144,6 +144,7 @@
49 }
50 }
51
52+#ifndef NOLUA
53 void Port::freeScriptResults(void)
54 {
55 while (!scriptResults.empty()) {
56@@ -151,6 +152,7 @@
57 scriptResults.pop_front();
58 }
59 }
60+#endif
61
62 /* Fills in namebuf (as long as there is space in buflen) with the
63 Name nmap normal output will use to describe the port. This takes
64--- a/Target.cc
65+++ b/Target.cc
66@@ -162,10 +162,12 @@
67
68 Target::~Target() {
69 FreeInternal();
70+#ifndef NOLUA
71 while (!scriptResults.empty()) {
72 scriptResults.front().clear();
73 scriptResults.pop_front();
74 }
75+#endif
76 }
77
78 void Target::FreeInternal() {
79
diff --git a/recipes-security/nmap/nmap_6.25.bb b/recipes-security/nmap/nmap_6.25.bb
deleted file mode 100644
index 5efcc70..0000000
--- a/recipes-security/nmap/nmap_6.25.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "network auditing tool"
2DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing."
3SECTION = "security"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
6FILES_${PN} += "${target_datadir}/ncat"
7
8SRC_URI = "http://nmap.org/dist/${PN}-${PV}.tar.bz2 \
9 file://lua.patch"
10
11SRC_URI[md5sum] = "fcc80f94ff3adcb11eedf91092ea6f5e"
12SRC_URI[sha256sum] = "3349cc6d36b86b95ca2b8075d16615a3a598cef494920d6652f9a8bf9f7660b5"
13
14inherit autotools-brokensep
15
16DEPENDS = "libpcap"
17
18EXTRA_OECONF = "--without-liblua --without-zenmap --without-subversion --with-pcap=linux"
19
20do_configure() {
21 autoconf
22 oe_runconf
23}
24
diff --git a/recipes-security/nmap/nmap_6.46.bb b/recipes-security/nmap/nmap_6.46.bb
new file mode 100644
index 0000000..42db71f
--- /dev/null
+++ b/recipes-security/nmap/nmap_6.46.bb
@@ -0,0 +1,36 @@
1SUMMARY = "network auditing tool"
2DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing."
3SECTION = "security"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
6FILES_${PN} += "${target_datadir}/ncat"
7
8SRC_URI = "http://nmap.org/dist/${BPN}-${PV}.tar.bz2"
9
10SRC_URI[md5sum] = "5a36ad3a63d5b7ea5514f745a397436a"
11SRC_URI[sha256sum] = "3f89d9053c69507fe9533c40188a6561d49607a37b1db6380aed9039d4883137"
12
13inherit autotools-brokensep
14
15DEPENDS = "libpcap"
16
17EXTRA_OECONF = "--without-liblua --without-zenmap --without-subversion --with-pcap=linux"
18
19do_configure() {
20 autoconf
21 oe_runconf
22}
23
24# should add a conditional for "--without-zenmap" test.
25# zenmap builds if the below are uncommented. Not tested
26#PACKAGES =+ "${PN}-zenmap"
27#FILES_${PN}-zenmap = "/usr/share/zenmap/*"
28
29# should add a conditional based for "--without-ndiff"
30PACKAGES =+ "${PN}-python"
31DESCRIPTION_${PN}-python = \
32"The ${PN}-python package includes the ndiff utility. \
33Ndiff is a tool to aid in the comparison of Nmap scans."
34FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
35
36