summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2014-08-17 19:15:07 -0700
committerArmin Kuster <akuster808@gmail.com>2014-08-27 21:11:32 -0700
commit6e72910b3e8e9545c885a29d62d7837aa3d95fb4 (patch)
tree0d73e9f64655a0cb3cb7e4eac7f48e15c0bcdd89
parent2559581eaa35adf8e1ff50db03c2b196c9ea4931 (diff)
downloadmeta-security-6e72910b3e8e9545c885a29d62d7837aa3d95fb4.tar.gz
samhain: server package
This is the server portion. Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/samhain/samhain-server_3.1.1.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes-security/samhain/samhain-server_3.1.1.bb b/recipes-security/samhain/samhain-server_3.1.1.bb
new file mode 100644
index 0000000..50e8d8a
--- /dev/null
+++ b/recipes-security/samhain/samhain-server_3.1.1.bb
@@ -0,0 +1,50 @@
1SAMHAIN_MODE="server"
2INITSCRIPT_PARAMS = "defaults 14 86"
3
4require samhain.inc
5
6DEPENDS = "gmp"
7
8EXTRA_OECONF += "--enable-network=${SAMHAIN_MODE} "
9
10# supports mysql|postgresql|oracle|odbc but postgresql is the only one available
11
12PACKAGECONFG ??= "postgresql"
13PACKAGECONFIG[postgres] = "--with-database=postgresql --enable-xml-log, "", postgresql"
14PACKAGECONFIG[suidcheck] = "--enable-suidcheck","" , "
15PACKAGECONFIG[logwatch] = "--enable-login-watch,"" , "
16PACKAGECONFIG[mounts] = "--enable-mounts-check","" , "
17PACKAGECONFIG[userfiles] = "--enable-userfiles","" , "
18PACKAGECONFIG[ipv6] = "--enable-ipv6,"--disable-ipv6","
19
20SRC_URI += "file://samhain-server-volatiles"
21
22EXTRA_OECONF += " \
23 --with-config-file=REQ_FROM_SERVER/etc/samhainrc \
24 --with-data-file=REQ_FROM_SERVER/var/lib/samhain/samhain_file \
25 "
26
27do_install_append() {
28 cd ${S}
29 install -d ${D}${sysconfdir}/default/volatiles
30 install -m 0644 ${WORKDIR}/samhain-server-volatiles \
31 ${D}${sysconfdir}/default/volatiles/samhain-server
32
33 install -m 700 samhain-install.sh init/samhain.startLinux \
34 init/samhain.startLSB ${D}/var/lib/samhain
35}
36
37INSANE_SKIP_${PN} = "already-stripped"
38
39PACKAGES = "${PN} ${PN}-doc ${PN}-dbg"
40
41FILES_${PN} += " \
42 ${sbindir}/* \
43 /run \
44 "
45
46FILES_${PN}-dbg += " \
47 ${sbindir}/.debug/* \
48 "
49
50DEPENDS_${PN} += "gmp"