summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2014-08-18 18:17:42 -0700
committerArmin Kuster <akuster808@gmail.com>2014-08-27 21:12:31 -0700
commit6328a58612c3105850819ede596900b062cdce3b (patch)
tree11d6e6a66f57be6e5c2561caa8d19c6ebc5eba5a
parent6e72910b3e8e9545c885a29d62d7837aa3d95fb4 (diff)
downloadmeta-security-6328a58612c3105850819ede596900b062cdce3b.tar.gz
pinentry: Fix QA error
This fixes: WARNING: QA Issue: pinentry rdepends on libcap, but it isn't a build dependency? [build-deps] Also add pkgconfig support. Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/pinentry/pinentry_0.8.3.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/recipes-security/pinentry/pinentry_0.8.3.bb b/recipes-security/pinentry/pinentry_0.8.3.bb
index 3209e53..0bd3021 100644
--- a/recipes-security/pinentry/pinentry_0.8.3.bb
+++ b/recipes-security/pinentry/pinentry_0.8.3.bb
@@ -2,14 +2,19 @@ DESCRIPTION = "This is a collection of simple PIN or passphrase entry dialogs wh
2HOMEPAGE = "ftp://ftp.gnupg.org/gcrypt/" 2HOMEPAGE = "ftp://ftp.gnupg.org/gcrypt/"
3LICENSE = "GPL-2.0" 3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" 4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
5DEPENDS = "glib-2.0 ncurses" 5DEPENDS = "glib-2.0 "
6 6
7SRC_URI = "ftp://ftp.gnupg.org/gcrypt/pinentry/${PN}-${PV}.tar.bz2" 7SRC_URI = "ftp://ftp.gnupg.org/gcrypt/pinentry/${PN}-${PV}.tar.bz2"
8 8
9SRC_URI[md5sum] = "2ae681cbca0d9fb774b2c90b11ebf56c" 9SRC_URI[md5sum] = "2ae681cbca0d9fb774b2c90b11ebf56c"
10SRC_URI[sha256sum] = "568b0b09b50b2388a4f94d704d5bcb28718ecd4654ed1acc43ab1f97d921a0ad" 10SRC_URI[sha256sum] = "568b0b09b50b2388a4f94d704d5bcb28718ecd4654ed1acc43ab1f97d921a0ad"
11 11
12inherit autotools 12inherit autotools pkgconfig
13 13
14EXTRA_OECONF +="--disable-pinentry-gtk2 --disable-pinentry-qt --disable-pinentry-qt4 --without-x --enable-ncurses \ 14EXTRA_OECONF +="--disable-pinentry-gtk2 --disable-pinentry-qt \
15 --with-ncurses-include-dir=${STAGING_INCDIR} " 15 --disable-pinentry-qt4 --without-x "
16
17PACKAGECONFIG ??= "ncurses"
18
19PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, '--disable-ncurses', ncurses"
20PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap"