summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2014-12-26 18:43:48 -0800
committerArmin Kuster <akuster808@gmail.com>2015-01-03 21:21:03 -0800
commit424473d61eeb28c93dcdfc89ce0a5644367c7aa1 (patch)
treed7e7bfb68e3dee05fcc12913daf70e17a9a69467
parent5294a2c60324fe0dcfe6764b4625091529fa0b77 (diff)
downloadmeta-security-424473d61eeb28c93dcdfc89ce0a5644367c7aa1.tar.gz
remove: libcurses-perl, libhtml-parser-perl, libnet-dns-perl
those packages are being moved to meta-perl. Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/perl/libcurses-perl_1.31.bb27
-rw-r--r--recipes-security/perl/libhtml-parser-perl_3.71.bb25
-rw-r--r--recipes-security/perl/libnet-dns-perl_0.72.bb25
3 files changed, 0 insertions, 77 deletions
diff --git a/recipes-security/perl/libcurses-perl_1.31.bb b/recipes-security/perl/libcurses-perl_1.31.bb
deleted file mode 100644
index bd74439..0000000
--- a/recipes-security/perl/libcurses-perl_1.31.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1DESCRIPTION = "lib-curses provides an interface between Perl programs and \
2the curses library."
3
4SECTION = "libs"
5LICENSE = "Artistic-1.0 | GPL-1.0+"
6PR = "r0"
7
8LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=0b37356c5e9e28080a3422d82af8af09"
9
10DEPENDS += "perl ncurses "
11
12SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tgz"
13
14SRC_URI[md5sum] = "119aff0faaa9347ed32dad127c4a6707"
15SRC_URI[sha256sum] = "7bb4623ac97125c85e25f9fbf980103da7ca51c029f704f0aa129b7a2e50a27a"
16
17S = "${WORKDIR}/Curses-${PV}"
18
19EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR}"
20
21inherit cpan
22
23do_compile() {
24 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
25 cpan_do_compile
26}
27
diff --git a/recipes-security/perl/libhtml-parser-perl_3.71.bb b/recipes-security/perl/libhtml-parser-perl_3.71.bb
deleted file mode 100644
index be0f4b2..0000000
--- a/recipes-security/perl/libhtml-parser-perl_3.71.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1DESCRIPTION = "This package contains the Parser.pm module with friends."
2
3SECTION = "libs"
4LICENSE = "Artistic-1.0 | GPL-1.0+"
5
6LIC_FILES_CHKSUM = "file://README;md5=6c3dacf9f405c7483870ab5f148770c3"
7
8DEPENDS += "perl"
9
10SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/HTML-Parser-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "9128a45893097dfa3bf03301b19c5efe"
13SRC_URI[sha256sum] = "be918b3749d3ff93627f72ee4b825683332ecb4c81c67a3a8d72b0435ffbd802"
14
15S = "${WORKDIR}/HTML-Parser-${PV}"
16
17EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
18
19inherit cpan
20
21do_compile() {
22 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
23 cpan_do_compile
24}
25BBCLASSEXTEND = "native"
diff --git a/recipes-security/perl/libnet-dns-perl_0.72.bb b/recipes-security/perl/libnet-dns-perl_0.72.bb
deleted file mode 100644
index 5c218b8..0000000
--- a/recipes-security/perl/libnet-dns-perl_0.72.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1DESCRIPTION = "This package contains the DNS.pm module with friends."
2
3SECTION = "libs"
4LICENSE = "Artistic-1.0 | GPL-1.0+"
5
6LIC_FILES_CHKSUM = "file://README;md5=f21d77d9c6b56a07470bbce561b169e3"
7
8DEPENDS += "perl"
9
10SRC_URI = "http://search.cpan.org/CPAN/authors/id/N/NL/NLNETLABS/Net-DNS-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "393e48ec6f28abe5ed30204276e02775"
13SRC_URI[sha256sum] = "a62cae0be54a9684c305456cb95515a0bd3128d6ef3093b6069fe8e8e8d5943f"
14
15S = "${WORKDIR}/Net-DNS-${PV}"
16
17EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
18
19inherit cpan
20
21do_compile() {
22 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
23 cpan_do_compile
24}
25BBCLASSEXTEND = "native"