summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2014-08-17 19:14:06 -0700
committerArmin Kuster <akuster808@gmail.com>2014-08-27 21:11:21 -0700
commit2559581eaa35adf8e1ff50db03c2b196c9ea4931 (patch)
tree43239c7053d09ec420aed170c4b159172015c569
parentf0f670c2fe8cd876eaf2143d7e18ec3eb7d2a641 (diff)
downloadmeta-security-2559581eaa35adf8e1ff50db03c2b196c9ea4931.tar.gz
samhain: client package
This is the client portion. Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/samhain/samhain-client_3.1.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-security/samhain/samhain-client_3.1.1.bb b/recipes-security/samhain/samhain-client_3.1.1.bb
new file mode 100644
index 0000000..501c3b8
--- /dev/null
+++ b/recipes-security/samhain/samhain-client_3.1.1.bb
@@ -0,0 +1,21 @@
1SAMHAIN_MODE="client"
2INITSCRIPT_PARAMS = "defaults 15 85"
3
4require samhain.inc
5
6#Let the default Logserver be 127.0.0.1
7EXTRA_OECONF += " \
8 --with-logserver=${SAMHAIN_SERVER} \
9 --with-port=${SAMHAIN_PORT} \
10 --with-config-file=/etc/samhainrc \
11 --with-data-file=/var/lib/samhain/samhain_file \
12 "
13
14
15INSANE_SKIP_${PN} = "already-stripped"
16
17FILES_${PN} += "\
18 /run \
19 "
20
21RDEPENDS_${PN} = "acl zlib attr"