summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2014-08-19 23:11:14 -0700
committerArmin Kuster <akuster808@gmail.com>2014-09-13 10:25:00 -0700
commit1f28cd51dcd762ebbb22510aed868f1661541252 (patch)
treef2d66eb07cf2f4d48c653737a9ee8dc8ee523a4e
parent20776618f2fa5373a9a48136c121bdcc64c3eaea (diff)
downloadmeta-security-1f28cd51dcd762ebbb22510aed868f1661541252.tar.gz
nmap: Add gui support
Add zenmap to work with gtk+/x11 Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/nmap/nmap_6.46.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/recipes-security/nmap/nmap_6.46.bb b/recipes-security/nmap/nmap_6.46.bb
index 6fe3c6b..573187d 100644
--- a/recipes-security/nmap/nmap_6.46.bb
+++ b/recipes-security/nmap/nmap_6.46.bb
@@ -1,5 +1,5 @@
1SUMMARY = "network auditing tool" 1SUMMARY = "network auditing tool"
2DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing." 2DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing.\nGui support via appending to IMAGE_FEATURES x11-base in local.conf"
3SECTION = "security" 3SECTION = "security"
4LICENSE = "GPL-2.0" 4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" 5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
@@ -9,9 +9,10 @@ SRC_URI = "http://nmap.org/dist/${BPN}-${PV}.tar.bz2"
9SRC_URI[md5sum] = "5a36ad3a63d5b7ea5514f745a397436a" 9SRC_URI[md5sum] = "5a36ad3a63d5b7ea5514f745a397436a"
10SRC_URI[sha256sum] = "3f89d9053c69507fe9533c40188a6561d49607a37b1db6380aed9039d4883137" 10SRC_URI[sha256sum] = "3f89d9053c69507fe9533c40188a6561d49607a37b1db6380aed9039d4883137"
11 11
12inherit autotools-brokensep pkgconfig 12inherit autotools-brokensep pkgconfig distro_features_check
13 13
14PACKAGECONFIG ??= "ncat nping ndiff pcap" 14PACKAGECONFIG ??= "ncat nping ndiff pcap"
15PACKAGECONFIG += " ${@bb.utils.contains("IMAGE_FEATURES", "x11-base", "zenmap", "", d)}"
15 16
16PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap" 17PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap"
17PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl" 18PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl"
@@ -25,7 +26,10 @@ PACKAGECONFIG[ndiff] = ",--without-ndiff,"
25PACKAGECONFIG[lua] = "--with-liblua=${STAGING_LIBDIR}/.., --with-liblua=included, lua" 26PACKAGECONFIG[lua] = "--with-liblua=${STAGING_LIBDIR}/.., --with-liblua=included, lua"
26PACKAGECONFIG[pcre] = "--with-libpcre=${STAGING_LIBDIR}/.., --with-libpcre=included, libpre" 27PACKAGECONFIG[pcre] = "--with-libpcre=${STAGING_LIBDIR}/.., --with-libpcre=included, libpre"
27 28
28EXTRA_OECONF = "--without-zenmap" 29#Add gui
30PACKAGECONFIG[zenmap] = "--with-zenmap, --without-zenmap, gtk+ python-core python-codecs python-io python-logging python-unittest python-xml python-netclient python-doctest python-subprocess python-pygtk, python-core python-codecs python-io python-logging python-netclient python-xml python-unittest python-doctest python-subprocess python-pygtk gtk+"
31
32EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion"
29 33
30do_configure() { 34do_configure() {
31 autoconf 35 autoconf
@@ -41,10 +45,8 @@ FILES_${PN} += "${@bb.utils.contains("PACKAGECONFIG", "ncat", "${bindir}/ncat ${
41FILES_${PN} += "${@bb.utils.contains("PACKAGECONFIG", "nping", "${bindir}/nping", "", d)}" 45FILES_${PN} += "${@bb.utils.contains("PACKAGECONFIG", "nping", "${bindir}/nping", "", d)}"
42FILES_${PN} += "${@bb.utils.contains("PACKAGECONFIG", "ndiff", "${bindir}/ndiff ${libdir}/python${PYTHON_BASEVERSION}/site-packages/ndiff*", "", d)}" 46FILES_${PN} += "${@bb.utils.contains("PACKAGECONFIG", "ndiff", "${bindir}/ndiff ${libdir}/python${PYTHON_BASEVERSION}/site-packages/ndiff*", "", d)}"
43 47
44# should add a conditional for "--without-zenmap" test. 48PACKAGES += "${@bb.utils.contains("PACKAGECONFIG", "zenmap", "${PN}-zenmap", "", d)}"
45# zenmap builds if the below are uncommented. Not tested
46#PACKAGES =+ "${PN}-zenmap"
47#FILES_${PN}-zenmap = "/usr/share/zenmap/*"
48
49 49
50FILES_${PN}-zenmap = "${@bb.utils.contains("PACKAGECONFIG", "zenmap", "${bindir}/*zenmap ${bindir}/xnmap ${datadir}/applications/* ${bindir}/nmapfe ${datadir}/zenmap/* ${libdir}/python${PYTHON_BASEVERSION}/site-packages/radialnet/* ${libdir}/python${PYTHON_BASEVERSION}/site-packages/zenmap*", "", d)}"
50 51
52RDEPENDS_${PN}-zenmap = "nmap"