summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2014-07-12 04:29:04 -0700
committerArmin Kuster <akuster808@gmail.com>2014-08-20 21:19:04 -0700
commit14b15cc2762160b64f63a5092238b0d0ba084b48 (patch)
tree1e138d0d15a6ed9e4353133e251a20bf753da0b8
parent43ce4b48896668c092e30a3417ea52a70629774b (diff)
downloadmeta-security-14b15cc2762160b64f63a5092238b0d0ba084b48.tar.gz
tomoyo: Add kconfig
V2: Fixed path to init program Fix typo in name Add kernel config to enable tomoyo Signed-off-by: Armin Kuster <akuster@mvista.com>
-rw-r--r--recipes-kernel/linux/linux-yocto/tomoyo.cfg7
-rw-r--r--recipes-kernel/linux/linux-yocto/tomoyo.scc4
-rw-r--r--recipes-kernel/linux/linux-yocto_3.14.bbappend4
3 files changed, 15 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto/tomoyo.cfg b/recipes-kernel/linux/linux-yocto/tomoyo.cfg
new file mode 100644
index 0000000..0caccf7
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto/tomoyo.cfg
@@ -0,0 +1,7 @@
1CONFIG_SECURITY_TOMOYO=y
2CONFIG_SECURITY_TOMOYO_MAX_ACCEPT_ENTRY=2048
3CONFIG_SECURITY_TOMOYO_MAX_AUDIT_LOG=1024
4CONFIG_SECURITY_TOMOYO_POLICY_LOADER="/sbin/ccs-init"
5CONFIG_SECURITY_TOMOYO_ACTIVATION_TRIGGER="/sbin/init"
6CONFIG_DEFAULT_SECURITY_TOMOYO=y
7CONFIG_DEFAULT_SECURITY="tomoyo"
diff --git a/recipes-kernel/linux/linux-yocto/tomoyo.scc b/recipes-kernel/linux/linux-yocto/tomoyo.scc
new file mode 100644
index 0000000..9080934
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto/tomoyo.scc
@@ -0,0 +1,4 @@
1define KFEATURE_DESCRIPTION "Toyomo Kernel Support"
2define KFEATURE_COMPATIBILITY arch
3
4kconf non-hardware toyomo.cfg
diff --git a/recipes-kernel/linux/linux-yocto_3.14.bbappend b/recipes-kernel/linux/linux-yocto_3.14.bbappend
new file mode 100644
index 0000000..b46419c
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -0,0 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3# Tomoyo kernel support
4SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tomoyo', ' file://tomoyo.cfg', '', d)}"