summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2021-03-06 22:10:08 +0000
committerArmin Kuster <akuster808@gmail.com>2021-03-09 08:52:21 -0800
commitb246b2d696d764a5e99f2727638e232c2490c6c0 (patch)
treed438ebf12091a522604183591495437157e4bce0
parentef93f8c9068d53e9e77e716b70fffe4d7cc03682 (diff)
downloadmeta-security-b246b2d696d764a5e99f2727638e232c2490c6c0.tar.gz
tpm2-tss: update to 3.0.3
include automate 2.70 fix Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-tpm/recipes-tpm2/tpm2-tss/tpm2-tss/0001-configure.ac-fix-compatibility-with-autoconf-2.70.patch48
-rw-r--r--meta-tpm/recipes-tpm2/tpm2-tss/tpm2-tss_3.0.3.bb (renamed from meta-tpm/recipes-tpm2/tpm2-tss/tpm2-tss_2.4.3.bb)6
2 files changed, 52 insertions, 2 deletions
diff --git a/meta-tpm/recipes-tpm2/tpm2-tss/tpm2-tss/0001-configure.ac-fix-compatibility-with-autoconf-2.70.patch b/meta-tpm/recipes-tpm2/tpm2-tss/tpm2-tss/0001-configure.ac-fix-compatibility-with-autoconf-2.70.patch
new file mode 100644
index 0000000..cae2e76
--- /dev/null
+++ b/meta-tpm/recipes-tpm2/tpm2-tss/tpm2-tss/0001-configure.ac-fix-compatibility-with-autoconf-2.70.patch
@@ -0,0 +1,48 @@
1From 03cca78d24d716eec792f86f5b0bc69886fad981 Mon Sep 17 00:00:00 2001
2From: Patrick McCarty <patrick.mccarty@intel.com>
3Date: Fri, 18 Dec 2020 01:54:05 +0000
4Subject: [PATCH] configure.ac: fix compatibility with autoconf 2.70
5
6With autoconf 2.70, not quoting the second argument to one of the AS_IF
7macro expansions leads to generation of invalid shell code affecting the
8first nested ERROR_IF_NO_PROG expansion.
9
10The invalid shell code leads to an error resembling:
11
12 ./configure: line 18826: syntax error near unexpected token `newline'
13 ./configure: line 18826: ` '''
14
15Fix the issue by quoting the second argument to the affected AS_IF,
16similar to the quoting found elsewhere in configure.ac.
17
18Signed-off-by: Patrick McCarty <patrick.mccarty@intel.com>
19
20Upstream-Status: Backport
21Signed-off-by: Armin Kuster <akuster808@gmail.com>
22
23---
24 configure.ac | 4 ++--
25 1 file changed, 2 insertions(+), 2 deletions(-)
26
27Index: tpm2-tss-3.0.3/configure.ac
28===================================================================
29--- tpm2-tss-3.0.3.orig/configure.ac
30+++ tpm2-tss-3.0.3/configure.ac
31@@ -279,7 +279,7 @@ AC_ARG_ENABLE([integration],
32 [build and execute integration tests])],,
33 [enable_integration=no])
34 AS_IF([test "x$enable_integration" = "xyes"],
35- AS_IF([test "$HOSTOS" = "Linux"],
36+ [AS_IF([test "$HOSTOS" = "Linux"],
37 [ERROR_IF_NO_PROG([ss])],
38 [ERROR_IF_NO_PROG([sockstat])])
39 ERROR_IF_NO_PROG([echo])
40@@ -328,7 +328,7 @@ AS_IF([test "x$enable_integration" = "xy
41 [AC_MSG_ERROR([No simulator executable found in PATH for testing TCTI.])])
42 AC_SUBST([INTEGRATION_TCTI], [$integration_tcti])
43 AC_SUBST([INTEGRATION_ARGS], [$integration_args])
44- AC_SUBST([ENABLE_INTEGRATION], [$enable_integration]))
45+ AC_SUBST([ENABLE_INTEGRATION], [$enable_integration])])
46 AM_CONDITIONAL([ENABLE_INTEGRATION],[test "x$enable_integration" = "xyes"])
47 #
48 # sanitizer compiler flags
diff --git a/meta-tpm/recipes-tpm2/tpm2-tss/tpm2-tss_2.4.3.bb b/meta-tpm/recipes-tpm2/tpm2-tss/tpm2-tss_3.0.3.bb
index 78be513..b2486e5 100644
--- a/meta-tpm/recipes-tpm2/tpm2-tss/tpm2-tss_2.4.3.bb
+++ b/meta-tpm/recipes-tpm2/tpm2-tss/tpm2-tss_3.0.3.bb
@@ -6,8 +6,10 @@ SECTION = "tpm"
6 6
7DEPENDS = "autoconf-archive-native libgcrypt openssl" 7DEPENDS = "autoconf-archive-native libgcrypt openssl"
8 8
9SRC_URI = "https://github.com/tpm2-software/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.gz" 9SRC_URI = "https://github.com/tpm2-software/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.gz \
10SRC_URI[sha256sum] = "e294677f8993234d0adfa191a5cbf9c5b83cc60c724c233e3d631c26712abea0" 10 file://0001-configure.ac-fix-compatibility-with-autoconf-2.70.patch \
11 "
12SRC_URI[sha256sum] = "78392be7309baf47f51b122f566ac915fd4d1760ea78571cba2e1484f9b5be17"
11 13
12inherit autotools pkgconfig systemd extrausers 14inherit autotools pkgconfig systemd extrausers
13 15