summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-03-13 08:23:25 -0700
committerArmin Kuster <akuster808@gmail.com>2015-03-20 09:53:41 -0700
commit14d6027b9ef4eddff43bec65c45e3baa39bee8b7 (patch)
tree41ec90d54d2cbd3ccc2c3fa95d8631b25977a5f7
parent7b1d78f1b9e8fa06b216a5c960f294d9227db6e0 (diff)
downloadmeta-security-14d6027b9ef4eddff43bec65c45e3baa39bee8b7.tar.gz
libseccomp: update to version 2.2.0
License is now LGPL sources come from github now dropped patches since alt solutions included now. Changes in the 2.2.0 release include: * Migrated the build system to autotools * Added support for the aarch64 architecture * Added support for the mips, mips64, and mips64n32 architectures * Added support for the new seccomp() syscall and thread sync * Added Python bindings * Updated the internal syscall tables to Linux v3.19 Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-security/libseccomp/libseccomp_2.1.1.bb37
-rw-r--r--recipes-security/libseccomp/libseccomp_2.2.0.bb23
2 files changed, 23 insertions, 37 deletions
diff --git a/recipes-security/libseccomp/libseccomp_2.1.1.bb b/recipes-security/libseccomp/libseccomp_2.1.1.bb
deleted file mode 100644
index 2d93479..0000000
--- a/recipes-security/libseccomp/libseccomp_2.1.1.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3SECTION = "security"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
6
7SRC_URI = "http://sourceforge.net/projects/libseccomp/files/${BP}.tar.gz \
8 file://compiler.patch \
9 file://0001-tests-create-install-tests-target.patch \
10 file://0002-tests-install-python-tests-if-appropriate.patch \
11 file://0003-tests-introduce-alternate-test-report-format.patch \
12"
13
14SRC_URI[md5sum] = "1f41207b29e66a7e5e375dd48a64de85"
15SRC_URI[sha256sum] = "8812c11e407c383f5ad6afb84a88e5a0224477bcfe8ff03f0c548e5abaac841c"
16
17do_configure() {
18 ${S}/configure --prefix=${prefix} --libdir=${libdir}
19}
20
21do_compile_append() {
22 oe_runmake DESTDIR=${D} tests
23}
24
25do_install() {
26 oe_runmake DESTDIR=${D} install
27 oe_runmake DESTDIR=${D} install-tests
28}
29
30# MIPS, aarch64, and PowerPC are not supported in this version.
31COMPATIBLE_HOST = '(x86_64|i.86|arm).*-linux'
32
33PACKAGES += "${PN}-tests "
34FILES_${PN}-tests = "${libdir}/${BPN}/tests/*"
35FILES_${PN}-dbg += "${libdir}/${BPN}/tests/.debug/*"
36
37RDEPENDS_${PN} = "bash"
diff --git a/recipes-security/libseccomp/libseccomp_2.2.0.bb b/recipes-security/libseccomp/libseccomp_2.2.0.bb
new file mode 100644
index 0000000..fb29e6c
--- /dev/null
+++ b/recipes-security/libseccomp/libseccomp_2.2.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3SECTION = "security"
4LICENSE = "LGPL-2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
6
7SRCREV = "bd10aab13c7248cc0df57512617e33d6743d33a6"
8
9PV = "2.2.0+git${SRCPV}"
10
11SRC_URI = "git://github.com/seccomp/libseccomp.git;protocol=http"
12
13S = "${WORKDIR}/git"
14
15inherit autotools-brokensep pkgconfig
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[python] = "--enable-python, --disable-python, python"
19
20# PowerPC is not supported in this version.
21COMPATIBLE_HOST = '(x86_64|i.86|arm|arm64|mips|mips64).*-linux'
22
23RDEPENDS_${PN} = "bash"