summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorniko.mauno@vaisala.com <niko.mauno@vaisala.com>2020-09-10 16:17:51 +0000
committerArmin Kuster <akuster808@gmail.com>2020-10-16 07:16:05 -0700
commit9e8522aeb5aaa5a2f57d4c291ab8e301be440fc4 (patch)
tree43370b352f8c00153031bf0e44ddd312f39a8496
parent6b600629c6031f53a5d07e0decf1a9c7fdfd6616 (diff)
downloadmeta-security-9e8522aeb5aaa5a2f57d4c291ab8e301be440fc4.tar.gz
dm-verity-image-initramfs: Bind at do_image instead
Bind custom actions in this image recipe in do_image() rather than do_rootfs(), which can help shaving even dozens of seconds from duration of 'bitbake <DM_VERITY_IMAGE>' command re-execution. Signed-off-by: Niko Mauno <niko.mauno@vaisala.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> (cherry picked from commit 03fdaf2f0464b28ab69114330a543b3c64c19a5d)
-rw-r--r--recipes-core/images/dm-verity-image-initramfs.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-core/images/dm-verity-image-initramfs.bb b/recipes-core/images/dm-verity-image-initramfs.bb
index 60e9892..8dd8543 100644
--- a/recipes-core/images/dm-verity-image-initramfs.bb
+++ b/recipes-core/images/dm-verity-image-initramfs.bb
@@ -14,10 +14,10 @@ PACKAGE_INSTALL = " \
14" 14"
15 15
16# Can we somehow inspect reverse dependencies to avoid these variables? 16# Can we somehow inspect reverse dependencies to avoid these variables?
17do_rootfs[depends] += "${DM_VERITY_IMAGE}:do_image_${DM_VERITY_IMAGE_TYPE}" 17do_image[depends] += "${DM_VERITY_IMAGE}:do_image_${DM_VERITY_IMAGE_TYPE}"
18 18
19# Ensure dm-verity.env is updated also when rebuilding DM_VERITY_IMAGE 19# Ensure dm-verity.env is updated also when rebuilding DM_VERITY_IMAGE
20do_rootfs[nostamp] = "1" 20do_image[nostamp] = "1"
21 21
22IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" 22IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
23 23
@@ -26,4 +26,4 @@ inherit core-image
26deploy_verity_hash() { 26deploy_verity_hash() {
27 install -D -m 0644 ${DEPLOY_DIR_IMAGE}/${DM_VERITY_IMAGE}-${MACHINE}.${DM_VERITY_IMAGE_TYPE}.verity.env ${IMAGE_ROOTFS}/${datadir}/dm-verity.env 27 install -D -m 0644 ${DEPLOY_DIR_IMAGE}/${DM_VERITY_IMAGE}-${MACHINE}.${DM_VERITY_IMAGE_TYPE}.verity.env ${IMAGE_ROOTFS}/${datadir}/dm-verity.env
28} 28}
29ROOTFS_POSTPROCESS_COMMAND += "deploy_verity_hash;" 29IMAGE_PREPROCESS_COMMAND += "deploy_verity_hash;"