summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-02-27 15:26:46 +0000
committerAndrei Gherzan <andrei@gherzan.ro>2016-02-28 12:48:20 +0100
commitc65b0b8c3ff4e06febaf9c104d191fcc6dd816eb (patch)
tree1f7c7ee97580a2c25b90241c23e770f540e3ada6 /recipes-devtools
parentbcb26ed634b82b9ab76255d36e558cfe6a2f0ed0 (diff)
downloadmeta-raspberrypi-c65b0b8c3ff4e06febaf9c104d191fcc6dd816eb.tar.gz
python-rtimu: Fix build with musl
ioctl(3) needs to include asm/ioctl.h for its signature Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch33
-rw-r--r--recipes-devtools/python/python-rtimu_git.bb4
2 files changed, 36 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch b/recipes-devtools/python/python-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch
new file mode 100644
index 0000000..4a93a1c
--- /dev/null
+++ b/recipes-devtools/python/python-rtimu/0001-include-asm-ioctl.h-for-ioctl-define.patch
@@ -0,0 +1,33 @@
1From c3aa4af56652b403e304ea5f321acfe289e42922 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 30 Jan 2016 16:07:14 -0800
4Subject: [PATCH] include asm/ioctl.h for ioctl() define
5
6also fixes errors e.g.
7
8../../RTIMULib/RTIMUHal.cpp:208:29: error: '_IOC_SIZEBITS' was not
9declared in this scope
10 return ioctl(m_SPI, SPI_IOC_MESSAGE(1), &wrIOC);
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14Upstream-Status: Submitted
15
16 RTIMULib/RTIMUHal.cpp | 1 +
17 1 file changed, 1 insertion(+)
18
19diff --git a/RTIMULib/RTIMUHal.cpp b/RTIMULib/RTIMUHal.cpp
20index f9c3d15..d968326 100644
21--- a/RTIMULib/RTIMUHal.cpp
22+++ b/RTIMULib/RTIMUHal.cpp
23@@ -29,6 +29,7 @@
24 #if !defined(WIN32) && !defined(__APPLE__)
25
26 #include <linux/spi/spidev.h>
27+#include <asm/ioctl.h>
28
29 RTIMUHal::RTIMUHal()
30 {
31--
322.7.0
33
diff --git a/recipes-devtools/python/python-rtimu_git.bb b/recipes-devtools/python/python-rtimu_git.bb
index f51a234..63c92b3 100644
--- a/recipes-devtools/python/python-rtimu_git.bb
+++ b/recipes-devtools/python/python-rtimu_git.bb
@@ -5,7 +5,9 @@ SECTION = "devel/python"
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://../../LICENSE;md5=96cdecb41125f498958e09b72faf318e" 6LIC_FILES_CHKSUM = "file://../../LICENSE;md5=96cdecb41125f498958e09b72faf318e"
7 7
8SRC_URI = "git://github.com/RPi-Distro/RTIMULib.git;protocol=http;branch=master" 8SRC_URI = "git://github.com/RPi-Distro/RTIMULib.git;protocol=http;branch=master \
9 file://0001-include-asm-ioctl.h-for-ioctl-define.patch;patchdir=../.. \
10 "
9SRCREV = "b949681af69b45f0f7f4bb53b6770037b5b02178" 11SRCREV = "b949681af69b45f0f7f4bb53b6770037b5b02178"
10 12
11S = "${WORKDIR}/git/Linux/python/" 13S = "${WORKDIR}/git/Linux/python/"