summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2015-03-02 00:06:16 +0100
committerAndrei Gherzan <andrei@gherzan.ro>2015-03-12 22:20:51 +0100
commitc0ee9c764159e887d99f4a6e0fb3375f053a071f (patch)
treeda618c13239ba42b01443599b639c02653886f5f /recipes-devtools
parentdf7eeb6f86666ed41fa82fe09ee3129d4a207bc5 (diff)
downloadmeta-raspberrypi-c0ee9c764159e887d99f4a6e0fb3375f053a071f.tar.gz
bcm2835: More recipe to devtools
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/bcm2835/bcm2835_1.38.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-devtools/bcm2835/bcm2835_1.38.bb b/recipes-devtools/bcm2835/bcm2835_1.38.bb
new file mode 100644
index 0000000..71395af
--- /dev/null
+++ b/recipes-devtools/bcm2835/bcm2835_1.38.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "Package that provides access to GPIO and other IO\
2functions on the Broadcom BCM 2835 chip, allowing access to the\
3GPIO pins on the 26 pin IDE plug on the RPi board"
4SECTION = "base"
5HOMEPAGE = "http://www.open.com.au/mikem/bcm2835"
6AUTHOR = "Mike McCauley (mikem@open.com.au)"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11COMPATIBLE_MACHINE = "raspberrypi"
12
13SRC_URI = "http://www.open.com.au/mikem/bcm2835/bcm2835-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "22d431f7402b9c7f93baef348a459cb1"
16SRC_URI[sha256sum] = "90c993559ea273ae2e0587f6b815f7c80f19f47ee7f8aa7799b883f975196dbe"
17
18inherit autotools
19
20do_compile_append() {
21 # Now compiling the examples provided by the package
22 mkdir -p ${B}/examples
23 for file in `ls ${S}/examples`; do
24 ${CC} ${S}/examples/${file}/${file}.c -o ${B}/examples/${file} -Bstatic -L${B}/src -lbcm2835 -I${S}/src
25 done
26}
27
28do_install_append() {
29 install -d ${D}/${libdir}/${BPN}
30 for file in ${B}/examples/*
31 do
32 install -m 0755 ${file} ${D}/${libdir}/${BPN}
33 done
34}
35
36PACKAGES += "${PN}-tests"
37
38FILES_${PN} = ""
39FILES_${PN}-tests = "${libdir}/${BPN}"
40FILES_${PN}-dbg += "${libdir}/${BPN}/.debug"