summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-02-27 15:26:49 +0000
committerAndrei Gherzan <andrei@gherzan.ro>2016-02-28 12:48:20 +0100
commitbcb26ed634b82b9ab76255d36e558cfe6a2f0ed0 (patch)
treef6bf68e97dac55a27e805c782eb2704fadfe7598 /recipes-devtools
parent9295c7fd71c4032fc71a2516d70f4f3e50b1cad0 (diff)
downloadmeta-raspberrypi-bcb26ed634b82b9ab76255d36e558cfe6a2f0ed0.tar.gz
rpio: Include sys/types.h for caddr_t
Fixes build with musl Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/rpio/0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch30
-rw-r--r--recipes-devtools/python/rpio_0.10.0.bb6
2 files changed, 33 insertions, 3 deletions
diff --git a/recipes-devtools/python/rpio/0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch b/recipes-devtools/python/rpio/0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch
new file mode 100644
index 0000000..bed9749
--- /dev/null
+++ b/recipes-devtools/python/rpio/0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch
@@ -0,0 +1,30 @@
1From c86bfacc98d58244f532626954ed00d84ecfa82d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 30 Jan 2016 17:12:37 -0800
4Subject: [PATCH] include sys/types.h explicitly for getting caddr_t definition
5
6Helps fixing build on musl where sys/types.h is not included indirectly
7as happening on glibc
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11Upstream-Status: Submitted
12
13 source/c_gpio/c_gpio.c | 1 +
14 1 file changed, 1 insertion(+)
15
16diff --git a/source/c_gpio/c_gpio.c b/source/c_gpio/c_gpio.c
17index 25a04ca..70df632 100644
18--- a/source/c_gpio/c_gpio.c
19+++ b/source/c_gpio/c_gpio.c
20@@ -29,6 +29,7 @@
21 #include <stdint.h>
22 #include <stdlib.h>
23 #include <fcntl.h>
24+#include <sys/types.h>
25 #include <sys/mman.h>
26 #include "c_gpio.h"
27
28--
292.7.0
30
diff --git a/recipes-devtools/python/rpio_0.10.0.bb b/recipes-devtools/python/rpio_0.10.0.bb
index 1cc1661..69ecb6f 100644
--- a/recipes-devtools/python/rpio_0.10.0.bb
+++ b/recipes-devtools/python/rpio_0.10.0.bb
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://README.rst;beginline=41;endline=53;md5=d5d95d7486a4d9
7 7
8SRCNAME = "RPIO" 8SRCNAME = "RPIO"
9 9
10SRC_URI = "\ 10SRC_URI = "http://pypi.python.org/packages/source/R/RPIO/${SRCNAME}-${PV}.tar.gz \
11 http://pypi.python.org/packages/source/R/RPIO/${SRCNAME}-${PV}.tar.gz \ 11 file://0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch \
12 " 12 "
13S = "${WORKDIR}/${SRCNAME}-${PV}" 13S = "${WORKDIR}/${SRCNAME}-${PV}"
14 14
15inherit setuptools 15inherit setuptools