summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2016-09-16 17:52:43 +0100
committerAndrei Gherzan <andrei@gherzan.ro>2016-09-21 11:38:22 +0100
commita5f9b07a820d50ae5fb62e07306cd4e72d8638a9 (patch)
treed2e08f059ed46a6aa185f13d826d81619c415dd5 /recipes-devtools
parent8c5eba1d94ef8059f96fcb38ce02d89beb752411 (diff)
downloadmeta-raspberrypi-a5f9b07a820d50ae5fb62e07306cd4e72d8638a9.tar.gz
bcm2835: Compile examples correct LDFLAGS to avoid HASH errorskrogoth
ERROR: bcm2835-1.50-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: 'build-rpi-master/tmp/work/cortexa7hf-neon-vfpv4-poky-linux-gnueabi/bcm2835/1.50-r0/packages-split/bcm2835-tests/usr/lib/bcm2835/spi' No GNU_HASH in the elf binary: 'build-rpi-master/tmp/work/cortexa7hf-neon-vfpv4-poky-linux-gnueabi/bcm2835/1.50-r0/packages-split/bcm2835-tests/usr/lib/bcm2835/event' No GNU_HASH in the elf binary: 'build-rpi-master/tmp/work/cortexa7hf-neon-vfpv4-poky-linux-gnueabi/bcm2835/1.50-r0/packages-split/bcm2835-tests/usr/lib/bcm2835/gpio' No GNU_HASH in the elf binary: 'build-rpi-master/tmp/work/cortexa7hf-neon-vfpv4-poky-linux-gnueabi/bcm2835/1.50-r0/packages-split/bcm2835-tests/usr/lib/bcm2835/i2c' No GNU_HASH in the elf binary: 'build-rpi-master/tmp/work/cortexa7hf-neon-vfpv4-poky-linux-gnueabi/bcm2835/1.50-r0/packages-split/bcm2835-tests/usr/lib/bcm2835/blink' No GNU_HASH in the elf binary: 'build-rpi-master/tmp/work/cortexa7hf-neon-vfpv4-poky-linux-gnueabi/bcm2835/1.50-r0/packages-split/bcm2835-tests/usr/lib/bcm2835/spin' No GNU_HASH in the elf binary: 'build-rpi-master/tmp/work/cortexa7hf-neon-vfpv4-poky-linux-gnueabi/bcm2835/1.50-r0/packages-split/bcm2835-tests/usr/lib/bcm2835/input' No GNU_HASH in the elf binary: 'build-rpi-master/tmp/work/cortexa7hf-neon-vfpv4-poky-linux-gnueabi/bcm2835/1.50-r0/packages-split/bcm2835-tests/usr/lib/bcm2835/pwm' [ldflags] Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/bcm2835/bcm2835_1.50.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/bcm2835/bcm2835_1.50.bb b/recipes-devtools/bcm2835/bcm2835_1.50.bb
index 634dac8..9cf6f48 100644
--- a/recipes-devtools/bcm2835/bcm2835_1.50.bb
+++ b/recipes-devtools/bcm2835/bcm2835_1.50.bb
@@ -21,7 +21,7 @@ do_compile_append() {
21 # Now compiling the examples provided by the package 21 # Now compiling the examples provided by the package
22 mkdir -p ${B}/examples 22 mkdir -p ${B}/examples
23 for file in `ls ${S}/examples`; do 23 for file in `ls ${S}/examples`; do
24 ${CC} ${S}/examples/${file}/${file}.c -o ${B}/examples/${file} -Bstatic -L${B}/src -lbcm2835 -I${S}/src 24 ${CC} ${LDFLAGS} ${S}/examples/${file}/${file}.c -o ${B}/examples/${file} -Bstatic -L${B}/src -lbcm2835 -I${S}/src
25 done 25 done
26} 26}
27 27