summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorLeon Anavi <leon@anavi.org>2015-12-20 22:53:16 +0200
committerAndrei Gherzan <andrei@gherzan.ro>2016-01-10 19:55:25 +0100
commit70e7860820f13ec7ad701fe458e6669848746bc7 (patch)
treef1d5e4a23632ced8f568dea918a454b88a0490f2 /recipes-devtools
parent509f042280dfa603484df6a35b265a453d1bff7a (diff)
downloadmeta-raspberrypi-70e7860820f13ec7ad701fe458e6669848746bc7.tar.gz
python-rtimu: Add recipe to support RTIMULib
RTIMULib is a C++ and Python library that makes it easy to use 9-dof and 10-dof IMUs with embedded Linux systems. Python module for Raspberry Pi Sense HAT depends on it. Python module python-rtimu uses the source code from the GitHub repository of RPi-Distro. Signed-off-by: Leon Anavi <leon@anavi.org> Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-rtimu_git.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-rtimu_git.bb b/recipes-devtools/python/python-rtimu_git.bb
new file mode 100644
index 0000000..f51a234
--- /dev/null
+++ b/recipes-devtools/python/python-rtimu_git.bb
@@ -0,0 +1,13 @@
1DESCRIPTION = "RTIMULib is a C++ and Python library that makes it easy to use 9-dof and \
210-dof IMUs with embedded Linux systems"
3HOMEPAGE = "https://github.com/RPi-Distro/RTIMULib/"
4SECTION = "devel/python"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://../../LICENSE;md5=96cdecb41125f498958e09b72faf318e"
7
8SRC_URI = "git://github.com/RPi-Distro/RTIMULib.git;protocol=http;branch=master"
9SRCREV = "b949681af69b45f0f7f4bb53b6770037b5b02178"
10
11S = "${WORKDIR}/git/Linux/python/"
12
13inherit setuptools