summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorLeon Anavi <leon@anavi.org>2015-12-20 23:58:30 +0200
committerAndrei Gherzan <andrei@gherzan.ro>2016-01-10 19:53:25 +0100
commit509f042280dfa603484df6a35b265a453d1bff7a (patch)
treecefed4a89694d9ec3c1c7ebb3057fa3700c7fa2f /recipes-devtools
parentf2cff839f52a6e6211337fc45c7c3eabf0fac113 (diff)
downloadmeta-raspberrypi-509f042280dfa603484df6a35b265a453d1bff7a.tar.gz
python-sense-hat: Add recipe to support Raspberry Pi Sense HAT
Python module to control the Raspberry Pi Sense HAT used in the Astro Pi mission. This recipe provides the officially supported library for the Sense HAT with access to all of the on-board sensors and the LED matrix. Signed-off-by: Leon Anavi <leon@anavi.org> Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-sense-hat_2.1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-sense-hat_2.1.0.bb b/recipes-devtools/python/python-sense-hat_2.1.0.bb
new file mode 100644
index 0000000..e990a28
--- /dev/null
+++ b/recipes-devtools/python/python-sense-hat_2.1.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Python module to control the Raspberry Pi Sense HAT used in the Astro Pi mission"
2HOMEPAGE = "https://github.com/RPi-Distro/python-sense-hat"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=d80fe312e1ff5fbd97369b093bf21cda"
6
7SRCNAME = "sense-hat"
8
9SRC_URI = "https://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "71217f15ea963040f06e2f50722186ca"
12SRC_URI[sha256sum] = "c6c76707c0ea514e4b0f1f96f1b5b79755875891aae037df7434b6aad7b9dbca"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18DEPENDS += " \
19 jpeg \
20 zlib \
21 freetype \
22 "
23
24RDEPENDS_${PN} += " \
25 python-numpy \
26 python-rtimu \
27 python-imaging \
28 "