summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorPetter Mabäcker <petter@technux.se>2015-07-08 18:10:37 +0200
committerAndrei Gherzan <andrei@gherzan.ro>2015-07-19 14:51:35 +0200
commit27a8acecf516dbda031effe0e736c2bf63d77f7c (patch)
treec86cfcfa8570c2cef819457f19eede9664c503a6 /recipes-devtools
parent5f057d9343c7c42137316a0126ae3835d48592e1 (diff)
downloadmeta-raspberrypi-27a8acecf516dbda031effe0e736c2bf63d77f7c.tar.gz
pi-blaster: bump to latest version
Removed 'enable-autotools-support.patch' since it is included in latest upstream. Also fix a cross compiling issue. [Support #60] Signed-off-by: Petter Mabäcker <petter@technux.se> Acked-by: Andrei Gherzan <andrei@gherzan.ro>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/pi-blaster/files/0001-handle-install-data-hook-when-cross-compile.patch54
-rw-r--r--recipes-devtools/pi-blaster/files/enable-autotools-support.patch77
-rw-r--r--recipes-devtools/pi-blaster/pi-blaster.inc4
-rw-r--r--recipes-devtools/pi-blaster/pi-blaster_git.bb2
4 files changed, 57 insertions, 80 deletions
diff --git a/recipes-devtools/pi-blaster/files/0001-handle-install-data-hook-when-cross-compile.patch b/recipes-devtools/pi-blaster/files/0001-handle-install-data-hook-when-cross-compile.patch
new file mode 100644
index 0000000..2f2a7f4
--- /dev/null
+++ b/recipes-devtools/pi-blaster/files/0001-handle-install-data-hook-when-cross-compile.patch
@@ -0,0 +1,54 @@
1From 28e4bc3216f8845cf278f0fbc6b2c30eebcc35aa Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Petter=20Mab=C3=A4cker?= <petter@technux.se>
3Date: Sun, 7 Jun 2015 17:17:01 +0200
4Subject: [PATCH] handle install-data-hook when cross compile
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Avoid doing 'install-data-hook' when cross compiling since it isn't
10suitable to update rc.d or run the service when cross
11compiling.
12
13Upstream-Status: Pending
14
15Signed-off-by: Petter Mabäcker <petter@technux.se>
16---
17 Makefile.am | 4 +++-
18 configure.ac | 1 +
19 2 files changed, 4 insertions(+), 1 deletion(-)
20
21diff --git a/Makefile.am b/Makefile.am
22index 6693d46..935288f 100644
23--- a/Makefile.am
24+++ b/Makefile.am
25@@ -13,6 +13,7 @@ else
26 init_ddir = $(sysconfdir)/init.d
27 init_d_SCRIPTS = pi-blaster.boot.sh
28
29+if !CROSS_COMPILING
30 install-data-hook:
31 update-rc.d pi-blaster.boot.sh defaults
32 $(init_ddir)/pi-blaster.boot.sh start
33@@ -20,4 +21,5 @@ install-data-hook:
34 uninstall-hook:
35 update-rc.d pi-blaster.boot.sh remove
36 killall pi-blaster
37-endif
38+endif # !CROSS_COMPILING
39+endif # !HAVE_SYSTEMD
40diff --git a/configure.ac b/configure.ac
41index 5d0c1fa..aaf4465 100644
42--- a/configure.ac
43+++ b/configure.ac
44@@ -23,6 +23,7 @@ if test "x$with_systemdsystemunitdir" != xno; then
45 AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
46 fi
47 AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != xno ])
48+AM_CONDITIONAL(CROSS_COMPILING, [test x"$cross_compiling" = x"yes" ])
49
50 # Checks for programs.
51 AC_PROG_CC
52--
531.9.1
54
diff --git a/recipes-devtools/pi-blaster/files/enable-autotools-support.patch b/recipes-devtools/pi-blaster/files/enable-autotools-support.patch
deleted file mode 100644
index f0d4958..0000000
--- a/recipes-devtools/pi-blaster/files/enable-autotools-support.patch
+++ /dev/null
@@ -1,77 +0,0 @@
1Add autotools configuration files to simplify cross-compilation
2
3Upstream-Status: Submitted [https://github.com/sarfata/pi-blaster/pull/25]
4
5Signed-off-by: Alex Lennon <ajlennon@dynamicdevices.co.uk>
6
7diff -Nur git.org/Makefile git.new/Makefile
8--- git.org/Makefile 2014-06-11 15:42:26.490930706 +0100
9+++ git.new/Makefile 1970-01-01 01:00:00.000000000 +0100
10@@ -1,23 +0,0 @@
11-.PHONY: all
12-all: pi-blaster
13-
14-REVISION=$(shell egrep -q '000f$$' /proc/cpuinfo && echo 2 || echo 1)
15-
16-pi-blaster: pi-blaster.c
17- gcc -Wall -g -O2 -o $@ $< -DREVISION=$(REVISION)
18-
19-clean:
20- rm -f pi-blaster
21-
22-install: pi-blaster
23- cp -f pi-blaster.boot.sh /etc/init.d/pi-blaster
24- chmod +x /etc/init.d/pi-blaster
25- cp -f pi-blaster /usr/sbin/pi-blaster
26- update-rc.d pi-blaster defaults
27- /etc/init.d/pi-blaster start
28-
29-uninstall:
30- -/etc/init.d/pi-blaster stop
31- rm /usr/sbin/pi-blaster
32- rm /etc/init.d/pi-blaster
33- update-rc.d pi-blaster remove
34diff -Nur git.org/Makefile.am git.new/Makefile.am
35--- git.org/Makefile.am 1970-01-01 01:00:00.000000000 +0100
36+++ git.new/Makefile.am 2014-06-11 15:40:16.562930372 +0100
37@@ -0,0 +1,9 @@
38+AUTOMAKE_OPTIONS = foreign
39+
40+CFLAGS = -Wall -pedantic
41+
42+sbin_PROGRAMS = pi-blaster
43+pi_blaster_SOURCES = pi-blaster.c
44+
45+init_ddir = $(sysconfdir)/init.d
46+init_d_SCRIPTS = pi-blaster.boot.sh
47diff -Nur git.org/autogen.sh git.new/autogen.sh
48--- git.org/autogen.sh 1970-01-01 01:00:00.000000000 +0100
49+++ git.new/autogen.sh 2014-06-11 15:35:57.798929684 +0100
50@@ -0,0 +1,9 @@
51+#!/bin/sh
52+
53+echo "Generating configure files... may take a while."
54+
55+autoreconf --install --force && \
56+ echo "Preparing was successful if there was no error messages above." && \
57+ echo "Now type:" && \
58+ echo " ./configure && make" && \
59+ echo "Run './configure --help' for more information"
60diff -Nur git.org/configure.ac git.new/configure.ac
61--- git.org/configure.ac 1970-01-01 01:00:00.000000000 +0100
62+++ git.new/configure.ac 2014-06-11 15:35:53.154929717 +0100
63@@ -0,0 +1,14 @@
64+# -*- Autoconf -*-
65+# Process this file with autoconf to produce a configure script.
66+
67+AC_PREREQ([2.69])
68+AC_INIT(pi-blaster, 0.1.0)
69+AC_CONFIG_SRCDIR([pi-blaster.c])
70+AC_CONFIG_HEADERS([config.h])
71+AM_INIT_AUTOMAKE
72+
73+# Checks for programs.
74+AC_PROG_CC
75+
76+AC_CONFIG_FILES([Makefile])
77+AC_OUTPUT
diff --git a/recipes-devtools/pi-blaster/pi-blaster.inc b/recipes-devtools/pi-blaster/pi-blaster.inc
index 04a7b5e..1f4cc2f 100644
--- a/recipes-devtools/pi-blaster/pi-blaster.inc
+++ b/recipes-devtools/pi-blaster/pi-blaster.inc
@@ -2,11 +2,11 @@ DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspbe
2HOMEPAGE = "https://github.com/sarfata/pi-blaster/" 2HOMEPAGE = "https://github.com/sarfata/pi-blaster/"
3SECTION = "devel/libs" 3SECTION = "devel/libs"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://README.md;beginline=138;endline=151;md5=e0f0f92050a87a160939707c60940307" 5LIC_FILES_CHKSUM = "file://README.md;beginline=157;endline=170;md5=f20832f31126609af5a7bf2340014540"
6 6
7SRC_URI = "git://github.com/sarfata/pi-blaster \ 7SRC_URI = "git://github.com/sarfata/pi-blaster \
8 file://enable-autotools-support.patch \
9 file://remove-initscript-lsb-dependency.patch \ 8 file://remove-initscript-lsb-dependency.patch \
9 file://0001-handle-install-data-hook-when-cross-compile.patch \
10" 10"
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
diff --git a/recipes-devtools/pi-blaster/pi-blaster_git.bb b/recipes-devtools/pi-blaster/pi-blaster_git.bb
index 25eb382..3ae7c49 100644
--- a/recipes-devtools/pi-blaster/pi-blaster_git.bb
+++ b/recipes-devtools/pi-blaster/pi-blaster_git.bb
@@ -1,3 +1,3 @@
1require pi-blaster.inc 1require pi-blaster.inc
2 2
3SRCREV = "177cef81774d6df5c6284c198ff818515281db14" 3SRCREV = "cd318cd63031a30249a4c08435b97263fa76d7b7"