summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2012-08-21 00:25:26 +0300
committerAndrei Gherzan <andrei@gherzan.ro>2012-08-29 00:04:19 +0300
commit2176dc0bbf7e5ce63f8a25d9cab873a1c651ec3a (patch)
treea24e0dfbbb93aaadf3d65dfdfbafb02b11aa3fe0 /recipes-devtools
parent32d2d1bcde24fa95d0771d5a7ae8b64c293083e0 (diff)
downloadmeta-raspberrypi-2176dc0bbf7e5ce63f8a25d9cab873a1c651ec3a.tar.gz
RPI.GPIO: Integrate v0.2.0
Patch was added to use setuptools that we already have integrated in yocto and not the one provided in package. In his way we can use setuptools bbclass. [GITHUB #36] Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/RPi-GPIO/don-t-install-setuptools.patch16
-rw-r--r--recipes-devtools/python/RPi-GPIO_0.2.0.bb21
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-devtools/python/RPi-GPIO/don-t-install-setuptools.patch b/recipes-devtools/python/RPi-GPIO/don-t-install-setuptools.patch
new file mode 100644
index 0000000..bc71443
--- /dev/null
+++ b/recipes-devtools/python/RPi-GPIO/don-t-install-setuptools.patch
@@ -0,0 +1,16 @@
1We already have setuptools python module so we will use that and not the
2one provided in this package.
3
4Upstream-Status: Inappropriate [embedded specific]
5Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
6
7Index: RPi.GPIO-0.2.0/setup.py
8===================================================================
9--- RPi.GPIO-0.2.0.orig/setup.py 2012-05-24 13:17:31.000000000 +0300
10+++ RPi.GPIO-0.2.0/setup.py 2012-08-22 00:56:59.049001018 +0300
11@@ -1,6 +1,4 @@
12 #!/usr/bin/env python
13-import distribute_setup
14-distribute_setup.use_setuptools()
15 from setuptools import setup, find_packages
16 import platform
diff --git a/recipes-devtools/python/RPi-GPIO_0.2.0.bb b/recipes-devtools/python/RPi-GPIO_0.2.0.bb
new file mode 100644
index 0000000..73122cd
--- /dev/null
+++ b/recipes-devtools/python/RPi-GPIO_0.2.0.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
2HOMEPAGE = "http://code.google.com/p/raspberry-gpio-python/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=ee5754ae9d5f8061d6d4ccd9c9fe0061"
6
7SRCNAME = "RPi.GPIO"
8PR = "r0"
9
10SRC_URI = "\
11 http://pypi.python.org/packages/source/R/RPi.GPIO/${SRCNAME}-${PV}.tar.gz \
12 file://don-t-install-setuptools.patch \
13 "
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18COMPATIBLE_MACHINE = "raspberrypi"
19
20SRC_URI[md5sum] = "0fc4bfa6aabc856b0b75252a40ac75cc"
21SRC_URI[sha256sum] = "fcfd97dc9687dde76b13b9d12c122e71b13e2ba09a62913d7b8d9ddbb3e8cabf"