summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorFabien Lahoudere <fabien.lahoudere@collabora.com>2018-11-16 16:10:54 +0100
committerAndrei Gherzan <andrei@gherzan.ro>2018-12-12 16:24:17 +0000
commit12e61faf30b08909b58ed87b9542f2753d0249dc (patch)
tree26d3567b9d91b684319e97b35666b41d9fc09d70 /recipes-core
parent1803681e8477394953833a82a9c0f4b0934bdaa0 (diff)
downloadmeta-raspberrypi-12e61faf30b08909b58ed87b9542f2753d0249dc.tar.gz
Add Pican2 support
In order to make Pican 2 work, we : - add mcp2515.dto to the overlay list - add a variable to enable it in local.conf - create a udev rule to mount interface http://skpang.co.uk/catalog/pican2-canbus-board-for-raspberry-pi-23-p-1475.html Signed-off-by: Fabien Lahoudere <fabien.lahoudere@collabora.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/udev/udev-rules-rpi.bb6
-rw-r--r--recipes-core/udev/udev-rules-rpi/can.rules1
2 files changed, 6 insertions, 1 deletions
diff --git a/recipes-core/udev/udev-rules-rpi.bb b/recipes-core/udev/udev-rules-rpi.bb
index edef0db..42cfcdd 100644
--- a/recipes-core/udev/udev-rules-rpi.bb
+++ b/recipes-core/udev/udev-rules-rpi.bb
@@ -2,7 +2,10 @@ DESCRIPTION = "udev rules for Raspberry Pi Boards"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" 3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4 4
5SRC_URI = " file://99-com.rules" 5SRC_URI = " \
6 file://99-com.rules \
7 file://can.rules \
8 "
6 9
7S = "${WORKDIR}" 10S = "${WORKDIR}"
8 11
@@ -11,4 +14,5 @@ INHIBIT_DEFAULT_DEPS = "1"
11do_install () { 14do_install () {
12 install -d ${D}${sysconfdir}/udev/rules.d 15 install -d ${D}${sysconfdir}/udev/rules.d
13 install -m 0644 ${WORKDIR}/99-com.rules ${D}${sysconfdir}/udev/rules.d/ 16 install -m 0644 ${WORKDIR}/99-com.rules ${D}${sysconfdir}/udev/rules.d/
17 install -m 0644 ${WORKDIR}/can.rules ${D}${sysconfdir}/udev/rules.d/
14} 18}
diff --git a/recipes-core/udev/udev-rules-rpi/can.rules b/recipes-core/udev/udev-rules-rpi/can.rules
new file mode 100644
index 0000000..a47d57d
--- /dev/null
+++ b/recipes-core/udev/udev-rules-rpi/can.rules
@@ -0,0 +1 @@
SUBSYSTEM=="net", DEVPATH=="/devices/platform/soc/3f204000.spi/spi_master/spi0/spi0.0/net/can0", RUN+="/sbin/ip link set can0 up type can bitrate 500000"