summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2019-09-06 11:40:02 +0000
committerAndrei Gherzan <andrei@gherzan.ro>2019-09-09 17:52:40 +0300
commitbfa90d0cf6b219fd2d5e86d4dbf096fa6ff135f3 (patch)
tree22c0a41aa228f0e98157248c951b963b54df8865
parent11eedec46a135f10b41491a606f8ac53b2dbf41e (diff)
downloadmeta-raspberrypi-bfa90d0cf6b219fd2d5e86d4dbf096fa6ff135f3.tar.gz
u-boot-fw-utils: apply the same rpi4 patches as for u-boot recipe
* otherwise u-boot-fw-utils build for rpi4 fails with: scripts/kconfig/conf --defconfig=arch/../configs/rpi_4_defconfig Kconfig *** *** Can't find default configuration "arch/../configs/rpi_4_defconfig"! *** scripts/kconfig/Makefile:128: recipe for target 'rpi_4_defconfig' failed * cannot include/require u-boot_2019.07.bbappend directly in u-boot-fw-utils_2019.07.bbappend, because then it fails with: "u-boot_2019.01.bbappend: not a BitBake file" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-fw-utils_2019.01.bbappend2
-rw-r--r--recipes-bsp/u-boot/u-boot-rpi4-2019.01.inc13
-rw-r--r--recipes-bsp/u-boot/u-boot_2019.01.bbappend15
3 files changed, 17 insertions, 13 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fw-utils_2019.01.bbappend b/recipes-bsp/u-boot/u-boot-fw-utils_2019.01.bbappend
new file mode 100644
index 0000000..3daf157
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fw-utils_2019.01.bbappend
@@ -0,0 +1,2 @@
1# Apply the same patches for rpi4 as u-boot recipe
2require u-boot-rpi4-${PV}.inc
diff --git a/recipes-bsp/u-boot/u-boot-rpi4-2019.01.inc b/recipes-bsp/u-boot/u-boot-rpi4-2019.01.inc
new file mode 100644
index 0000000..e06ebfc
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-rpi4-2019.01.inc
@@ -0,0 +1,13 @@
1FILESEXTRAPATHS_prepend_raspberrypi4 := "${THISDIR}/u-boot-2019.01:"
2UBOOT_RPI4_SUPPORT_PATCHES = " \
3 file://0001-Fix-compilation-error-if-CONFIG_USB-is-disabled.patch \
4 file://0001-configs-rpi4-Add-defconfigs-for-rpi4-32-64.patch \
5 file://0002-ARM-bcm283x-Add-BCM283x_BASE-define.patch \
6 file://0003-arm-mach-bcm283x-Define-configs-for-RaspberryPi-4.patch \
7 file://0004-rpi-Add-entry-for-Raspberry-Pi-4-model-B.patch \
8 file://0005-arm-bcm283x-Include-definition-for-additional-emmc-c.patch \
9 file://0006-mmc-bcm2835_sdhci-Add-support-for-bcm2711-device.patch \
10 file://0007-rpi-Add-memory-map-for-bcm2838.patch \
11"
12
13SRC_URI_append_raspberrypi4 = "${UBOOT_RPI4_SUPPORT_PATCHES}"
diff --git a/recipes-bsp/u-boot/u-boot_2019.01.bbappend b/recipes-bsp/u-boot/u-boot_2019.01.bbappend
index b11dfc2..3daf157 100644
--- a/recipes-bsp/u-boot/u-boot_2019.01.bbappend
+++ b/recipes-bsp/u-boot/u-boot_2019.01.bbappend
@@ -1,13 +1,2 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:" 1# Apply the same patches for rpi4 as u-boot recipe
2UBOOT_RPI4_SUPPORT_PATCHES = " \ 2require u-boot-rpi4-${PV}.inc
3 file://0001-Fix-compilation-error-if-CONFIG_USB-is-disabled.patch \
4 file://0001-configs-rpi4-Add-defconfigs-for-rpi4-32-64.patch \
5 file://0002-ARM-bcm283x-Add-BCM283x_BASE-define.patch \
6 file://0003-arm-mach-bcm283x-Define-configs-for-RaspberryPi-4.patch \
7 file://0004-rpi-Add-entry-for-Raspberry-Pi-4-model-B.patch \
8 file://0005-arm-bcm283x-Include-definition-for-additional-emmc-c.patch \
9 file://0006-mmc-bcm2835_sdhci-Add-support-for-bcm2711-device.patch \
10 file://0007-rpi-Add-memory-map-for-bcm2838.patch \
11"
12
13SRC_URI_append_raspberrypi4 = "${UBOOT_RPI4_SUPPORT_PATCHES}"