summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-07-25 23:44:16 -0700
committerAndrei Gherzan <andrei@gherzan.ro>2019-08-16 15:17:26 +0100
commita374ab0e4e5f2d17d506f28498b0de37798549fb (patch)
treefeeb903ad401d24fe81b0ba5dd03565c0f75d337
parentf961726634dc84b2f535ebd5eb323a3235785f30 (diff)
downloadmeta-raspberrypi-a374ab0e4e5f2d17d506f28498b0de37798549fb.tar.gz
userland: Upgrade to latest
Fix build with glibc 2.30 Forward patches to 20190724 release Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-graphics/userland/files/0001-Allow-applications-to-set-next-resource-handle.patch6
-rw-r--r--recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch14
-rw-r--r--recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch10
-rw-r--r--recipes-graphics/userland/files/0004-wayland-egl-Add-bcm_host-to-dependencies.patch6
-rw-r--r--recipes-graphics/userland/files/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch6
-rw-r--r--recipes-graphics/userland/files/0006-zero-out-wl-buffers-in-egl_surface_free.patch6
-rw-r--r--recipes-graphics/userland/files/0007-initialize-front-back-wayland-buffers.patch6
-rw-r--r--recipes-graphics/userland/files/0008-Remove-RPC_FLUSH.patch6
-rw-r--r--recipes-graphics/userland/files/0009-fix-cmake-dependency-race.patch10
-rw-r--r--recipes-graphics/userland/files/0010-Fix-for-framerate-with-nested-composition.patch6
-rw-r--r--recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch10
-rw-r--r--recipes-graphics/userland/files/0012-implement-buffer-wrapping-interface-for-dispmanx.patch6
-rw-r--r--recipes-graphics/userland/files/0013-Implement-triple-buffering-for-wayland.patch6
-rw-r--r--recipes-graphics/userland/files/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch6
-rw-r--r--recipes-graphics/userland/files/0015-EGL-glplatform.h-define-EGL_CAST.patch6
-rw-r--r--recipes-graphics/userland/files/0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch6
-rw-r--r--recipes-graphics/userland/files/0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch6
-rw-r--r--recipes-graphics/userland/files/0018-Add-EGL_IMG_context_priority-related-defines.patch6
-rw-r--r--recipes-graphics/userland/files/0019-libfdt-Undefine-__wordsize-if-already-defined.patch31
-rw-r--r--recipes-graphics/userland/userland_git.bb6
20 files changed, 98 insertions, 67 deletions
diff --git a/recipes-graphics/userland/files/0001-Allow-applications-to-set-next-resource-handle.patch b/recipes-graphics/userland/files/0001-Allow-applications-to-set-next-resource-handle.patch
index b2bd46f..af803a3 100644
--- a/recipes-graphics/userland/files/0001-Allow-applications-to-set-next-resource-handle.patch
+++ b/recipes-graphics/userland/files/0001-Allow-applications-to-set-next-resource-handle.patch
@@ -1,7 +1,7 @@
1From e94675aa943c114ff801167c69bdd2d366d01665 Mon Sep 17 00:00:00 2001 1From ccb7f6f1a2bc491a24c0402616a2d24b85e3933a Mon Sep 17 00:00:00 2001
2From: Dom Cobley <dc4@broadcom.com> 2From: Dom Cobley <dc4@broadcom.com>
3Date: Tue, 9 Jul 2013 09:26:26 -0400 3Date: Tue, 9 Jul 2013 09:26:26 -0400
4Subject: [PATCH 01/18] Allow applications to set next resource handle 4Subject: [PATCH 01/19] Allow applications to set next resource handle
5 5
6This patch adds provisions in userland to 6This patch adds provisions in userland to
7let apps callers set the next rendereing dispmanx resource. 7let apps callers set the next rendereing dispmanx resource.
@@ -204,5 +204,5 @@ index 8a5734c..51b3580 100644
204 204
205 FN(void, eglIntGetColorData_impl, (EGL_SURFACE_ID_T s, KHRN_IMAGE_FORMAT_T format, uint32_t width, uint32_t height, int32_t stride, uint32_t y_offset, void *data)) 205 FN(void, eglIntGetColorData_impl, (EGL_SURFACE_ID_T s, KHRN_IMAGE_FORMAT_T format, uint32_t width, uint32_t height, int32_t stride, uint32_t y_offset, void *data))
206-- 206--
2072.21.0 2072.22.0
208 208
diff --git a/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch b/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch
index 5efc7a4..8ce9090 100644
--- a/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch
+++ b/recipes-graphics/userland/files/0002-wayland-Add-support-for-the-Wayland-winsys.patch
@@ -1,7 +1,7 @@
1From ad6f485d9eb809b67398ce0948844dd30ea1c8e3 Mon Sep 17 00:00:00 2001 1From 7432d49ddca97b34e402d0108221d34ec69bcd66 Mon Sep 17 00:00:00 2001
2From: Tomeu Vizoso <tomeu.vizoso@collabora.com> 2From: Tomeu Vizoso <tomeu.vizoso@collabora.com>
3Date: Tue, 1 Oct 2013 13:19:20 +0200 3Date: Tue, 1 Oct 2013 13:19:20 +0200
4Subject: [PATCH 02/18] wayland: Add support for the Wayland winsys 4Subject: [PATCH 02/19] wayland: Add support for the Wayland winsys
5 5
6* Adds EGL_WL_bind_wayland_display extension 6* Adds EGL_WL_bind_wayland_display extension
7* Adds wayland-egl library 7* Adds wayland-egl library
@@ -1551,12 +1551,12 @@ index 0000000..8bafc15
1551+Libs: -L${libdir} -lwayland-egl 1551+Libs: -L${libdir} -lwayland-egl
1552+Cflags: -I${includedir} 1552+Cflags: -I${includedir}
1553diff --git a/interface/vmcs_host/CMakeLists.txt b/interface/vmcs_host/CMakeLists.txt 1553diff --git a/interface/vmcs_host/CMakeLists.txt b/interface/vmcs_host/CMakeLists.txt
1554index fde18da..6718215 100755 1554index a157db1..55b6ace 100755
1555--- a/interface/vmcs_host/CMakeLists.txt 1555--- a/interface/vmcs_host/CMakeLists.txt
1556+++ b/interface/vmcs_host/CMakeLists.txt 1556+++ b/interface/vmcs_host/CMakeLists.txt
1557@@ -9,13 +9,24 @@ add_definitions(-fno-strict-aliasing) 1557@@ -7,13 +7,24 @@
1558 1558 # vc_vchi_gencmd.c has a type-punning problem in vc_gencmd_read_response
1559 include_directories(${VMCS_TARGET}/vcfiled) 1559 add_definitions(-fno-strict-aliasing)
1560 1560
1561-add_library(vchostif 1561-add_library(vchostif
1562- ${VMCS_TARGET}/vcfilesys.c ${VMCS_TARGET}/vcmisc.c 1562- ${VMCS_TARGET}/vcfilesys.c ${VMCS_TARGET}/vcmisc.c
@@ -1894,5 +1894,5 @@ index 0000000..ad90d30
1894+ set(${_sources} ${${_sources}} PARENT_SCOPE) 1894+ set(${_sources} ${${_sources}} PARENT_SCOPE)
1895+endfunction() 1895+endfunction()
1896-- 1896--
18972.21.0 18972.22.0
1898 1898
diff --git a/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch b/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch
index ba83db8..3da0f50 100644
--- a/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch
+++ b/recipes-graphics/userland/files/0003-wayland-Add-Wayland-example.patch
@@ -1,7 +1,7 @@
1From 642110bbc9ebcb9ad497f4f1c1ccbc5a9afda753 Mon Sep 17 00:00:00 2001 1From 481a9aeba3f84371668fdf8a1380a3cb23bfc502 Mon Sep 17 00:00:00 2001
2From: Tomeu Vizoso <tomeu.vizoso@collabora.com> 2From: Tomeu Vizoso <tomeu.vizoso@collabora.com>
3Date: Tue, 1 Oct 2013 13:19:20 +0200 3Date: Tue, 1 Oct 2013 13:19:20 +0200
4Subject: [PATCH 03/18] wayland: Add Wayland example 4Subject: [PATCH 03/19] wayland: Add Wayland example
5 5
6--- 6---
7 .../linux/apps/hello_pi/CMakeLists.txt | 1 + 7 .../linux/apps/hello_pi/CMakeLists.txt | 1 +
@@ -19,10 +19,10 @@ Subject: [PATCH 03/18] wayland: Add Wayland example
19 create mode 100644 host_applications/linux/apps/hello_pi/hello_wayland/triangle.c 19 create mode 100644 host_applications/linux/apps/hello_pi/hello_wayland/triangle.c
20 20
21diff --git a/host_applications/linux/apps/hello_pi/CMakeLists.txt b/host_applications/linux/apps/hello_pi/CMakeLists.txt 21diff --git a/host_applications/linux/apps/hello_pi/CMakeLists.txt b/host_applications/linux/apps/hello_pi/CMakeLists.txt
22index f2c6aef..0df78f7 100644 22index b28a94a..2849fad 100644
23--- a/host_applications/linux/apps/hello_pi/CMakeLists.txt 23--- a/host_applications/linux/apps/hello_pi/CMakeLists.txt
24+++ b/host_applications/linux/apps/hello_pi/CMakeLists.txt 24+++ b/host_applications/linux/apps/hello_pi/CMakeLists.txt
25@@ -21,6 +21,7 @@ add_subdirectory(hello_encode) 25@@ -25,6 +25,7 @@ add_subdirectory(hello_encode)
26 add_subdirectory(hello_jpeg) 26 add_subdirectory(hello_jpeg)
27 add_subdirectory(hello_videocube) 27 add_subdirectory(hello_videocube)
28 add_subdirectory(hello_teapot) 28 add_subdirectory(hello_teapot)
@@ -862,5 +862,5 @@ index 8225dd5..0be6ce7 100755
862- 862-
863+make -C hello_wayland 863+make -C hello_wayland
864-- 864--
8652.21.0 8652.22.0
866 866
diff --git a/recipes-graphics/userland/files/0004-wayland-egl-Add-bcm_host-to-dependencies.patch b/recipes-graphics/userland/files/0004-wayland-egl-Add-bcm_host-to-dependencies.patch
index c806e7b..9ca6b9f 100644
--- a/recipes-graphics/userland/files/0004-wayland-egl-Add-bcm_host-to-dependencies.patch
+++ b/recipes-graphics/userland/files/0004-wayland-egl-Add-bcm_host-to-dependencies.patch
@@ -1,7 +1,7 @@
1From 33374e6b19a28d52a0089aa7b9af9b698fb98a86 Mon Sep 17 00:00:00 2001 1From 4463e2732a09dbb721d0614e7147cbfaa9059930 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 10 Aug 2015 02:38:27 -0700 3Date: Mon, 10 Aug 2015 02:38:27 -0700
4Subject: [PATCH 04/18] wayland-egl: Add bcm_host to dependencies 4Subject: [PATCH 04/19] wayland-egl: Add bcm_host to dependencies
5 5
6It uses headers like vcos_platform_types.h but does not 6It uses headers like vcos_platform_types.h but does not
7depend on module which should add the required include paths 7depend on module which should add the required include paths
@@ -24,5 +24,5 @@ index 8bafc15..fd259c9 100644
24 Libs: -L${libdir} -lwayland-egl 24 Libs: -L${libdir} -lwayland-egl
25 Cflags: -I${includedir} 25 Cflags: -I${includedir}
26-- 26--
272.21.0 272.22.0
28 28
diff --git a/recipes-graphics/userland/files/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch b/recipes-graphics/userland/files/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch
index bcf828c..459fc04 100644
--- a/recipes-graphics/userland/files/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch
+++ b/recipes-graphics/userland/files/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch
@@ -1,7 +1,7 @@
1From e2d13265a34519364bd7d27d54a860967b320504 Mon Sep 17 00:00:00 2001 1From 571c417c055a57cfd42c30a7a8279332397bad83 Mon Sep 17 00:00:00 2001
2From: "Yann E. MORIN" <yann.morin.1998@free.fr> 2From: "Yann E. MORIN" <yann.morin.1998@free.fr>
3Date: Sat, 24 Jan 2015 22:07:19 +0100 3Date: Sat, 24 Jan 2015 22:07:19 +0100
4Subject: [PATCH 05/18] interface: remove faulty assert() to make weston happy 4Subject: [PATCH 05/19] interface: remove faulty assert() to make weston happy
5 at runtime 5 at runtime
6 6
7This was removed after a discussion on IRC with the weston guys 7This was removed after a discussion on IRC with the weston guys
@@ -25,5 +25,5 @@ index eab146e..29e0dee 100755
25 } 25 }
26 } else { 26 } else {
27-- 27--
282.21.0 282.22.0
29 29
diff --git a/recipes-graphics/userland/files/0006-zero-out-wl-buffers-in-egl_surface_free.patch b/recipes-graphics/userland/files/0006-zero-out-wl-buffers-in-egl_surface_free.patch
index ed7baf8..cc59ca6 100644
--- a/recipes-graphics/userland/files/0006-zero-out-wl-buffers-in-egl_surface_free.patch
+++ b/recipes-graphics/userland/files/0006-zero-out-wl-buffers-in-egl_surface_free.patch
@@ -1,7 +1,7 @@
1From 0c64a21bd90b9dea9916dcdc7c8c23b93518ccb8 Mon Sep 17 00:00:00 2001 1From 393e90beb9f5e535b5ce5d9eba4bc74907a96afe Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 6 Feb 2016 11:10:47 -0800 3Date: Sat, 6 Feb 2016 11:10:47 -0800
4Subject: [PATCH 06/18] zero-out wl buffers in egl_surface_free 4Subject: [PATCH 06/19] zero-out wl buffers in egl_surface_free
5 5
6origins from buildroot 6origins from buildroot
7 7
@@ -29,5 +29,5 @@ index 42350bf..1f923d9 100644
29 #endif 29 #endif
30 } 30 }
31-- 31--
322.21.0 322.22.0
33 33
diff --git a/recipes-graphics/userland/files/0007-initialize-front-back-wayland-buffers.patch b/recipes-graphics/userland/files/0007-initialize-front-back-wayland-buffers.patch
index 3bc633f..c5ad519 100644
--- a/recipes-graphics/userland/files/0007-initialize-front-back-wayland-buffers.patch
+++ b/recipes-graphics/userland/files/0007-initialize-front-back-wayland-buffers.patch
@@ -1,7 +1,7 @@
1From 4e0f83d815461d501fef788236dab356c9b60ea5 Mon Sep 17 00:00:00 2001 1From 3e7e309de25d546a4836c59523060f286aadd87d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 6 Feb 2016 11:11:41 -0800 3Date: Sat, 6 Feb 2016 11:11:41 -0800
4Subject: [PATCH 07/18] initialize front back wayland buffers 4Subject: [PATCH 07/19] initialize front back wayland buffers
5 5
6origins from metrological wayland support 6origins from metrological wayland support
7 7
@@ -30,5 +30,5 @@ index 1f923d9..9a9582c 100644
30 } 30 }
31 #endif 31 #endif
32-- 32--
332.21.0 332.22.0
34 34
diff --git a/recipes-graphics/userland/files/0008-Remove-RPC_FLUSH.patch b/recipes-graphics/userland/files/0008-Remove-RPC_FLUSH.patch
index 94dee07..219a258 100644
--- a/recipes-graphics/userland/files/0008-Remove-RPC_FLUSH.patch
+++ b/recipes-graphics/userland/files/0008-Remove-RPC_FLUSH.patch
@@ -1,7 +1,7 @@
1From 67384449b85e65661558b9ebe059792cdd737fc7 Mon Sep 17 00:00:00 2001 1From a08887086cf4418fa0999a340c574b66a5ab4412 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 6 Feb 2016 11:09:18 -0800 3Date: Sat, 6 Feb 2016 11:09:18 -0800
4Subject: [PATCH 08/18] Remove RPC_FLUSH 4Subject: [PATCH 08/19] Remove RPC_FLUSH
5 5
6Origins from buildroot 6Origins from buildroot
7 7
@@ -23,5 +23,5 @@ index f9b7287..b04ffef 100644
23 } 23 }
24 #endif 24 #endif
25-- 25--
262.21.0 262.22.0
27 27
diff --git a/recipes-graphics/userland/files/0009-fix-cmake-dependency-race.patch b/recipes-graphics/userland/files/0009-fix-cmake-dependency-race.patch
index 375b181..9e148ee 100644
--- a/recipes-graphics/userland/files/0009-fix-cmake-dependency-race.patch
+++ b/recipes-graphics/userland/files/0009-fix-cmake-dependency-race.patch
@@ -1,7 +1,7 @@
1From a4a31696bddb72f3bf58f6b5303816fd31081566 Mon Sep 17 00:00:00 2001 1From e14d2bfff42be64361a873e73674ce1205af3ee5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 6 Feb 2016 13:12:47 -0800 3Date: Sat, 6 Feb 2016 13:12:47 -0800
4Subject: [PATCH 09/18] fix cmake dependency race 4Subject: [PATCH 09/19] fix cmake dependency race
5 5
6Fixes errors like 6Fixes errors like
7 7
@@ -42,10 +42,10 @@ index 1d81ca3..d6cd415 100644
42 add_library (vcos SHARED ${SOURCES}) 42 add_library (vcos SHARED ${SOURCES})
43 target_link_libraries (vcos pthread dl rt) 43 target_link_libraries (vcos pthread dl rt)
44diff --git a/interface/vmcs_host/CMakeLists.txt b/interface/vmcs_host/CMakeLists.txt 44diff --git a/interface/vmcs_host/CMakeLists.txt b/interface/vmcs_host/CMakeLists.txt
45index 6718215..c415176 100755 45index 55b6ace..ae52495 100755
46--- a/interface/vmcs_host/CMakeLists.txt 46--- a/interface/vmcs_host/CMakeLists.txt
47+++ b/interface/vmcs_host/CMakeLists.txt 47+++ b/interface/vmcs_host/CMakeLists.txt
48@@ -17,14 +17,6 @@ set(VCHOSTIF_SOURCE 48@@ -15,14 +15,6 @@ set(VCHOSTIF_SOURCE
49 # ${VMCS_TARGET}/vmcs_main.c 49 # ${VMCS_TARGET}/vmcs_main.c
50 # vc_vchi_haud.c 50 # vc_vchi_haud.c
51 51
@@ -74,5 +74,5 @@ index f0bae30..8c44c58 100644
74 struct wl_resource *resource; 74 struct wl_resource *resource;
75 struct wl_dispmanx *dispmanx; 75 struct wl_dispmanx *dispmanx;
76-- 76--
772.21.0 772.22.0
78 78
diff --git a/recipes-graphics/userland/files/0010-Fix-for-framerate-with-nested-composition.patch b/recipes-graphics/userland/files/0010-Fix-for-framerate-with-nested-composition.patch
index 20a3743..a075b1e 100644
--- a/recipes-graphics/userland/files/0010-Fix-for-framerate-with-nested-composition.patch
+++ b/recipes-graphics/userland/files/0010-Fix-for-framerate-with-nested-composition.patch
@@ -1,7 +1,7 @@
1From c7acd48a9044e24d64ef453ff35202d6a697eb5d Mon Sep 17 00:00:00 2001 1From ea3f7c3822efd33cec96a79eb9a345544b942d9e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 29 Mar 2016 20:38:30 -0700 3Date: Tue, 29 Mar 2016 20:38:30 -0700
4Subject: [PATCH 10/18] Fix for framerate with nested composition 4Subject: [PATCH 10/19] Fix for framerate with nested composition
5 5
6frame rate appears irregular and lower than expected when using nested composition. 6frame rate appears irregular and lower than expected when using nested composition.
7 7
@@ -56,5 +56,5 @@ index 03fe67b..13a110c 100644
56 #ifdef ANDROID 56 #ifdef ANDROID
57 CLIENT_UNLOCK(); 57 CLIENT_UNLOCK();
58-- 58--
592.21.0 592.22.0
60 60
diff --git a/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch b/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch
index 5e14135..1e60751 100644
--- a/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch
+++ b/recipes-graphics/userland/files/0011-build-shared-library-for-vchostif.patch
@@ -1,7 +1,7 @@
1From a49fbbc6abc3d57d45011a3410d3b8f04349e424 Mon Sep 17 00:00:00 2001 1From 407ab0ed315b4c7b49d1a1dd3777d5af8e0b7e66 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 2 Apr 2016 10:37:24 -0700 3Date: Sat, 2 Apr 2016 10:37:24 -0700
4Subject: [PATCH 11/18] build shared library for vchostif 4Subject: [PATCH 11/19] build shared library for vchostif
5 5
6Fixes #149 6Fixes #149
7 7
@@ -11,10 +11,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
11 1 file changed, 1 insertion(+), 1 deletion(-) 11 1 file changed, 1 insertion(+), 1 deletion(-)
12 12
13diff --git a/interface/vmcs_host/CMakeLists.txt b/interface/vmcs_host/CMakeLists.txt 13diff --git a/interface/vmcs_host/CMakeLists.txt b/interface/vmcs_host/CMakeLists.txt
14index c415176..d0cca1a 100755 14index ae52495..369758b 100755
15--- a/interface/vmcs_host/CMakeLists.txt 15--- a/interface/vmcs_host/CMakeLists.txt
16+++ b/interface/vmcs_host/CMakeLists.txt 16+++ b/interface/vmcs_host/CMakeLists.txt
17@@ -17,7 +17,7 @@ set(VCHOSTIF_SOURCE 17@@ -15,7 +15,7 @@ set(VCHOSTIF_SOURCE
18 # ${VMCS_TARGET}/vmcs_main.c 18 # ${VMCS_TARGET}/vmcs_main.c
19 # vc_vchi_haud.c 19 # vc_vchi_haud.c
20 20
@@ -24,5 +24,5 @@ index c415176..d0cca1a 100755
24 #add_library(bufman vc_vchi_bufman.c ) 24 #add_library(bufman vc_vchi_bufman.c )
25 25
26-- 26--
272.21.0 272.22.0
28 28
diff --git a/recipes-graphics/userland/files/0012-implement-buffer-wrapping-interface-for-dispmanx.patch b/recipes-graphics/userland/files/0012-implement-buffer-wrapping-interface-for-dispmanx.patch
index 0bb9ef7..c4ec571 100644
--- a/recipes-graphics/userland/files/0012-implement-buffer-wrapping-interface-for-dispmanx.patch
+++ b/recipes-graphics/userland/files/0012-implement-buffer-wrapping-interface-for-dispmanx.patch
@@ -1,7 +1,7 @@
1From 70c5c684fbfbc8ebd890b0aafb2bb5c13d6cfb11 Mon Sep 17 00:00:00 2001 1From 48a946e24c3e7172f1044f5815e9cfed96982830 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 2 Apr 2016 10:54:59 -0700 3Date: Sat, 2 Apr 2016 10:54:59 -0700
4Subject: [PATCH 12/18] implement buffer wrapping interface for dispmanx 4Subject: [PATCH 12/19] implement buffer wrapping interface for dispmanx
5 5
6Courtesy: Zan Dobersek 6Courtesy: Zan Dobersek
7 7
@@ -88,5 +88,5 @@ index c18626d..11ed1ef 100644
88 88
89 </protocol> 89 </protocol>
90-- 90--
912.21.0 912.22.0
92 92
diff --git a/recipes-graphics/userland/files/0013-Implement-triple-buffering-for-wayland.patch b/recipes-graphics/userland/files/0013-Implement-triple-buffering-for-wayland.patch
index aae0b02..85b9a4e 100644
--- a/recipes-graphics/userland/files/0013-Implement-triple-buffering-for-wayland.patch
+++ b/recipes-graphics/userland/files/0013-Implement-triple-buffering-for-wayland.patch
@@ -1,7 +1,7 @@
1From 789d16a9d5aa57b201e9d6be9427671f48fec5e4 Mon Sep 17 00:00:00 2001 1From 31e61d1a1d26442be9c90c479e2b14589acedb0e Mon Sep 17 00:00:00 2001
2From: Jeff Wannamaker <jeff_wannamaker@cable.comcast.com> 2From: Jeff Wannamaker <jeff_wannamaker@cable.comcast.com>
3Date: Thu, 19 Jan 2017 18:56:07 +0000 3Date: Thu, 19 Jan 2017 18:56:07 +0000
4Subject: [PATCH 13/18] Implement triple buffering for wayland 4Subject: [PATCH 13/19] Implement triple buffering for wayland
5 5
6Change from double to triple buffering for wayland. 6Change from double to triple buffering for wayland.
7This enables higher frame rates without tearing artifacts 7This enables higher frame rates without tearing artifacts
@@ -86,5 +86,5 @@ index e328b77..58a3184 100644
86 back_wl_buffer 86 back_wl_buffer
87 87
88-- 88--
892.21.0 892.22.0
90 90
diff --git a/recipes-graphics/userland/files/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch b/recipes-graphics/userland/files/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch
index dd27e68..c491550 100644
--- a/recipes-graphics/userland/files/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch
+++ b/recipes-graphics/userland/files/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch
@@ -1,7 +1,7 @@
1From 49604e158b8171033bc8a9db5d8893887fb98557 Mon Sep 17 00:00:00 2001 1From 961cd03f4db37041ae068cd8535f11cf739e42c0 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 10 May 2017 06:39:34 +0000 3Date: Wed, 10 May 2017 06:39:34 +0000
4Subject: [PATCH 14/18] GLES2/gl2ext.h: Define GL_R8_EXT and GL_RG8_EXT 4Subject: [PATCH 14/19] GLES2/gl2ext.h: Define GL_R8_EXT and GL_RG8_EXT
5 5
6weston code uses these defines 6weston code uses these defines
7Upstream-Status: Pending 7Upstream-Status: Pending
@@ -31,5 +31,5 @@ index 4eacf7f..b1acc9f 100644
31 #ifndef GL_EXT_texture_type_2_10_10_10_REV 31 #ifndef GL_EXT_texture_type_2_10_10_10_REV
32 #define GL_UNSIGNED_INT_2_10_10_10_REV_EXT 0x8368 32 #define GL_UNSIGNED_INT_2_10_10_10_REV_EXT 0x8368
33-- 33--
342.21.0 342.22.0
35 35
diff --git a/recipes-graphics/userland/files/0015-EGL-glplatform.h-define-EGL_CAST.patch b/recipes-graphics/userland/files/0015-EGL-glplatform.h-define-EGL_CAST.patch
index 5a5a032..2fc16b1 100644
--- a/recipes-graphics/userland/files/0015-EGL-glplatform.h-define-EGL_CAST.patch
+++ b/recipes-graphics/userland/files/0015-EGL-glplatform.h-define-EGL_CAST.patch
@@ -1,7 +1,7 @@
1From 90f6ebc04c688720f45c7009d12d524d33f51781 Mon Sep 17 00:00:00 2001 1From 9568135c3e4c23e9056135a13cee58c37456aaac Mon Sep 17 00:00:00 2001
2From: Andrea Galbusera <gizero@gmail.com> 2From: Andrea Galbusera <gizero@gmail.com>
3Date: Fri, 14 Jul 2017 09:52:54 +0200 3Date: Fri, 14 Jul 2017 09:52:54 +0200
4Subject: [PATCH 15/18] EGL/glplatform.h: define EGL_CAST 4Subject: [PATCH 15/19] EGL/glplatform.h: define EGL_CAST
5 5
6C++ / C typecast macros for special EGL handle values: used by libepoxy code 6C++ / C typecast macros for special EGL handle values: used by libepoxy code
7The definition comes from the updated version of this header in mesa. 7The definition comes from the updated version of this header in mesa.
@@ -28,5 +28,5 @@ index 1f7c930..c39d425 100644
28+ 28+
29 #endif /* __eglplatform_h */ 29 #endif /* __eglplatform_h */
30-- 30--
312.21.0 312.22.0
32 32
diff --git a/recipes-graphics/userland/files/0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch b/recipes-graphics/userland/files/0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch
index da18541..570b72c 100644
--- a/recipes-graphics/userland/files/0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch
+++ b/recipes-graphics/userland/files/0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch
@@ -1,7 +1,7 @@
1From b8a1516fd1d8c8a5f2400a7fb7bd6b9e05d33a55 Mon Sep 17 00:00:00 2001 1From 493b013cb702b821fdeaef7021ae25dea88900c6 Mon Sep 17 00:00:00 2001
2From: Jeff Wannamaker <jeff_wannamaker@cable.comcast.com> 2From: Jeff Wannamaker <jeff_wannamaker@cable.comcast.com>
3Date: Sat, 27 Jan 2018 12:28:31 -0500 3Date: Sat, 27 Jan 2018 12:28:31 -0500
4Subject: [PATCH 16/18] Allow multiple wayland compositor state data per 4Subject: [PATCH 16/19] Allow multiple wayland compositor state data per
5 process 5 process
6 6
7When eglBindWaylandDisplayWL is called store the wl_global 7When eglBindWaylandDisplayWL is called store the wl_global
@@ -141,5 +141,5 @@ index 9ef89cd..abd5ab3 100644
141 CLIENT_UNLOCK(); 141 CLIENT_UNLOCK();
142 142
143-- 143--
1442.21.0 1442.22.0
145 145
diff --git a/recipes-graphics/userland/files/0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch b/recipes-graphics/userland/files/0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch
index 9d96d5f..2f37989 100644
--- a/recipes-graphics/userland/files/0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch
+++ b/recipes-graphics/userland/files/0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch
@@ -1,7 +1,7 @@
1From d65939b5bdc6cfddb68803e87efffac13182ae46 Mon Sep 17 00:00:00 2001 1From cc25f8abd4498004a276a4ee40e37681fa42422a Mon Sep 17 00:00:00 2001
2From: Hugo Hromic <hhromic@gmail.com> 2From: Hugo Hromic <hhromic@gmail.com>
3Date: Sun, 13 May 2018 10:49:04 +0100 3Date: Sun, 13 May 2018 10:49:04 +0100
4Subject: [PATCH 17/18] khronos: backport typedef for 4Subject: [PATCH 17/19] khronos: backport typedef for
5 EGL_EXT_image_dma_buf_import 5 EGL_EXT_image_dma_buf_import
6 6
7The `gstreamer1.0-plugins-base` package version `1.14` uses `EGL_EXT_image_dma_buf_import`, which 7The `gstreamer1.0-plugins-base` package version `1.14` uses `EGL_EXT_image_dma_buf_import`, which
@@ -34,5 +34,5 @@ index d7e5ba7..dcc90ce 100755
34 #ifndef EGL_WL_bind_wayland_display 34 #ifndef EGL_WL_bind_wayland_display
35 #define EGL_WL_bind_wayland_display 1 35 #define EGL_WL_bind_wayland_display 1
36-- 36--
372.21.0 372.22.0
38 38
diff --git a/recipes-graphics/userland/files/0018-Add-EGL_IMG_context_priority-related-defines.patch b/recipes-graphics/userland/files/0018-Add-EGL_IMG_context_priority-related-defines.patch
index 86f7b36..c44c821 100644
--- a/recipes-graphics/userland/files/0018-Add-EGL_IMG_context_priority-related-defines.patch
+++ b/recipes-graphics/userland/files/0018-Add-EGL_IMG_context_priority-related-defines.patch
@@ -1,7 +1,7 @@
1From e5fcfe7af2c7f75b66356680bb641f4f6555d0c5 Mon Sep 17 00:00:00 2001 1From e091388b4382d90494b5842e9f591043a45b2b21 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 15 Jul 2018 00:48:38 -0700 3Date: Sun, 15 Jul 2018 00:48:38 -0700
4Subject: [PATCH 18/18] Add EGL_IMG_context_priority related defines 4Subject: [PATCH 18/19] Add EGL_IMG_context_priority related defines
5 5
6These defines are needed for compiling weston 4.x 6These defines are needed for compiling weston 4.x
7taken from Khronos headers 7taken from Khronos headers
@@ -31,5 +31,5 @@ index dcc90ce..6842bf9 100755
31 #define EGL_KHR_vg_parent_image 1 31 #define EGL_KHR_vg_parent_image 1
32 #define EGL_VG_PARENT_IMAGE_KHR 0x30BA /* eglCreateImageKHR target */ 32 #define EGL_VG_PARENT_IMAGE_KHR 0x30BA /* eglCreateImageKHR target */
33-- 33--
342.21.0 342.22.0
35 35
diff --git a/recipes-graphics/userland/files/0019-libfdt-Undefine-__wordsize-if-already-defined.patch b/recipes-graphics/userland/files/0019-libfdt-Undefine-__wordsize-if-already-defined.patch
new file mode 100644
index 0000000..fc66f53
--- /dev/null
+++ b/recipes-graphics/userland/files/0019-libfdt-Undefine-__wordsize-if-already-defined.patch
@@ -0,0 +1,31 @@
1From 5229430874b5275547babdbef1e322922317456d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 25 Jul 2019 23:30:27 -0700
4Subject: [PATCH 19/19] libfdt: Undefine __wordsize if already defined
5
6glibc 2.30+ defines __wordsize, which is same so its easier to compile
7for multiple versions of glibc even ones which does not have this define
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 opensrc/helpers/libfdt/libfdt_env.h | 4 ++++
12 1 file changed, 4 insertions(+)
13
14diff --git a/opensrc/helpers/libfdt/libfdt_env.h b/opensrc/helpers/libfdt/libfdt_env.h
15index 1c966b8..fc25ca6 100644
16--- a/opensrc/helpers/libfdt/libfdt_env.h
17+++ b/opensrc/helpers/libfdt/libfdt_env.h
18@@ -56,6 +56,10 @@
19 #include <stdint.h>
20 #include <string.h>
21
22+#ifdef __bitwise
23+#undef __bitwise
24+#endif
25+
26 #ifdef __CHECKER__
27 #define __force __attribute__((force))
28 #define __bitwise __attribute__((bitwise))
29--
302.22.0
31
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index 2b5ac33..99a3f23 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -12,11 +12,11 @@ COMPATIBLE_MACHINE = "^rpi$"
12 12
13SRCBRANCH = "master" 13SRCBRANCH = "master"
14SRCFORK = "raspberrypi" 14SRCFORK = "raspberrypi"
15SRCREV = "517cdc30da167d81a485e7a994e02cec2390a269" 15SRCREV = "17d2fdc1abd370e09ba7074753294c7976dd6b0d"
16 16
17# Use the date of the above commit as the package version. Update this when 17# Use the date of the above commit as the package version. Update this when
18# SRCREV is changed. 18# SRCREV is changed.
19PV = "20190501" 19PV = "20190724"
20 20
21SRC_URI = "\ 21SRC_URI = "\
22 git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \ 22 git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \
@@ -38,6 +38,7 @@ SRC_URI = "\
38 file://0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch \ 38 file://0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch \
39 file://0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch \ 39 file://0017-khronos-backport-typedef-for-EGL_EXT_image_dma_buf_i.patch \
40 file://0018-Add-EGL_IMG_context_priority-related-defines.patch \ 40 file://0018-Add-EGL_IMG_context_priority-related-defines.patch \
41 file://0019-libfdt-Undefine-__wordsize-if-already-defined.patch \
41" 42"
42S = "${WORKDIR}/git" 43S = "${WORKDIR}/git"
43 44
@@ -64,7 +65,6 @@ do_install_append () {
64 sed -i 's/include "vcos_futex_mutex.h"/include "pthreads\/vcos_futex_mutex.h"/g' ${f} 65 sed -i 's/include "vcos_futex_mutex.h"/include "pthreads\/vcos_futex_mutex.h"/g' ${f}
65 sed -i 's/include "vcos_platform_types.h"/include "pthreads\/vcos_platform_types.h"/g' ${f} 66 sed -i 's/include "vcos_platform_types.h"/include "pthreads\/vcos_platform_types.h"/g' ${f}
66 done 67 done
67 install -D -m 0755 ${D}${prefix}${sysconfdir}/init.d/vcfiled ${D}${sysconfdir}/init.d/vcfiled
68 rm -rf ${D}${prefix}${sysconfdir} 68 rm -rf ${D}${prefix}${sysconfdir}
69 if [ "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" = "1" ]; then 69 if [ "${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" = "1" ]; then
70 rm -rf ${D}${libdir}/libEGL* 70 rm -rf ${D}${libdir}/libEGL*