summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2017-11-30 18:04:26 +0000
committerAndrei Gherzan <andrei@gherzan.com>2017-12-04 17:53:26 +0100
commitea6dc59cd7e5b5a0c16c4696ce5f5dad3b6bfa0b (patch)
treeddaab5351fa43d7344c3659cd485bb41b9955835
parent0c4191526002d6ced75818ef6db2a5ebc71783b9 (diff)
downloadmeta-raspberrypi-ea6dc59cd7e5b5a0c16c4696ce5f5dad3b6bfa0b.tar.gz
linux-raspberrypi: Update dev version to 4.14.y
The patch to add dtbo rules to the arm64 Makefile is no longer needed. Signed-off-by: Paul Barker <pbarker@toganlabs.com>
-rw-r--r--recipes-kernel/linux/linux-raspberrypi-dev.bb5
-rw-r--r--recipes-kernel/linux/linux-raspberrypi-dev/0001-build-arm64-Add-rules-for-.dtbo-files-for-dts-overla.patch29
2 files changed, 2 insertions, 32 deletions
diff --git a/recipes-kernel/linux/linux-raspberrypi-dev.bb b/recipes-kernel/linux/linux-raspberrypi-dev.bb
index b947659..ae76572 100644
--- a/recipes-kernel/linux/linux-raspberrypi-dev.bb
+++ b/recipes-kernel/linux/linux-raspberrypi-dev.bb
@@ -7,12 +7,11 @@ python __anonymous() {
7 7
8FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:" 8FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:"
9 9
10LINUX_VERSION ?= "4.13" 10LINUX_VERSION ?= "4.14"
11LINUX_RPI_DEV_BRANCH ?= "rpi-4.13.y" 11LINUX_RPI_DEV_BRANCH ?= "rpi-4.14.y"
12 12
13SRCREV = "${AUTOREV}" 13SRCREV = "${AUTOREV}"
14SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=${LINUX_RPI_DEV_BRANCH} \ 14SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=${LINUX_RPI_DEV_BRANCH} \
15 file://0001-build-arm64-Add-rules-for-.dtbo-files-for-dts-overla.patch \
16" 15"
17require linux-raspberrypi.inc 16require linux-raspberrypi.inc
18 17
diff --git a/recipes-kernel/linux/linux-raspberrypi-dev/0001-build-arm64-Add-rules-for-.dtbo-files-for-dts-overla.patch b/recipes-kernel/linux/linux-raspberrypi-dev/0001-build-arm64-Add-rules-for-.dtbo-files-for-dts-overla.patch
deleted file mode 100644
index e8bc52e..0000000
--- a/recipes-kernel/linux/linux-raspberrypi-dev/0001-build-arm64-Add-rules-for-.dtbo-files-for-dts-overla.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 922ce1fd0eb810b713f6ffa9a7ab97c11b6e38cf Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 10 Feb 2017 17:57:08 -0800
4Subject: [PATCH] build/arm64: Add rules for .dtbo files for dts overlays
5
6We now create overlays as .dtbo files.
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 arch/arm64/Makefile | 3 +++
11 1 file changed, 3 insertions(+)
12
13diff --git a/arch/arm64/Makefile b/arch/arm64/Makefile
14index 3635b8662724..822fefeb1cd0 100644
15--- a/arch/arm64/Makefile
16+++ b/arch/arm64/Makefile
17@@ -113,6 +113,9 @@ zinstall install:
18 %.dtb: scripts
19 $(Q)$(MAKE) $(build)=$(boot)/dts $(boot)/dts/$@
20
21+%.dtbo: | scripts
22+ $(Q)$(MAKE) $(build)=$(boot)/dts MACHINE=$(MACHINE) $(boot)/dts/$@
23+
24 PHONY += dtbs dtbs_install
25
26 dtbs: prepare scripts
27--
282.11.1
29