summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2018-02-26 16:42:01 +0000
committerPaul Barker <pbarker@toganlabs.com>2018-02-26 21:54:28 +0000
commitbe300f74bb22e4322269faf08156bdbaacf66d2e (patch)
treee242a05699feb8ce544bcbeb2a442022a94e2bbb
parent142eb1ed57fe97c690088055bba2af52fa87f407 (diff)
downloadmeta-raspberrypi-be300f74bb22e4322269faf08156bdbaacf66d2e.tar.gz
rpi-*-image: Deprecate old image names
As discussed on the issue tracker, it's confusing for meta-raspberrypi to have its own set of image names filling the same jobs as the core images. Therefore we are marking these images as deprecated and will be removing them in the future. The recommended replacement images are as follows: rpi-hwup-image -> core-image-minimal rpi-basic-image -> core-image-base The image 'rpi-test-image' will be kept and is not marked as deprecated, it is still useful for testing. It it updated to be based on 'core-image-base'. Signed-off-by: Paul Barker <pbarker@toganlabs.com>
-rw-r--r--recipes-core/images/rpi-basic-image.bb4
-rw-r--r--recipes-core/images/rpi-hwup-image.bb4
-rw-r--r--recipes-core/images/rpi-test-image.bb4
3 files changed, 10 insertions, 2 deletions
diff --git a/recipes-core/images/rpi-basic-image.bb b/recipes-core/images/rpi-basic-image.bb
index 623a5a7..33dca7d 100644
--- a/recipes-core/images/rpi-basic-image.bb
+++ b/recipes-core/images/rpi-basic-image.bb
@@ -4,3 +4,7 @@ include rpi-hwup-image.bb
4SPLASH = "psplash-raspberrypi" 4SPLASH = "psplash-raspberrypi"
5 5
6IMAGE_FEATURES += "ssh-server-dropbear splash" 6IMAGE_FEATURES += "ssh-server-dropbear splash"
7
8do_image_prepend() {
9 bb.warn("The image 'rpi-basic-image' is deprecated, please use 'core-image-base' instead")
10}
diff --git a/recipes-core/images/rpi-hwup-image.bb b/recipes-core/images/rpi-hwup-image.bb
index 486ea59..d2371ad 100644
--- a/recipes-core/images/rpi-hwup-image.bb
+++ b/recipes-core/images/rpi-hwup-image.bb
@@ -5,3 +5,7 @@ include recipes-core/images/core-image-minimal.bb
5IMAGE_INSTALL += " \ 5IMAGE_INSTALL += " \
6 kernel-modules \ 6 kernel-modules \
7 " 7 "
8
9do_image_prepend() {
10 bb.warn("The image 'rpi-hwup-image' is deprecated, please use 'core-image-minimal' instead")
11}
diff --git a/recipes-core/images/rpi-test-image.bb b/recipes-core/images/rpi-test-image.bb
index c8dc436..c2f5f73 100644
--- a/recipes-core/images/rpi-test-image.bb
+++ b/recipes-core/images/rpi-test-image.bb
@@ -1,5 +1,5 @@
1# Base this image on rpi-basic-image 1# Base this image on core-image-base
2include rpi-basic-image.bb 2include recipes-core/images/core-image-base.bb
3 3
4COMPATIBLE_MACHINE = "^rpi$" 4COMPATIBLE_MACHINE = "^rpi$"
5 5