summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Galbusera <gizero@gmail.com>2018-01-22 14:59:23 +0100
committerAndrei Gherzan <andrei@gherzan.com>2018-01-22 20:20:38 +0000
commita50e19695f2cc655ef6248b77c8244519dbb468c (patch)
tree136b09c9be1fbe81a8fa82d462acb608bcb24aa3
parent61c2a965a21cfc927b817dc517100d31c07ffa95 (diff)
downloadmeta-raspberrypi-a50e19695f2cc655ef6248b77c8244519dbb468c.tar.gz
u-boot: drop upstreamed patches in v2018.01
These are now in upstream, so they are no longer required here. Signed-off-by: Andrea Galbusera <gizero@gmail.com>
-rw-r--r--recipes-bsp/u-boot/u-boot/0001-add-support-for-Raspberry-Pi-Zero-W.patch143
-rw-r--r--recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch42
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend7
3 files changed, 0 insertions, 192 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0001-add-support-for-Raspberry-Pi-Zero-W.patch b/recipes-bsp/u-boot/u-boot/0001-add-support-for-Raspberry-Pi-Zero-W.patch
deleted file mode 100644
index f011208..0000000
--- a/recipes-bsp/u-boot/u-boot/0001-add-support-for-Raspberry-Pi-Zero-W.patch
+++ /dev/null
@@ -1,143 +0,0 @@
1From 8993056fb3d4af4f0cd078df20130d4e7c35c2f7 Mon Sep 17 00:00:00 2001
2From: Dmitry Korunov <dessel.k@gmail.com>
3Date: Sun, 26 Nov 2017 13:38:53 +0400
4Subject: [PATCH 1/1] add support for Raspberry Pi Zero W
5
6Signed-off-by: Dmitry Korunov <dessel.k@gmail.com>
7Signed-off-by: Mirza Krak <mirza.krak@gmail.com>
8Upstream-status: Backport
9---
10 arch/arm/dts/bcm2835-rpi-zero-w.dts | 26 ++++++++++++++++++++++++++
11 arch/arm/mach-bcm283x/Kconfig | 16 ++++++++++++++++
12 board/raspberrypi/rpi/rpi.c | 5 +++++
13 configs/rpi_0_w_defconfig | 28 ++++++++++++++++++++++++++++
14 include/configs/rpi.h | 2 +-
15 5 files changed, 76 insertions(+), 1 deletion(-)
16 create mode 100644 arch/arm/dts/bcm2835-rpi-zero-w.dts
17 create mode 100644 configs/rpi_0_w_defconfig
18
19diff --git a/arch/arm/dts/bcm2835-rpi-zero-w.dts b/arch/arm/dts/bcm2835-rpi-zero-w.dts
20new file mode 100644
21index 0000000..7817054
22--- /dev/null
23+++ b/arch/arm/dts/bcm2835-rpi-zero-w.dts
24@@ -0,0 +1,26 @@
25+/dts-v1/;
26+#include "bcm2835.dtsi"
27+#include "bcm2835-rpi.dtsi"
28+#include "bcm283x-rpi-smsc9512.dtsi"
29+#include "bcm283x-rpi-usb-host.dtsi"
30+
31+/ {
32+ compatible = "raspberrypi,model-zero-w", "brcm,bcm2835";
33+ model = "Raspberry Pi Zero W";
34+
35+ leds {
36+ act {
37+ gpios = <&gpio 47 0>;
38+ };
39+ };
40+};
41+
42+&uart1 {
43+ pinctrl-names = "default";
44+ pinctrl-0 = <&uart1_gpio14>;
45+ status = "okay";
46+};
47+
48+&hdmi {
49+ hpd-gpios = <&gpio 46 GPIO_ACTIVE_LOW>;
50+};
51diff --git a/arch/arm/mach-bcm283x/Kconfig b/arch/arm/mach-bcm283x/Kconfig
52index 69f7a46..a78239d 100644
53--- a/arch/arm/mach-bcm283x/Kconfig
54+++ b/arch/arm/mach-bcm283x/Kconfig
55@@ -44,6 +44,22 @@ config TARGET_RPI
56 This option creates a build targetting the ARM1176 ISA.
57 select BCM2835
58
59+config TARGET_RPI_0_W
60+ bool "Raspberry Pi Zero W"
61+ help
62+ Support for all ARM1176-/BCM2835-based Raspberry Pi variants, such as
63+ the RPi Zero model W.
64+
65+ This option assumes the VideoCore firmware is configured to use the
66+ mini UART (rather than PL011) for the serial console. This is the
67+ default on the RPi Zero W. To enable the UART console, the following
68+ non-default option must be present in config.txt: enable_uart=1.
69+ This is required for U-Boot to operate correctly, even if you only
70+ care about the HDMI/usbkbd console.
71+
72+ This option creates a build targetting the ARMv7/AArch32 ISA.
73+ select BCM2835
74+
75 config TARGET_RPI_2
76 bool "Raspberry Pi 2"
77 help
78diff --git a/board/raspberrypi/rpi/rpi.c b/board/raspberrypi/rpi/rpi.c
79index 530f149..3b7a54f 100644
80--- a/board/raspberrypi/rpi/rpi.c
81+++ b/board/raspberrypi/rpi/rpi.c
82@@ -105,6 +105,11 @@ static const struct rpi_model rpi_models_new_scheme[] = {
83 DTB_DIR "bcm2835-rpi-zero.dtb",
84 false,
85 },
86+ [0xC] = {
87+ "Zero W",
88+ DTB_DIR "bcm2835-rpi-zero-w.dtb",
89+ false,
90+ },
91 };
92
93 static const struct rpi_model rpi_models_old_scheme[] = {
94diff --git a/configs/rpi_0_w_defconfig b/configs/rpi_0_w_defconfig
95new file mode 100644
96index 0000000..092f378
97--- /dev/null
98+++ b/configs/rpi_0_w_defconfig
99@@ -0,0 +1,28 @@
100+CONFIG_ARM=y
101+CONFIG_ARCH_BCM283X=y
102+CONFIG_TARGET_RPI_0_W=y
103+CONFIG_DEFAULT_DEVICE_TREE="bcm2835-rpi-zero-w"
104+CONFIG_DISTRO_DEFAULTS=y
105+CONFIG_OF_BOARD_SETUP=y
106+# CONFIG_DISPLAY_CPUINFO is not set
107+# CONFIG_DISPLAY_BOARDINFO is not set
108+CONFIG_SYS_PROMPT="U-Boot> "
109+# CONFIG_CMD_IMLS is not set
110+# CONFIG_CMD_FLASH is not set
111+CONFIG_CMD_MMC=y
112+CONFIG_CMD_USB=y
113+# CONFIG_CMD_FPGA is not set
114+CONFIG_CMD_GPIO=y
115+CONFIG_DM_MMC=y
116+CONFIG_MMC_SDHCI=y
117+CONFIG_MMC_SDHCI_BCM2835=y
118+CONFIG_DM_ETH=y
119+CONFIG_USB=y
120+CONFIG_DM_USB=y
121+CONFIG_USB_STORAGE=y
122+CONFIG_USB_KEYBOARD=y
123+CONFIG_DM_VIDEO=y
124+CONFIG_SYS_WHITE_ON_BLACK=y
125+CONFIG_CONSOLE_SCROLL_LINES=10
126+CONFIG_PHYS_TO_BUS=y
127+CONFIG_OF_LIBFDT_OVERLAY=y
128diff --git a/include/configs/rpi.h b/include/configs/rpi.h
129index c499b45..cab8661 100644
130--- a/include/configs/rpi.h
131+++ b/include/configs/rpi.h
132@@ -76,7 +76,7 @@
133 #endif
134
135 /* Console UART */
136-#ifdef CONFIG_BCM2837
137+#if defined (CONFIG_BCM2837) || defined(CONFIG_TARGET_RPI_0_W)
138 #define CONFIG_BCM283X_MU_SERIAL
139 #else
140 #define CONFIG_PL01X_SERIAL
141--
1422.1.4
143
diff --git a/recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch b/recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch
deleted file mode 100644
index 9af9c4e..0000000
--- a/recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From ee4328553b1a10d2686d60c7b184223b09d76cdc Mon Sep 17 00:00:00 2001
2From: Drew Moseley <drew.moseley@northern.tech>
3Date: Sun, 7 Jan 2018 10:00:10 -0500
4Subject: [PATCH] rpi_0_w: Add configs consistent with RpI3
5
6Upstream-Status: Submitted [https://patchwork.ozlabs.org/patch/856572/]
7
8Signed-off-by: Drew Moseley <drew.moseley@northern.tech>
9---
10 configs/rpi_0_w_defconfig | 7 +++++++
11 1 file changed, 7 insertions(+)
12
13diff --git a/configs/rpi_0_w_defconfig b/configs/rpi_0_w_defconfig
14index 092f378..623aad3 100644
15--- a/configs/rpi_0_w_defconfig
16+++ b/configs/rpi_0_w_defconfig
17@@ -11,6 +11,10 @@ CONFIG_SYS_PROMPT="U-Boot> "
18 # CONFIG_CMD_FLASH is not set
19 CONFIG_CMD_MMC=y
20 CONFIG_CMD_USB=y
21+CONFIG_OF_EMBED=y
22+CONFIG_ENV_FAT_INTERFACE="mmc"
23+CONFIG_ENV_FAT_DEVICE_AND_PART="0:1"
24+CONFIG_DM_KEYBOARD=y
25 # CONFIG_CMD_FPGA is not set
26 CONFIG_CMD_GPIO=y
27 CONFIG_DM_MMC=y
28@@ -19,8 +23,11 @@ CONFIG_MMC_SDHCI_BCM2835=y
29 CONFIG_DM_ETH=y
30 CONFIG_USB=y
31 CONFIG_DM_USB=y
32+CONFIG_USB_DWC2=y
33 CONFIG_USB_STORAGE=y
34 CONFIG_USB_KEYBOARD=y
35+CONFIG_USB_HOST_ETHER=y
36+CONFIG_USB_ETHER_SMSC95XX=y
37 CONFIG_DM_VIDEO=y
38 CONFIG_SYS_WHITE_ON_BLACK=y
39 CONFIG_CONSOLE_SCROLL_LINES=10
40--
412.7.4
42
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index f91ad95..3781666 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1,8 +1 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
2
3SRC_URI_append_rpi = " \
4 file://0001-add-support-for-Raspberry-Pi-Zero-W.patch \
5 file://0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch \
6"
7
8RDEPENDS_${PN}_append_rpi = " rpi-u-boot-scr" RDEPENDS_${PN}_append_rpi = " rpi-u-boot-scr"