summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2017-12-11 19:50:40 +0000
committerAndrei Gherzan <andrei@gherzan.com>2017-12-18 19:20:43 +0000
commit9bf918014bbf1df7b2f4844cc5e70532a625f887 (patch)
treedee5cb894874fce5cf9720a65e9663513e7810b5
parent8124f871753fb874e927c222d574ace1c4dfc2c1 (diff)
downloadmeta-raspberrypi-9bf918014bbf1df7b2f4844cc5e70532a625f887.tar.gz
rpi-config: Add RPI_EXTRA_CONFIG option
The variable RPI_EXTRA_CONFIG can be set in local.conf to append text to the Raspberry Pi config.txt file as described in the documentation. Signed-off-by: Paul Barker <pbarker@toganlabs.com>
-rw-r--r--docs/extra-build-config.md16
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb3
2 files changed, 19 insertions, 0 deletions
diff --git a/docs/extra-build-config.md b/docs/extra-build-config.md
index 380d969..d162abc 100644
--- a/docs/extra-build-config.md
+++ b/docs/extra-build-config.md
@@ -186,3 +186,19 @@ RaspberryPi3 will have to explicitely set in local.conf:
186Ref.: 186Ref.:
187* <https://github.com/raspberrypi/firmware/issues/553> 187* <https://github.com/raspberrypi/firmware/issues/553>
188* <https://github.com/RPi-Distro/repo/issues/22> 188* <https://github.com/RPi-Distro/repo/issues/22>
189
190## Manual additions to config.txt
191
192The `RPI_EXTRA_CONFIG` variable can be used to manually add additional lines to
193the `config.txt` file if there is not a specific option above for the
194configuration you need. To add multiple lines you must include `\n` separators.
195If double-quotes are needed in the lines you are adding you can use single
196quotes around the whole string.
197
198For example, to add a comment containing a double-quote and a configuration
199option:
200
201 RPI_EXTRA_CONFIG = ' \n \
202 # Raspberry Pi 7\" display/touch screen \n \
203 lcd_rotate=2 \n \
204 '
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index ca4160b..49758ac 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -127,6 +127,9 @@ do_deploy() {
127 echo "hdmi_cvt 1024 600 60 6 0 0 0" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 127 echo "hdmi_cvt 1024 600 60 6 0 0 0" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
128 echo "hdmi_drive=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 128 echo "hdmi_drive=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
129 fi 129 fi
130
131 # Append extra config if the user has provided any
132 echo "${RPI_EXTRA_CONFIG}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
130} 133}
131 134
132do_deploy_append_raspberrypi3-64() { 135do_deploy_append_raspberrypi3-64() {