summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew Moseley <drew.moseley@northern.tech>2018-01-07 11:57:04 -0500
committerAndrei Gherzan <andrei@gherzan.com>2018-02-14 17:52:28 +0000
commit72bc798ff548ba610e8dea53c80e39a37de8e043 (patch)
tree371e56b09f7ecf6984d0a89c88867b4d5b88609f
parenta2ba56f74ed7d1a794c3d92a0c10039c2b6e0cc6 (diff)
downloadmeta-raspberrypi-72bc798ff548ba610e8dea53c80e39a37de8e043.tar.gz
u-boot: Update RPi Zero W defconfig to support DTB.
This makes the defconfig more consistent with the RPi 3 and CONFIG_OF_EMBED is needed to get the RPi firmware provided DTB to function. Recently removed by: a50e19695f2cc655ef6248b77c8244519dbb468c u-boot: drop upstreamed patches in v2018.01 however this change missed the cutoff for v2018.01 Signed-off-by: Drew Moseley <drew.moseley@northern.tech>
-rw-r--r--recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch41
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend6
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch b/recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch
new file mode 100644
index 0000000..e98fd85
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch
@@ -0,0 +1,41 @@
1From 5d113dc0130ea2ea9faaa000fba9c737266b9747 Mon Sep 17 00:00:00 2001
2From: Drew Moseley <drew.moseley@northern.tech>
3Date: Fri, 9 Feb 2018 18:10:09 -0500
4Subject: [PATCH] rpi_0_w: Add configs consistent with RpI3
5
6Upstream-Status: Accepted [https://patchwork.ozlabs.org/patch/856572/]
7
8Signed-off-by: Drew Moseley <drew.moseley@northern.tech>
9---
10 configs/rpi_0_w_defconfig | 7 +++++++
11 1 file changed, 7 insertions(+)
12
13diff --git a/configs/rpi_0_w_defconfig b/configs/rpi_0_w_defconfig
14index 9a6d24b..1248294 100644
15--- a/configs/rpi_0_w_defconfig
16+++ b/configs/rpi_0_w_defconfig
17@@ -12,14 +12,21 @@ CONFIG_SYS_PROMPT="U-Boot> "
18 CONFIG_CMD_GPIO=y
19 CONFIG_CMD_MMC=y
20 CONFIG_CMD_USB=y
21+CONFIG_OF_EMBED=y
22+CONFIG_ENV_FAT_INTERFACE="mmc"
23+CONFIG_ENV_FAT_DEVICE_AND_PART="0:1"
24+CONFIG_DM_KEYBOARD=y
25 CONFIG_DM_MMC=y
26 CONFIG_MMC_SDHCI=y
27 CONFIG_MMC_SDHCI_BCM2835=y
28 CONFIG_DM_ETH=y
29 CONFIG_USB=y
30 CONFIG_DM_USB=y
31+CONFIG_USB_DWC2=y
32 CONFIG_USB_STORAGE=y
33 CONFIG_USB_KEYBOARD=y
34+CONFIG_USB_HOST_ETHER=y
35+CONFIG_USB_ETHER_SMSC95XX=y
36 CONFIG_DM_VIDEO=y
37 CONFIG_SYS_WHITE_ON_BLACK=y
38 CONFIG_CONSOLE_SCROLL_LINES=10
39--
402.7.4
41
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index 3781666..de58f3a 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
2
3SRC_URI_append_rpi = " \
4 file://0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch \
5"
6
1RDEPENDS_${PN}_append_rpi = " rpi-u-boot-scr" 7RDEPENDS_${PN}_append_rpi = " rpi-u-boot-scr"