summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.com>2018-01-26 15:10:23 +0000
committerAndrei Gherzan <andrei@gherzan.com>2018-01-26 16:50:42 +0000
commit6235b0a8543bcf6704d0fe0156ab2b847a4ea0bc (patch)
treea365d754e11884b30c45cd73d5a7cc289149f654
parent0202bc288176fdd3319ea7764c7b62d9772c8903 (diff)
downloadmeta-raspberrypi-6235b0a8543bcf6704d0fe0156ab2b847a4ea0bc.tar.gz
bluez5: Use serial device alias for BT device
Signed-off-by: Andrei Gherzan <andrei@gherzan.com>
-rw-r--r--recipes-connectivity/bluez5/bluez5/brcm43438.service2
-rw-r--r--recipes-connectivity/bluez5/bluez5_%.bbappend4
2 files changed, 5 insertions, 1 deletions
diff --git a/recipes-connectivity/bluez5/bluez5/brcm43438.service b/recipes-connectivity/bluez5/bluez5/brcm43438.service
index d57125c..c6e7456 100644
--- a/recipes-connectivity/bluez5/bluez5/brcm43438.service
+++ b/recipes-connectivity/bluez5/bluez5/brcm43438.service
@@ -6,7 +6,7 @@ After=dev-ttyAMA0.device
6 6
7[Service] 7[Service]
8Type=simple 8Type=simple
9ExecStart=/usr/bin/hciattach -n /dev/ttyAMA0 bcm43xx 921600 noflow - 9ExecStart=/usr/bin/hciattach -n /dev/serial1 bcm43xx 921600 noflow -
10 10
11[Install] 11[Install]
12WantedBy=multi-user.target 12WantedBy=multi-user.target
diff --git a/recipes-connectivity/bluez5/bluez5_%.bbappend b/recipes-connectivity/bluez5/bluez5_%.bbappend
index eac8d40..c49d696 100644
--- a/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ b/recipes-connectivity/bluez5/bluez5_%.bbappend
@@ -36,6 +36,8 @@ FILES_${PN}_append_raspberrypi3 = " ${BCM_BT_FIRMWARE}"
36 36
37SYSTEMD_SERVICE_${PN}_append_raspberrypi3 = " ${BCM_BT_SERVICE}" 37SYSTEMD_SERVICE_${PN}_append_raspberrypi3 = " ${BCM_BT_SERVICE}"
38 38
39RDEPENDS_${PN}_append_raspberrypi3 = " udev-rules-rpi"
40
39# for raspberrypi0-wifi 41# for raspberrypi0-wifi
40SRC_URI_append_raspberrypi0-wifi = " ${BCM_BT_SOURCES}" 42SRC_URI_append_raspberrypi0-wifi = " ${BCM_BT_SOURCES}"
41 43
@@ -46,3 +48,5 @@ do_install_append_raspberrypi0-wifi() {
46FILES_${PN}_append_raspberrypi0-wifi = " ${BCM_BT_FIRMWARE}" 48FILES_${PN}_append_raspberrypi0-wifi = " ${BCM_BT_FIRMWARE}"
47 49
48SYSTEMD_SERVICE_${PN}_append_raspberrypi0-wifi = " ${BCM_BT_SERVICE}" 50SYSTEMD_SERVICE_${PN}_append_raspberrypi0-wifi = " ${BCM_BT_SERVICE}"
51
52RDEPENDS_${PN}_append_raspebrrypi0-wifi = " udev-rules-rpi"