summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew Moseley <drew.moseley@northern.tech>2018-01-07 11:57:04 -0500
committerAndrei Gherzan <andrei@gherzan.com>2018-01-11 21:33:55 +0000
commit58d86c0986ab50d5d193ab9a965cb88d528269dd (patch)
tree1353e9c3ac2b28d75869eb39ad1a2933da016b70
parent9c9c2bac613b2a763f95ab4b323a8e4f325a4d79 (diff)
downloadmeta-raspberrypi-58d86c0986ab50d5d193ab9a965cb88d528269dd.tar.gz
u-boot: Update RPi Zero W defconfig to support DTB.
This makes the defconfig more consistent with the RPi 3 and CONFIG_OF_EMBED is needed to get the RPi firmware provided DTB to function. Signed-off-by: Drew Moseley <drew.moseley@northern.tech> Added patch status information in patch header, and re-word of commit message Signed-off-by: Mirza Krak <mirza.krak@endian.se>
-rw-r--r--recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch42
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend1
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch b/recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch
new file mode 100644
index 0000000..9af9c4e
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch
@@ -0,0 +1,42 @@
1From ee4328553b1a10d2686d60c7b184223b09d76cdc Mon Sep 17 00:00:00 2001
2From: Drew Moseley <drew.moseley@northern.tech>
3Date: Sun, 7 Jan 2018 10:00:10 -0500
4Subject: [PATCH] rpi_0_w: Add configs consistent with RpI3
5
6Upstream-Status: Submitted [https://patchwork.ozlabs.org/patch/856572/]
7
8Signed-off-by: Drew Moseley <drew.moseley@northern.tech>
9---
10 configs/rpi_0_w_defconfig | 7 +++++++
11 1 file changed, 7 insertions(+)
12
13diff --git a/configs/rpi_0_w_defconfig b/configs/rpi_0_w_defconfig
14index 092f378..623aad3 100644
15--- a/configs/rpi_0_w_defconfig
16+++ b/configs/rpi_0_w_defconfig
17@@ -11,6 +11,10 @@ CONFIG_SYS_PROMPT="U-Boot> "
18 # CONFIG_CMD_FLASH is not set
19 CONFIG_CMD_MMC=y
20 CONFIG_CMD_USB=y
21+CONFIG_OF_EMBED=y
22+CONFIG_ENV_FAT_INTERFACE="mmc"
23+CONFIG_ENV_FAT_DEVICE_AND_PART="0:1"
24+CONFIG_DM_KEYBOARD=y
25 # CONFIG_CMD_FPGA is not set
26 CONFIG_CMD_GPIO=y
27 CONFIG_DM_MMC=y
28@@ -19,8 +23,11 @@ CONFIG_MMC_SDHCI_BCM2835=y
29 CONFIG_DM_ETH=y
30 CONFIG_USB=y
31 CONFIG_DM_USB=y
32+CONFIG_USB_DWC2=y
33 CONFIG_USB_STORAGE=y
34 CONFIG_USB_KEYBOARD=y
35+CONFIG_USB_HOST_ETHER=y
36+CONFIG_USB_ETHER_SMSC95XX=y
37 CONFIG_DM_VIDEO=y
38 CONFIG_SYS_WHITE_ON_BLACK=y
39 CONFIG_CONSOLE_SCROLL_LINES=10
40--
412.7.4
42
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index 9fd7304..f91ad95 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
2 2
3SRC_URI_append_rpi = " \ 3SRC_URI_append_rpi = " \
4 file://0001-add-support-for-Raspberry-Pi-Zero-W.patch \ 4 file://0001-add-support-for-Raspberry-Pi-Zero-W.patch \
5 file://0002-rpi_0_w-Add-configs-consistent-with-RpI3.patch \
5" 6"
6 7
7RDEPENDS_${PN}_append_rpi = " rpi-u-boot-scr" 8RDEPENDS_${PN}_append_rpi = " rpi-u-boot-scr"