summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2018-02-26 16:27:22 +0000
committerPaul Barker <pbarker@toganlabs.com>2018-02-26 21:54:27 +0000
commit142eb1ed57fe97c690088055bba2af52fa87f407 (patch)
treeaa80888abfed1a938faaf79b408fe7d52f81c2af
parentec26440fb1f504451c20d4fced0ba88093f6f695 (diff)
downloadmeta-raspberrypi-142eb1ed57fe97c690088055bba2af52fa87f407.tar.gz
rpio: Use pypi.bbclass
This should resolve recent issues with the non-https URL in SRC_URI. Signed-off-by: Paul Barker <pbarker@toganlabs.com>
-rw-r--r--recipes-devtools/python/rpio_0.10.0.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/recipes-devtools/python/rpio_0.10.0.bb b/recipes-devtools/python/rpio_0.10.0.bb
index 998fdb3..c3254bc 100644
--- a/recipes-devtools/python/rpio_0.10.0.bb
+++ b/recipes-devtools/python/rpio_0.10.0.bb
@@ -5,12 +5,10 @@ SECTION = "devel/python"
5LICENSE = "LGPLv3+" 5LICENSE = "LGPLv3+"
6LIC_FILES_CHKSUM = "file://README.rst;beginline=41;endline=53;md5=d5d95d7486a4d98c999675c23196b25a" 6LIC_FILES_CHKSUM = "file://README.rst;beginline=41;endline=53;md5=d5d95d7486a4d98c999675c23196b25a"
7 7
8SRCNAME = "RPIO" 8PYPI_PACKAGE = "RPIO"
9inherit pypi
9 10
10SRC_URI = "http://pypi.python.org/packages/source/R/RPIO/${SRCNAME}-${PV}.tar.gz \ 11SRC_URI += "file://0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch"
11 file://0001-include-sys-types.h-explicitly-for-getting-caddr_t-d.patch \
12 "
13S = "${WORKDIR}/${SRCNAME}-${PV}"
14 12
15inherit setuptools 13inherit setuptools
16 14