summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-01-31 16:54:59 +0000
committerAndrei Gherzan <andrei@gherzan.com>2018-02-01 18:42:47 +0000
commit073f1e845eb1d3807069644bc535fefe8c013a64 (patch)
tree7c547b5bb48657b7cf34997af944222e350d4e1b
parentea35d07b5bc7df34e73d86f3566775f8216f1c29 (diff)
downloadmeta-raspberrypi-073f1e845eb1d3807069644bc535fefe8c013a64.tar.gz
omxplayer: make samba support configureable
* samba depends on libpam and it might be useful to disable support for it in DISTROs without pam in DISTRO_FEATURES * disable it by default Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-multimedia/omxplayer/omxplayer_git.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-multimedia/omxplayer/omxplayer_git.bb b/recipes-multimedia/omxplayer/omxplayer_git.bb
index db01d74..1df41a5 100644
--- a/recipes-multimedia/omxplayer/omxplayer_git.bb
+++ b/recipes-multimedia/omxplayer/omxplayer_git.bb
@@ -7,7 +7,7 @@ SECTION = "console/utils"
7LICENSE = "GPLv2" 7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
9 9
10DEPENDS = "libpcre libav virtual/egl boost freetype dbus openssl samba libssh libomxil coreutils-native curl-native" 10DEPENDS = "libpcre libav virtual/egl boost freetype dbus openssl libssh libomxil coreutils-native curl-native"
11PR = "r4" 11PR = "r4"
12 12
13SRCREV_default = "b8ff59dccd9307f10dad71bec2525a95bd6c603b" 13SRCREV_default = "b8ff59dccd9307f10dad71bec2525a95bd6c603b"
@@ -40,6 +40,11 @@ COMPATIBLE_MACHINE_rpi = "(.*)"
40 40
41inherit autotools-brokensep pkgconfig 41inherit autotools-brokensep pkgconfig
42 42
43# This isn't used directly by omxplayer, but applied to Makefile.ffmpeg which
44# runs the ffmpeg configuration
45PACKAGECONFIG ??= ""
46PACKAGECONFIG[samba] = "--enable-libsmbclient,--disable-libsmbclient,samba"
47
43# Needed in ffmpeg configure 48# Needed in ffmpeg configure
44export TEMPDIR = "${S}/tmp" 49export TEMPDIR = "${S}/tmp"
45 50
@@ -66,6 +71,8 @@ do_compile() {
66 # Needed for compiler test in ffmpeg's configure 71 # Needed for compiler test in ffmpeg's configure
67 mkdir -p tmp 72 mkdir -p tmp
68 73
74 sed -i 's/--enable-libsmbclient/${@bb.utils.contains("PACKAGECONFIG", "samba", "--enable-libsmbclient", "--disable-libsmbclient", d)}/g' Makefile.ffmpeg
75
69 oe_runmake -f Makefile.ffmpeg 76 oe_runmake -f Makefile.ffmpeg
70 oe_runmake -f Makefile.ffmpeg install 77 oe_runmake -f Makefile.ffmpeg install
71 oe_runmake 78 oe_runmake