summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2019-06-27 21:48:09 +0100
committerAndrei Gherzan <andrei@gherzan.ro>2019-07-20 21:56:21 +0100
commite9388ca16910051222c56115f7ef5ed8f70b9ee7 (patch)
tree842d9149c44d606c632c741a463258f6d9fc2cd2
parentb85775a16ac1ad61dd9f762b5fb57f8ab47df073 (diff)
downloadmeta-raspberrypi-e9388ca16910051222c56115f7ef5ed8f70b9ee7.tar.gz
linux-firmware-rpidistro: Fix WiFi on RaspberryPi 4
The official Raspbian with RPi4 support has an additional change for the NVRAM WiFi configuration: boardflags3 value is changed from "0x48200100" to "0x44200100". Without this change the interface never comes up. It is confusing because the deb changelog doesn't say anything about it and the repository upstream doesn't have this change. Asked for more info here: https://github.com/RPi-Distro/firmware-nonfree/issues/3 In the meanwhile we import this change. Also, we remove the .pc directory which confuses the patch step. Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
-rw-r--r--recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro/0001-brcmfmac43455-sdio.txt-Follow-raspbian-change-for-bo.patch39
-rw-r--r--recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb12
2 files changed, 50 insertions, 1 deletions
diff --git a/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro/0001-brcmfmac43455-sdio.txt-Follow-raspbian-change-for-bo.patch b/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro/0001-brcmfmac43455-sdio.txt-Follow-raspbian-change-for-bo.patch
new file mode 100644
index 0000000..1ad0fd1
--- /dev/null
+++ b/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro/0001-brcmfmac43455-sdio.txt-Follow-raspbian-change-for-bo.patch
@@ -0,0 +1,39 @@
1From c9d4f263131cb8e62597e0a296968b5cdbfe0019 Mon Sep 17 00:00:00 2001
2From: Andrei Gherzan <andrei@gherzan.ro>
3Date: Thu, 27 Jun 2019 20:49:10 +0100
4Subject: [PATCH] brcmfmac43455-sdio.txt: Follow raspbian change for
5 boardflags3
6
7Without this change the WiFi interface on RPi4 never comes up. Also the
8upstream repository doesn't include this change. It is only (as far as I
9know) part of the raspberrypi deb repository with the following
10changelog:
11
12firmware-nonfree (1:20190114-1+rpt2) buster; urgency=medium
13 * Update brcmfmac43455-sdio.txt
14 - Update boardflags3
15 -- Serge Schneider <serge@raspberrypi.org> Thu, 18 Apr 2019 14:35:34
16+0100
17
18Upstream-status: Pending
19Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
20---
21 brcm/brcmfmac43455-sdio.txt | 2 +-
22 1 file changed, 1 insertion(+), 1 deletion(-)
23
24diff --git a/brcm/brcmfmac43455-sdio.txt b/brcm/brcmfmac43455-sdio.txt
25index 54d9321..6801286 100644
26--- a/brcm/brcmfmac43455-sdio.txt
27+++ b/brcm/brcmfmac43455-sdio.txt
28@@ -21,7 +21,7 @@ btc_mode=1
29 # bit1 for btcoex
30 boardflags=0x00480201
31 boardflags2=0x40800000
32-boardflags3=0x48200100
33+boardflags3=0x44200100
34 phycal_tempdelta=15
35 rxchain=1
36 txchain=1
37--
382.17.1
39
diff --git a/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb b/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
index 1f63c32..39ffbf5 100644
--- a/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
+++ b/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
@@ -33,7 +33,10 @@ LIC_FILES_CHKSUM = "\
33NO_GENERIC_LICENSE[Firmware-broadcom_bcm43xx-rpidistro] = "LICENCE.broadcom_bcm43xx" 33NO_GENERIC_LICENSE[Firmware-broadcom_bcm43xx-rpidistro] = "LICENCE.broadcom_bcm43xx"
34NO_GENERIC_LICENSE[WHENCE] = "WHENCE" 34NO_GENERIC_LICENSE[WHENCE] = "WHENCE"
35 35
36SRC_URI = "git://github.com/RPi-Distro/firmware-nonfree" 36SRC_URI = " \
37 git://github.com/RPi-Distro/firmware-nonfree \
38 file://0001-brcmfmac43455-sdio.txt-Follow-raspbian-change-for-bo.patch \
39 "
37SRCREV = "b518de45ced519e8f7a499f4778100173402ae43" 40SRCREV = "b518de45ced519e8f7a499f4778100173402ae43"
38PV = "0.0+git${SRCPV}" 41PV = "0.0+git${SRCPV}"
39 42
@@ -43,6 +46,13 @@ inherit allarch
43 46
44CLEANBROKEN = "1" 47CLEANBROKEN = "1"
45 48
49do_unpack_append() {
50 bb.build.exec_func('do_clean_pc', d)
51}
52do_clean_pc() {
53 rm -rf ${S}/.pc
54}
55
46do_compile() { 56do_compile() {
47 : 57 :
48} 58}