summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.com>2017-09-06 20:27:52 +0100
committerAndrei Gherzan <andrei@gherzan.com>2017-09-08 18:47:41 +0100
commitfa82321af29aabdf82a5cdf247fde372c41cec35 (patch)
treeca3c2800d120b0a03fa097db635a40ea55eb5bb0
parentd2acb3ffdae3143da383048e07cce9163f7864e8 (diff)
downloadmeta-raspberrypi-fa82321af29aabdf82a5cdf247fde372c41cec35.tar.gz
rpi-gpio: Update to 0.6.3
As well integrate with meta-oe bbclass pypi. Signed-off-by: Andrei Gherzan <andrei@gherzan.com>
-rw-r--r--recipes-devtools/python/rpi-gpio_0.6.2.bb21
-rw-r--r--recipes-devtools/python/rpi-gpio_0.6.3.bb14
2 files changed, 14 insertions, 21 deletions
diff --git a/recipes-devtools/python/rpi-gpio_0.6.2.bb b/recipes-devtools/python/rpi-gpio_0.6.2.bb
deleted file mode 100644
index 9c72168..0000000
--- a/recipes-devtools/python/rpi-gpio_0.6.2.bb
+++ /dev/null
@@ -1,21 +0,0 @@
1DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
2HOMEPAGE = "http://code.google.com/p/raspberry-gpio-python/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=9b95630a648966b142f1a0dcea001cb7"
6
7SRCNAME = "RPi.GPIO"
8
9SRC_URI = "\
10 http://pypi.python.org/packages/source/R/RPi.GPIO/${SRCNAME}-${PV}.tar.gz \
11 file://0001-Remove-nested-functions.patch \
12 "
13SRC_URI[md5sum] = "9db86fd5f3bae872de9dbb068ee0b096"
14SRC_URI[sha256sum] = "82acff0ef6bbe3cdf6f4dbdd73d96add5294bb94baf7f51c1d901861af3c2392"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit distutils
19
20COMPATIBLE_MACHINE = "^rpi$"
21
diff --git a/recipes-devtools/python/rpi-gpio_0.6.3.bb b/recipes-devtools/python/rpi-gpio_0.6.3.bb
new file mode 100644
index 0000000..d0ff00a
--- /dev/null
+++ b/recipes-devtools/python/rpi-gpio_0.6.3.bb
@@ -0,0 +1,14 @@
1DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
2HOMEPAGE = "http://code.google.com/p/raspberry-gpio-python/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=9b95630a648966b142f1a0dcea001cb7"
6
7PYPI_PACKAGE = "RPi.GPIO"
8inherit pypi distutils
9
10SRC_URI += "file://0001-Remove-nested-functions.patch"
11SRC_URI[md5sum] = "e4abe1cfb5eacebe53078032256eb837"
12SRC_URI[sha256sum] = "a5fc0eb5e401963b6c0a03650da6b42c4005f02d962b81241d96c98d0a578516"
13
14COMPATIBLE_MACHINE = "^rpi$"