summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2017-09-25 10:40:34 -0300
committerAndrei Gherzan <andrei@gherzan.com>2017-09-27 11:16:31 +0100
commite2432d3bb42e1d6c58f4665a8817e5b18e142a58 (patch)
treed5e5fd01994422da5a61b6f07c1b8d61c1231e89
parentf1e2bf782f5906f05dfe7c1a9260ce5b4744f5bc (diff)
downloadmeta-raspberrypi-e2432d3bb42e1d6c58f4665a8817e5b18e142a58.tar.gz
layer.conf: Add Dynamic Layer mechanism
This allow for bbappend files to be enabled when specific layers are included. Change-Id: Iecbcf0de85a64aad71605b60ecd3d9a2586fae85 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--conf/layer.conf9
1 files changed, 9 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index bea5a65..bbdce14 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -12,3 +12,12 @@ BBFILE_PRIORITY_raspberrypi = "9"
12# Additional license directories. 12# Additional license directories.
13LICENSE_PATH += "${LAYERDIR}/files/custom-licenses" 13LICENSE_PATH += "${LAYERDIR}/files/custom-licenses"
14 14
15# The dynamic-layers directory hosts the extensions and layer specific
16# modifications.
17#
18# The .bbappend and .bb files are included if the respective layer
19# collection is available.
20BBFILES += "${@' '.join('${LAYERDIR}/dynamic-layers/%s/recipes*/*/*.bbappend' % layer \
21 for layer in BBFILE_COLLECTIONS.split())}"
22BBFILES += "${@' '.join('${LAYERDIR}/dynamic-layers/%s/recipes*/*/*.bb' % layer \
23 for layer in BBFILE_COLLECTIONS.split())}"