summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-09-17 22:30:23 -0700
committerAndrei Gherzan <andrei@gherzan.com>2017-09-20 15:50:20 +0100
commitbb51049ebe761ac2806fa0fa492c586976632011 (patch)
treebf23b9606ad6ee151a703718fc3ef451be3390bc
parentd31377b81a9ca7e9e70f334da68c2bdb437380fe (diff)
downloadmeta-raspberrypi-bb51049ebe761ac2806fa0fa492c586976632011.tar.gz
raspberrypi3-64: Use vc4-fkms-v3d overlay for rpi64
Use correct overlay for enabled vc4 accelaration This enable 3D accelaration over dispmanx on vc4/rpi64 Enable audio over HDMI Disable overscan to avoid graphics glitches Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--conf/machine/raspberrypi3-64.conf1
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb14
2 files changed, 13 insertions, 2 deletions
diff --git a/conf/machine/raspberrypi3-64.conf b/conf/machine/raspberrypi3-64.conf
index e3d11f2..237684a 100644
--- a/conf/machine/raspberrypi3-64.conf
+++ b/conf/machine/raspberrypi3-64.conf
@@ -31,6 +31,7 @@ KERNEL_DEVICETREE = " \
31 overlays/pi3-disable-bt.dtbo \ 31 overlays/pi3-disable-bt.dtbo \
32 overlays/pi3-miniuart-bt.dtbo \ 32 overlays/pi3-miniuart-bt.dtbo \
33 overlays/vc4-kms-v3d.dtbo \ 33 overlays/vc4-kms-v3d.dtbo \
34 overlays/vc4-fkms-v3d.dtbo \
34 " 35 "
35 36
36SERIAL_CONSOLE ?= "115200 ttyS0" 37SERIAL_CONSOLE ?= "115200 ttyS0"
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index 38a1237..4353061 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -21,7 +21,8 @@ PITFT28r="${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "1", "0", d)}"
21PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}" 21PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}"
22 22
23VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" 23VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
24 24VC4DTBO_raspberrypi3-64 = "vc4-fkms-v3d"
25VC4DTBO ?= "vc4-kms-v3d"
25inherit deploy 26inherit deploy
26 27
27do_deploy() { 28do_deploy() {
@@ -114,7 +115,7 @@ do_deploy() {
114 # VC4 Graphics support 115 # VC4 Graphics support
115 if [ "${VC4GRAPHICS}" = "1" ]; then 116 if [ "${VC4GRAPHICS}" = "1" ]; then
116 echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 117 echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
117 echo "dtoverlay=vc4-kms-v3d,${VC4_CMA_SIZE}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt 118 echo "dtoverlay=${VC4DTBO},${VC4_CMA_SIZE}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
118 fi 119 fi
119 120
120 # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm) 121 # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
@@ -129,6 +130,15 @@ do_deploy() {
129} 130}
130 131
131do_deploy_append_raspberrypi3-64() { 132do_deploy_append_raspberrypi3-64() {
133 echo "# have a properly sized image" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
134 echo "disable_overscan=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
135
136 echo "# for sound over HDMI" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
137 echo "hdmi_drive=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
138
139 echo "# Enable audio (loads snd_bcm2835)" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
140 echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
141
132 # Device Tree support 142 # Device Tree support
133 echo "# Load correct Device Tree for Aarch64" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt 143 echo "# Load correct Device Tree for Aarch64" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
134 echo "device_tree=bcm2710-rpi-3-b.dtb" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt 144 echo "device_tree=bcm2710-rpi-3-b.dtb" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt