summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYusuke Mitsuki <mickey.happygolucky@gmail.com>2017-09-06 07:13:16 +0900
committerAndrei Gherzan <andrei@gherzan.com>2017-09-11 13:12:42 +0100
commit6abd752bd0dce56a4458377dcabfe7fe84843715 (patch)
treec555ed1d37484661edc32813337f30ef8d711087
parent91f59ae288d8ee6c37091952802e7924b97ecff5 (diff)
downloadmeta-raspberrypi-6abd752bd0dce56a4458377dcabfe7fe84843715.tar.gz
bluez5: add functions/variables to enabling bluetooth on another raspberrypi
functions/variables in this bbappend implemented for only raspberrypi3. But these must be able to used to enabling bluetooth on another raspberrypi that has bluetooth feature such as raspberrypi0-wifi. The simple solution is a duplicating these but it is not good ideas for maintainance. Add functions/variables follows to simplify to enabling bluetooth on another raspberrypi that has bluetooth. - BCM_BT_SOURCES - enable_bcm_bluetooth() - BCM_BT_FIRMWARE - BCM_BT_SERVICE Signed-off-by: Yusuke Mitsuki <mickey.happygolucky@gmail.com>
-rw-r--r--recipes-connectivity/bluez5/bluez5_%.bbappend18
1 files changed, 14 insertions, 4 deletions
diff --git a/recipes-connectivity/bluez5/bluez5_%.bbappend b/recipes-connectivity/bluez5/bluez5_%.bbappend
index 956d776..b2fbf22 100644
--- a/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ b/recipes-connectivity/bluez5/bluez5_%.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI_append_raspberrypi3 = " \ 3BCM_BT_SOURCES = " \
4 file://BCM43430A1.hcd \ 4 file://BCM43430A1.hcd \
5 file://0001-bcm43xx-Add-bcm43xx-3wire-variant.patch \ 5 file://0001-bcm43xx-Add-bcm43xx-3wire-variant.patch \
6 file://0002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch \ 6 file://0002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch \
@@ -9,7 +9,7 @@ SRC_URI_append_raspberrypi3 = " \
9 file://brcm43438.service \ 9 file://brcm43438.service \
10 " 10 "
11 11
12do_install_append_raspberrypi3() { 12enable_bcm_bluetooth() {
13 install -d ${D}/lib/firmware/brcm/ 13 install -d ${D}/lib/firmware/brcm/
14 install -m 0644 ${WORKDIR}/BCM43430A1.hcd ${D}/lib/firmware/brcm/BCM43430A1.hcd 14 install -m 0644 ${WORKDIR}/BCM43430A1.hcd ${D}/lib/firmware/brcm/BCM43430A1.hcd
15 15
@@ -19,8 +19,18 @@ do_install_append_raspberrypi3() {
19 fi 19 fi
20} 20}
21 21
22FILES_${PN}_append_raspberrypi3 = " \ 22BCM_BT_FIRMWARE = " \
23 /lib/firmware/brcm/BCM43430A1.hcd \ 23 /lib/firmware/brcm/BCM43430A1.hcd \
24 " 24 "
25 25
26SYSTEMD_SERVICE_${PN}_append_raspberrypi3 = " brcm43438.service" 26BCM_BT_SERVICE = " brcm43438.service"
27
28SRC_URI_append_raspberrypi3 = " ${BCM_BT_SOURCES}"
29
30do_install_append_raspberrypi3() {
31 enable_bcm_bluetooth
32}
33
34FILES_${PN}_append_raspberrypi3 = " ${BCM_BT_FIRMWARE}"
35
36SYSTEMD_SERVICE_${PN}_append_raspberrypi3 = " ${BCM_BT_SERVICE}"