summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Galbusera <gizero@gmail.com>2017-09-14 18:26:37 +0200
committerAndrei Gherzan <andrei@gherzan.com>2017-09-18 21:59:02 +0100
commit5a2b34e56c228a2fa768a2b3feeebc9f4600b7c4 (patch)
treedf428c1eecd3f6131b52c92707e111f79b4cc6a8
parenta120ece0e4a12c8f77b32b76078003d2542187f0 (diff)
downloadmeta-raspberrypi-5a2b34e56c228a2fa768a2b3feeebc9f4600b7c4.tar.gz
u-boot: drop now upstreamed patches
oe-core now provides v2017.09 of u-boot which already merged both patches introduced by commit 94e2929f746f7e49a7870f7ea889dcbed05296c7 so we can drop them from meta-raspberrypi. Signed-off-by: Andrea Galbusera <gizero@gmail.com>
-rw-r--r--recipes-bsp/u-boot/u-boot/0001-Revert-dm-arm-rpi-Drop-CONFIG_OF_EMBED.patch67
-rw-r--r--recipes-bsp/u-boot/u-boot/0002-rpi-Enable-USB-keyboard-support.patch71
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend7
3 files changed, 0 insertions, 145 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0001-Revert-dm-arm-rpi-Drop-CONFIG_OF_EMBED.patch b/recipes-bsp/u-boot/u-boot/0001-Revert-dm-arm-rpi-Drop-CONFIG_OF_EMBED.patch
deleted file mode 100644
index ffabe89..0000000
--- a/recipes-bsp/u-boot/u-boot/0001-Revert-dm-arm-rpi-Drop-CONFIG_OF_EMBED.patch
+++ /dev/null
@@ -1,67 +0,0 @@
1From 46035d84eb75d54e524d068c29a42c4f562f757a Mon Sep 17 00:00:00 2001
2From: Paul Barker <pbarker@toganlabs.com>
3Date: Wed, 2 Aug 2017 11:37:30 +0100
4Subject: [PATCH 1/2] Revert "dm: arm: rpi: Drop CONFIG_OF_EMBED"
5
6This reverts commit 25877d4e4c45451c5398aec3de50e0d5befe0e9f.
7
8Signed-off-by: Paul Barker <pbarker@toganlabs.com>
9Upstream-status: Pending
10---
11 configs/rpi_2_defconfig | 1 +
12 configs/rpi_3_32b_defconfig | 1 +
13 configs/rpi_3_defconfig | 1 +
14 configs/rpi_defconfig | 1 +
15 4 files changed, 4 insertions(+)
16
17diff --git a/configs/rpi_2_defconfig b/configs/rpi_2_defconfig
18index 862203f..6aa0532 100644
19--- a/configs/rpi_2_defconfig
20+++ b/configs/rpi_2_defconfig
21@@ -13,6 +13,7 @@ CONFIG_CMD_MMC=y
22 CONFIG_CMD_USB=y
23 # CONFIG_CMD_FPGA is not set
24 CONFIG_CMD_GPIO=y
25+CONFIG_OF_EMBED=y
26 CONFIG_DM_MMC=y
27 CONFIG_MMC_SDHCI=y
28 CONFIG_MMC_SDHCI_BCM2835=y
29diff --git a/configs/rpi_3_32b_defconfig b/configs/rpi_3_32b_defconfig
30index 95b1677..7396925 100644
31--- a/configs/rpi_3_32b_defconfig
32+++ b/configs/rpi_3_32b_defconfig
33@@ -14,6 +14,7 @@ CONFIG_CMD_MMC=y
34 CONFIG_CMD_USB=y
35 # CONFIG_CMD_FPGA is not set
36 CONFIG_CMD_GPIO=y
37+CONFIG_OF_EMBED=y
38 CONFIG_DM_MMC=y
39 CONFIG_MMC_SDHCI=y
40 CONFIG_MMC_SDHCI_BCM2835=y
41diff --git a/configs/rpi_3_defconfig b/configs/rpi_3_defconfig
42index f91b53d..1b1ee67 100644
43--- a/configs/rpi_3_defconfig
44+++ b/configs/rpi_3_defconfig
45@@ -14,6 +14,7 @@ CONFIG_CMD_MMC=y
46 CONFIG_CMD_USB=y
47 # CONFIG_CMD_FPGA is not set
48 CONFIG_CMD_GPIO=y
49+CONFIG_OF_EMBED=y
50 CONFIG_DM_MMC=y
51 CONFIG_MMC_SDHCI=y
52 CONFIG_MMC_SDHCI_BCM2835=y
53diff --git a/configs/rpi_defconfig b/configs/rpi_defconfig
54index e2d81ab..c7cf6e0 100644
55--- a/configs/rpi_defconfig
56+++ b/configs/rpi_defconfig
57@@ -13,6 +13,7 @@ CONFIG_CMD_MMC=y
58 CONFIG_CMD_USB=y
59 # CONFIG_CMD_FPGA is not set
60 CONFIG_CMD_GPIO=y
61+CONFIG_OF_EMBED=y
62 CONFIG_DM_MMC=y
63 CONFIG_MMC_SDHCI=y
64 CONFIG_MMC_SDHCI_BCM2835=y
65--
662.7.4
67
diff --git a/recipes-bsp/u-boot/u-boot/0002-rpi-Enable-USB-keyboard-support.patch b/recipes-bsp/u-boot/u-boot/0002-rpi-Enable-USB-keyboard-support.patch
deleted file mode 100644
index 675d7d9..0000000
--- a/recipes-bsp/u-boot/u-boot/0002-rpi-Enable-USB-keyboard-support.patch
+++ /dev/null
@@ -1,71 +0,0 @@
1From e4ddccdcf2360c104de502db140a2dbb90b63cfe Mon Sep 17 00:00:00 2001
2From: Simon Glass <sjg@chromium.org>
3Date: Thu, 24 Aug 2017 19:45:31 -0600
4Subject: [PATCH 2/2] rpi: Enable USB keyboard support
5
6This is currently disabled, so USB keyboards are not detected in U_Boot.
7Enable this option to fix that.
8
9Backported to v2017.07.
10
11Signed-off-by: Simon Glass <sjg@chromium.org>
12Signed-off-by: Paul Barker <pbarker@toganlabs.com>
13Upstream-status: Backport
14---
15 configs/rpi_2_defconfig | 1 +
16 configs/rpi_3_32b_defconfig | 1 +
17 configs/rpi_3_defconfig | 1 +
18 configs/rpi_defconfig | 1 +
19 4 files changed, 4 insertions(+)
20
21diff --git a/configs/rpi_2_defconfig b/configs/rpi_2_defconfig
22index 6aa0532..9851836 100644
23--- a/configs/rpi_2_defconfig
24+++ b/configs/rpi_2_defconfig
25@@ -22,6 +22,7 @@ CONFIG_USB=y
26 CONFIG_DM_USB=y
27 CONFIG_USB_STORAGE=y
28 CONFIG_USB_KEYBOARD=y
29+CONFIG_DM_KEYBOARD=y
30 CONFIG_DM_VIDEO=y
31 CONFIG_SYS_WHITE_ON_BLACK=y
32 CONFIG_CONSOLE_SCROLL_LINES=10
33diff --git a/configs/rpi_3_32b_defconfig b/configs/rpi_3_32b_defconfig
34index 7396925..c9bdcd7 100644
35--- a/configs/rpi_3_32b_defconfig
36+++ b/configs/rpi_3_32b_defconfig
37@@ -24,6 +24,7 @@ CONFIG_USB=y
38 CONFIG_DM_USB=y
39 CONFIG_USB_STORAGE=y
40 CONFIG_USB_KEYBOARD=y
41+CONFIG_DM_KEYBOARD=y
42 CONFIG_DM_VIDEO=y
43 CONFIG_SYS_WHITE_ON_BLACK=y
44 CONFIG_CONSOLE_SCROLL_LINES=10
45diff --git a/configs/rpi_3_defconfig b/configs/rpi_3_defconfig
46index 1b1ee67..e9c9806 100644
47--- a/configs/rpi_3_defconfig
48+++ b/configs/rpi_3_defconfig
49@@ -24,6 +24,7 @@ CONFIG_USB=y
50 CONFIG_DM_USB=y
51 CONFIG_USB_STORAGE=y
52 CONFIG_USB_KEYBOARD=y
53+CONFIG_DM_KEYBOARD=y
54 CONFIG_DM_VIDEO=y
55 CONFIG_SYS_WHITE_ON_BLACK=y
56 CONFIG_CONSOLE_SCROLL_LINES=10
57diff --git a/configs/rpi_defconfig b/configs/rpi_defconfig
58index c7cf6e0..59d8c58 100644
59--- a/configs/rpi_defconfig
60+++ b/configs/rpi_defconfig
61@@ -22,6 +22,7 @@ CONFIG_USB=y
62 CONFIG_DM_USB=y
63 CONFIG_USB_STORAGE=y
64 CONFIG_USB_KEYBOARD=y
65+CONFIG_DM_KEYBOARD=y
66 CONFIG_DM_VIDEO=y
67 CONFIG_SYS_WHITE_ON_BLACK=y
68 CONFIG_CONSOLE_SCROLL_LINES=10
69--
702.7.4
71
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index 8d0a531..3781666 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1,8 +1 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
2
3SRC_URI_append_rpi = " \
4 file://0001-Revert-dm-arm-rpi-Drop-CONFIG_OF_EMBED.patch \
5 file://0002-rpi-Enable-USB-keyboard-support.patch \
6 "
7
8RDEPENDS_${PN}_append_rpi = " rpi-u-boot-scr" RDEPENDS_${PN}_append_rpi = " rpi-u-boot-scr"