summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2017-09-08 09:52:29 +0000
committerAndrei Gherzan <andrei@gherzan.com>2017-09-24 20:39:35 +0100
commit49f1a945120ede2273c02388d54059b7eee57e5e (patch)
tree9ff00ff6ac4710e62f2be6496854c594e011785b
parente7bac0bed5797342ac52431cf9678981bfd8decf (diff)
downloadmeta-raspberrypi-49f1a945120ede2273c02388d54059b7eee57e5e.tar.gz
linux-raspberrypi: Move LOADADDR setting to inc file
There is no reason to continue supporting pre-4.8 series kernels so we can move the setting of LOADADDR to the common inc file. Signed-off-by: Paul Barker <pbarker@toganlabs.com>
-rw-r--r--recipes-kernel/linux/linux-raspberrypi-dev.bb5
-rw-r--r--recipes-kernel/linux/linux-raspberrypi.inc5
-rw-r--r--recipes-kernel/linux/linux-raspberrypi_4.9.bb5
3 files changed, 5 insertions, 10 deletions
diff --git a/recipes-kernel/linux/linux-raspberrypi-dev.bb b/recipes-kernel/linux/linux-raspberrypi-dev.bb
index 05a7ea2..0fecccb 100644
--- a/recipes-kernel/linux/linux-raspberrypi-dev.bb
+++ b/recipes-kernel/linux/linux-raspberrypi-dev.bb
@@ -16,11 +16,6 @@ SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=${LINUX_RP
16" 16"
17require linux-raspberrypi.inc 17require linux-raspberrypi.inc
18 18
19# A LOADADDR is needed when building a uImage format kernel. This value is not
20# set by default in rpi-4.8.y and later branches so we need to provide it
21# manually. This value unused if KERNEL_IMAGETYPE is not uImage.
22KERNEL_EXTRA_ARGS += "LOADADDR=0x00008000"
23
24# Disable version check so that we don't have to edit this recipe every time 19# Disable version check so that we don't have to edit this recipe every time
25# upstream bumps the version 20# upstream bumps the version
26KERNEL_VERSION_SANITY_SKIP = "1" 21KERNEL_VERSION_SANITY_SKIP = "1"
diff --git a/recipes-kernel/linux/linux-raspberrypi.inc b/recipes-kernel/linux/linux-raspberrypi.inc
index 9f401d0..37cf0bb 100644
--- a/recipes-kernel/linux/linux-raspberrypi.inc
+++ b/recipes-kernel/linux/linux-raspberrypi.inc
@@ -41,6 +41,11 @@ KERNEL_INITRAMFS ?= '${@base_conditional("INITRAMFS_IMAGE_BUNDLE", "1", "1", "",
41 41
42KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "stmpe-ts", "", d)}" 42KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "stmpe-ts", "", d)}"
43 43
44# A LOADADDR is needed when building a uImage format kernel. This value is not
45# set by default in rpi-4.8.y and later branches so we need to provide it
46# manually. This value unused if KERNEL_IMAGETYPE is not uImage.
47KERNEL_EXTRA_ARGS += "LOADADDR=0x00008000"
48
44# Set a variable in .configure 49# Set a variable in .configure
45# $1 - Configure variable to be set 50# $1 - Configure variable to be set
46# $2 - value [n/y/value] 51# $2 - value [n/y/value]
diff --git a/recipes-kernel/linux/linux-raspberrypi_4.9.bb b/recipes-kernel/linux/linux-raspberrypi_4.9.bb
index 068965f..dd9afe2 100644
--- a/recipes-kernel/linux/linux-raspberrypi_4.9.bb
+++ b/recipes-kernel/linux/linux-raspberrypi_4.9.bb
@@ -6,8 +6,3 @@ SRCREV = "46e2d4d1bd2c17e2f84dd90768321ee0bbaa6b8a"
6SRC_URI = "git://github.com/raspberrypi/linux.git;branch=rpi-4.9.y" 6SRC_URI = "git://github.com/raspberrypi/linux.git;branch=rpi-4.9.y"
7 7
8require linux-raspberrypi.inc 8require linux-raspberrypi.inc
9
10# A LOADADDR is needed when building a uImage format kernel. This value is not
11# set by default in rpi-4.8.y and later branches so we need to provide it
12# manually. This value unused if KERNEL_IMAGETYPE is not uImage.
13KERNEL_EXTRA_ARGS += "LOADADDR=0x00008000"