summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Galbusera <gizero@gmail.com>2017-07-14 10:44:40 +0200
committerAndrei Gherzan <andrei@gherzan.com>2017-07-14 14:35:59 +0100
commit1e1b50c55dd5d1eba5e6fda17f9176127ee6ac5d (patch)
treec5a4fae08897e46521595d3e4bd798f663ea03c2
parent4cff21e24384cf7f1e7d47e430d4254723cd25e2 (diff)
downloadmeta-raspberrypi-1e1b50c55dd5d1eba5e6fda17f9176127ee6ac5d.tar.gz
userland: Add missing EGL_CAST defines
Needed by libepoxy Signed-off-by: Andrea Galbusera <gizero@gmail.com>
-rw-r--r--recipes-graphics/userland/userland/0015-EGL-glplatform.h-define-EGL_CAST.patch32
-rw-r--r--recipes-graphics/userland/userland_git.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-graphics/userland/userland/0015-EGL-glplatform.h-define-EGL_CAST.patch b/recipes-graphics/userland/userland/0015-EGL-glplatform.h-define-EGL_CAST.patch
new file mode 100644
index 0000000..5a80a26
--- /dev/null
+++ b/recipes-graphics/userland/userland/0015-EGL-glplatform.h-define-EGL_CAST.patch
@@ -0,0 +1,32 @@
1From 382e3b16cbcc09d825540d5bd3e45a2fca4484fe Mon Sep 17 00:00:00 2001
2From: Andrea Galbusera <gizero@gmail.com>
3Date: Fri, 14 Jul 2017 09:52:54 +0200
4Subject: [PATCH] EGL/glplatform.h: define EGL_CAST
5
6C++ / C typecast macros for special EGL handle values: used by libepoxy code
7The definition comes from the updated version of this header in mesa.
8
9Upstream-Status: Pending
10---
11 interface/khronos/include/EGL/eglplatform.h | 7 +++++++
12 1 file changed, 7 insertions(+)
13
14diff --git a/interface/khronos/include/EGL/eglplatform.h b/interface/khronos/include/EGL/eglplatform.h
15index 1f7c930..c39d425 100644
16--- a/interface/khronos/include/EGL/eglplatform.h
17+++ b/interface/khronos/include/EGL/eglplatform.h
18@@ -202,4 +202,11 @@ EGLAPI void EGLAPIENTRY BEGL_GetDefaultDriverInterfaces(BEGL_DriverInterfaces *i
19 #include "interface/khronos/common/khrn_client_mangle.h"
20 #endif
21
22+/* C++ / C typecast macros for special EGL handle values */
23+#if defined(__cplusplus)
24+#define EGL_CAST(type, value) (static_cast<type>(value))
25+#else
26+#define EGL_CAST(type, value) ((type) (value))
27+#endif
28+
29 #endif /* __eglplatform_h */
30--
312.7.4
32
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index 26bbfaf..893fcba 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -34,6 +34,7 @@ SRC_URI = "\
34 file://0012-implement-buffer-wrapping-interface-for-dispmanx.patch \ 34 file://0012-implement-buffer-wrapping-interface-for-dispmanx.patch \
35 file://0013-Implement-triple-buffering-for-wayland.patch \ 35 file://0013-Implement-triple-buffering-for-wayland.patch \
36 file://0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch \ 36 file://0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch \
37 file://0015-EGL-glplatform.h-define-EGL_CAST.patch \
37" 38"
38S = "${WORKDIR}/git" 39S = "${WORKDIR}/git"
39 40