summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2017-08-13 09:25:55 +0100
committerGitHub <noreply@github.com>2017-08-13 09:25:54 +0100
commit1b589998f4e96a0d1576de42f1927d69482c9cb4 (patch)
treef29088edd609ad4eaf034a015add154a09224b8a
parentf6a2ca21c72b8d97cd0f89a0a436bf90b431698b (diff)
parentff02bf92e66a9997576923b4622cdcf740352724 (diff)
downloadmeta-raspberrypi-1b589998f4e96a0d1576de42f1927d69482c9cb4.tar.gz
Merge pull request #102 from shr-project/jansa/master
Fixes for bitbake world
-rw-r--r--recipes-bsp/bootfiles/bcm2835-bootfiles.bb2
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb2
-rw-r--r--recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb2
-rw-r--r--recipes-core/images/rpi-test-image.bb2
-rw-r--r--recipes-core/packagegroups/packagegroup-rpi-test.bb7
-rw-r--r--recipes-devtools/bcm2835/bcm2835_1.52.bb2
-rw-r--r--recipes-devtools/pi-blaster/pi-blaster.inc2
-rw-r--r--recipes-devtools/python/rpi-gpio_0.6.2.bb2
-rw-r--r--recipes-devtools/python/rpio_0.10.0.bb2
-rw-r--r--recipes-devtools/wiringPi/wiringpi_git.bb2
-rw-r--r--recipes-graphics/userland/userland_git.bb2
-rw-r--r--recipes-graphics/vc-graphics/vc-graphics.inc2
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend18
-rw-r--r--recipes-kernel/linux/linux-raspberrypi.inc2
14 files changed, 28 insertions, 21 deletions
diff --git a/recipes-bsp/bootfiles/bcm2835-bootfiles.bb b/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
index b279e15..a115037 100644
--- a/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
+++ b/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
@@ -9,7 +9,7 @@ include recipes-bsp/common/firmware.inc
9 9
10RDEPENDS_${PN} = "rpi-config" 10RDEPENDS_${PN} = "rpi-config"
11 11
12COMPATIBLE_MACHINE = "raspberrypi" 12COMPATIBLE_MACHINE = "^rpi$"
13 13
14S = "${RPIFW_S}/boot" 14S = "${RPIFW_S}/boot"
15 15
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index b3c5084..38a1237 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "Commented config.txt file for the Raspberry Pi. \
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7 7
8COMPATIBLE_MACHINE = "raspberrypi" 8COMPATIBLE_MACHINE = "^rpi$"
9 9
10SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f" 10SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f"
11SRC_URI = "git://github.com/Evilpaul/RPi-config.git;protocol=git;branch=master \ 11SRC_URI = "git://github.com/Evilpaul/RPi-config.git;protocol=git;branch=master \
diff --git a/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb b/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
index 4936dcf..c938c3b 100644
--- a/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
+++ b/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
@@ -1,7 +1,7 @@
1SUMMARY = "U-boot boot scripts for Raspberry Pi" 1SUMMARY = "U-boot boot scripts for Raspberry Pi"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4COMPATIBLE_MACHINE = "rpi" 4COMPATIBLE_MACHINE = "^rpi$"
5 5
6DEPENDS = "u-boot-mkimage-native" 6DEPENDS = "u-boot-mkimage-native"
7 7
diff --git a/recipes-core/images/rpi-test-image.bb b/recipes-core/images/rpi-test-image.bb
index b5602a6..c8dc436 100644
--- a/recipes-core/images/rpi-test-image.bb
+++ b/recipes-core/images/rpi-test-image.bb
@@ -1,4 +1,6 @@
1# Base this image on rpi-basic-image 1# Base this image on rpi-basic-image
2include rpi-basic-image.bb 2include rpi-basic-image.bb
3 3
4COMPATIBLE_MACHINE = "^rpi$"
5
4IMAGE_INSTALL_append = " packagegroup-rpi-test" 6IMAGE_INSTALL_append = " packagegroup-rpi-test"
diff --git a/recipes-core/packagegroups/packagegroup-rpi-test.bb b/recipes-core/packagegroups/packagegroup-rpi-test.bb
index 29e995e..029c18c 100644
--- a/recipes-core/packagegroups/packagegroup-rpi-test.bb
+++ b/recipes-core/packagegroups/packagegroup-rpi-test.bb
@@ -4,8 +4,13 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
4 4
5inherit packagegroup 5inherit packagegroup
6 6
7COMPATIBLE_MACHINE = "^rpi$"
8
9OMXPLAYER_rpi = "omxplayer"
10OMXPLAYER_rpi_aarch64 = ""
11
7RDEPENDS_${PN} = "\ 12RDEPENDS_${PN} = "\
8 omxplayer \ 13 ${OMXPLAYER} \
9 bcm2835-tests \ 14 bcm2835-tests \
10 wiringpi \ 15 wiringpi \
11 rpio \ 16 rpio \
diff --git a/recipes-devtools/bcm2835/bcm2835_1.52.bb b/recipes-devtools/bcm2835/bcm2835_1.52.bb
index 8e41c61..eef6afd 100644
--- a/recipes-devtools/bcm2835/bcm2835_1.52.bb
+++ b/recipes-devtools/bcm2835/bcm2835_1.52.bb
@@ -8,7 +8,7 @@ AUTHOR = "Mike McCauley (mikem@open.com.au)"
8LICENSE = "GPLv2" 8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10 10
11COMPATIBLE_MACHINE = "raspberrypi" 11COMPATIBLE_MACHINE = "^rpi$"
12 12
13SRC_URI = "http://www.airspayce.com/mikem/bcm2835/bcm2835-${PV}.tar.gz" 13SRC_URI = "http://www.airspayce.com/mikem/bcm2835/bcm2835-${PV}.tar.gz"
14 14
diff --git a/recipes-devtools/pi-blaster/pi-blaster.inc b/recipes-devtools/pi-blaster/pi-blaster.inc
index a548957..6ea4fa3 100644
--- a/recipes-devtools/pi-blaster/pi-blaster.inc
+++ b/recipes-devtools/pi-blaster/pi-blaster.inc
@@ -16,6 +16,6 @@ INITSCRIPT_PACKAGES = "${PN}"
16INITSCRIPT_NAME_${PN} = "${PN}.boot.sh" 16INITSCRIPT_NAME_${PN} = "${PN}.boot.sh"
17INITSCRIPT_PARAMS_${PN} = "defaults 15 85" 17INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
18 18
19COMPATIBLE_MACHINE = "raspberrypi" 19COMPATIBLE_MACHINE = "^rpi$"
20 20
21PACKAGE_ARCH = "${MACHINE_ARCH}" 21PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-devtools/python/rpi-gpio_0.6.2.bb b/recipes-devtools/python/rpi-gpio_0.6.2.bb
index a08ea98..9c72168 100644
--- a/recipes-devtools/python/rpi-gpio_0.6.2.bb
+++ b/recipes-devtools/python/rpi-gpio_0.6.2.bb
@@ -17,5 +17,5 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
17 17
18inherit distutils 18inherit distutils
19 19
20COMPATIBLE_MACHINE = "raspberrypi" 20COMPATIBLE_MACHINE = "^rpi$"
21 21
diff --git a/recipes-devtools/python/rpio_0.10.0.bb b/recipes-devtools/python/rpio_0.10.0.bb
index 1a6cee7..998fdb3 100644
--- a/recipes-devtools/python/rpio_0.10.0.bb
+++ b/recipes-devtools/python/rpio_0.10.0.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
14 14
15inherit setuptools 15inherit setuptools
16 16
17COMPATIBLE_MACHINE = "raspberrypi" 17COMPATIBLE_MACHINE = "^rpi$"
18 18
19RDEPENDS_${PN} = "\ 19RDEPENDS_${PN} = "\
20 python-logging \ 20 python-logging \
diff --git a/recipes-devtools/wiringPi/wiringpi_git.bb b/recipes-devtools/wiringPi/wiringpi_git.bb
index 7953a55..f1b01db 100644
--- a/recipes-devtools/wiringPi/wiringpi_git.bb
+++ b/recipes-devtools/wiringPi/wiringpi_git.bb
@@ -13,7 +13,7 @@ SRC_URI = "git://git.drogon.net/wiringPi \
13 file://0001-Add-initial-cross-compile-support.patch \ 13 file://0001-Add-initial-cross-compile-support.patch \
14 " 14 "
15 15
16COMPATIBLE_MACHINE = "raspberrypi" 16COMPATIBLE_MACHINE = "^rpi$"
17 17
18CFLAGS_prepend = "-I${S}/wiringPi -I${S}/devLib " 18CFLAGS_prepend = "-I${S}/wiringPi -I${S}/devLib "
19 19
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index 893fcba..8ff1411 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -12,7 +12,7 @@ PROVIDES = "virtual/libgles2 \
12 12
13RPROVIDES_${PN} += "libgles2 egl" 13RPROVIDES_${PN} += "libgles2 egl"
14 14
15COMPATIBLE_MACHINE = "raspberrypi" 15COMPATIBLE_MACHINE = "^rpi$"
16 16
17SRCBRANCH = "master" 17SRCBRANCH = "master"
18SRCFORK = "raspberrypi" 18SRCFORK = "raspberrypi"
diff --git a/recipes-graphics/vc-graphics/vc-graphics.inc b/recipes-graphics/vc-graphics/vc-graphics.inc
index a1c8d29..668c5ce 100644
--- a/recipes-graphics/vc-graphics/vc-graphics.inc
+++ b/recipes-graphics/vc-graphics/vc-graphics.inc
@@ -4,7 +4,7 @@ LICENSE = "Proprietary"
4LIC_FILES_CHKSUM = "file://LICENCE;md5=86e53f5f5909ee66900418028de11780" 4LIC_FILES_CHKSUM = "file://LICENCE;md5=86e53f5f5909ee66900418028de11780"
5 5
6PROVIDES = "virtual/libgles2 virtual/egl" 6PROVIDES = "virtual/libgles2 virtual/egl"
7COMPATIBLE_MACHINE = "raspberrypi" 7COMPATIBLE_MACHINE = "^rpi$"
8 8
9include recipes-bsp/common/firmware.inc 9include recipes-bsp/common/firmware.inc
10 10
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index f2cb7aa..1dac41c 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -1,12 +1,12 @@
1EXTRA_OECONF_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' --enable-rpi-compositor WESTON_NATIVE_BACKEND=rpi-backend.so', d)}"
2
3PACKAGECONFIG_remove_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', 'fbdev', '', d)}" 1PACKAGECONFIG_remove_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', 'fbdev', '', d)}"
4 2
5EXTRA_OECONF += "--disable-xwayland-test \ 3EXTRA_OECONF_append_rpi = " \
6 --disable-simple-egl-clients \ 4 --disable-xwayland-test \
5 --disable-simple-egl-clients \
6 ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' \
7 --enable-rpi-compositor \
8 --disable-resize-optimization \
9 --disable-setuid-install \
10 WESTON_NATIVE_BACKEND=rpi-backend.so \
11 ', d)} \
7" 12"
8
9EXTRA_OECONF += "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', '--enable-rpi-compositor', d)}"
10EXTRA_OECONF += "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', '--disable-resize-optimization', d)}"
11EXTRA_OECONF += "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', '--disable-setuid-install', d)}"
12EXTRA_OECONF += "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'WESTON_NATIVE_BACKEND=rpi-backend.so', d)}"
diff --git a/recipes-kernel/linux/linux-raspberrypi.inc b/recipes-kernel/linux/linux-raspberrypi.inc
index 9265d55..4f5999d 100644
--- a/recipes-kernel/linux/linux-raspberrypi.inc
+++ b/recipes-kernel/linux/linux-raspberrypi.inc
@@ -10,7 +10,7 @@ SRC_URI += " \
10 file://defconfig \ 10 file://defconfig \
11 " 11 "
12 12
13COMPATIBLE_MACHINE = "raspberrypi" 13COMPATIBLE_MACHINE = "^rpi$"
14 14
15PE = "1" 15PE = "1"
16PV = "${LINUX_VERSION}+git${SRCPV}" 16PV = "${LINUX_VERSION}+git${SRCPV}"