summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2020-07-16 12:18:41 -0300
committerAndrei Gherzan <andrei@gherzan.ro>2020-08-05 21:20:06 +0100
commitfc494a35b513b05860c5a813239274017f1ef934 (patch)
treebd7fa0f0b058324e72283ebbcd45490cf44eca36
parent89ca43fe6411a40d1ba8f5379e49affd78cdd644 (diff)
downloadmeta-raspberrypi-fc494a35b513b05860c5a813239274017f1ef934.tar.gz
u-boot: Move fw_env.config to u-boot append
The u-boot-env is provided by u-boot recipe and not by libubootenv, so right recipe to append is the u-boot. Adding the rpi-u-boot-scr in DEPENDS variable is wrong because it is forcing rpi-u-boot-scr to be a dependency, but it'll fail if I have another recipe that provides bootscript, once both recipes provide the same file. The default value of u-boot-default-script is rpi-u-boot-scr, so right way is to use u-boot-default-script and change the PREFERRED_PROVIDER_u-boot-default-script if needed. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> (cherry picked from commit fc72c061411ea78515a670b63b0d44c13451cb78)
-rw-r--r--recipes-bsp/u-boot/libubootenv_%.bbappend12
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend8
2 files changed, 8 insertions, 12 deletions
diff --git a/recipes-bsp/u-boot/libubootenv_%.bbappend b/recipes-bsp/u-boot/libubootenv_%.bbappend
deleted file mode 100644
index 22d1bdc..0000000
--- a/recipes-bsp/u-boot/libubootenv_%.bbappend
+++ /dev/null
@@ -1,12 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append_rpi = " \
4 file://fw_env.config \
5"
6
7DEPENDS_append_rpi = " rpi-u-boot-scr"
8
9do_install_append_rpi () {
10 install -d ${D}${sysconfdir}
11 install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
12}
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index 40b4fc0..2442dfc 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1,5 +1,13 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI_append_rpi = " \
4 file://fw_env.config \
5"
6
3DEPENDS_append_rpi = " u-boot-default-script" 7DEPENDS_append_rpi = " u-boot-default-script"
4 8
5SRC_URI_append_raspberrypi-cm3 = " file://0001-dm-core-Move-ofdata_to_platdata-call-earlier.patch" 9SRC_URI_append_raspberrypi-cm3 = " file://0001-dm-core-Move-ofdata_to_platdata-call-earlier.patch"
10do_install_append_rpi () {
11 install -d ${D}${sysconfdir}
12 install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
13}