summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2020-08-06 11:59:33 +0100
committerAndrei Gherzan <andrei@gherzan.ro>2020-08-10 11:10:11 +0100
commitcf1398262577e46a497fc845227ce09c6f71e748 (patch)
tree3f14fddd612e82bdc59a048c65ebaa04a337fb66
parent4869bb1b9565d10a12e46fd0c306c15e2e0bafeb (diff)
downloadmeta-raspberrypi-cf1398262577e46a497fc845227ce09c6f71e748.tar.gz
Revert "u-boot: Move fw_env.config to u-boot append"
This reverts commit fc494a35b513b05860c5a813239274017f1ef934.
-rw-r--r--recipes-bsp/u-boot/libubootenv_%.bbappend12
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend8
2 files changed, 12 insertions, 8 deletions
diff --git a/recipes-bsp/u-boot/libubootenv_%.bbappend b/recipes-bsp/u-boot/libubootenv_%.bbappend
new file mode 100644
index 0000000..22d1bdc
--- /dev/null
+++ b/recipes-bsp/u-boot/libubootenv_%.bbappend
@@ -0,0 +1,12 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append_rpi = " \
4 file://fw_env.config \
5"
6
7DEPENDS_append_rpi = " rpi-u-boot-scr"
8
9do_install_append_rpi () {
10 install -d ${D}${sysconfdir}
11 install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
12}
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index 2442dfc..40b4fc0 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1,13 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI_append_rpi = " \
4 file://fw_env.config \
5"
6
7DEPENDS_append_rpi = " u-boot-default-script" 3DEPENDS_append_rpi = " u-boot-default-script"
8 4
9SRC_URI_append_raspberrypi-cm3 = " file://0001-dm-core-Move-ofdata_to_platdata-call-earlier.patch" 5SRC_URI_append_raspberrypi-cm3 = " file://0001-dm-core-Move-ofdata_to_platdata-call-earlier.patch"
10do_install_append_rpi () {
11 install -d ${D}${sysconfdir}
12 install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
13}